summaryrefslogtreecommitdiff
path: root/games-simulation
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/Manifest.gzbin3753 -> 3750 bytes
-rw-r--r--games-simulation/corsix-th/Manifest2
-rw-r--r--games-simulation/corsix-th/corsix-th-0.65.1.ebuild82
-rw-r--r--games-simulation/gl117/Manifest5
-rw-r--r--games-simulation/gl117/files/gl117-1.3.2-mode.patch5
-rw-r--r--games-simulation/gl117/gl117-1.3.2-r1.ebuild38
-rw-r--r--games-simulation/lincity-ng/Manifest5
-rw-r--r--games-simulation/lincity-ng/files/lincity-ng-2.9_beta-flags.patch10
-rw-r--r--games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild54
-rw-r--r--games-simulation/lincity-ng/metadata.xml1
-rw-r--r--games-simulation/lincity/Manifest7
-rw-r--r--games-simulation/lincity/files/lincity-1.13.1-build.patch38
-rw-r--r--games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch37
-rw-r--r--games-simulation/lincity/lincity-1.13.1-r1.ebuild53
-rw-r--r--games-simulation/lincity/lincity-1.13.1-r2.ebuild60
15 files changed, 255 insertions, 142 deletions
diff --git a/games-simulation/Manifest.gz b/games-simulation/Manifest.gz
index 0ca0bff368d9..9a0ea1885579 100644
--- a/games-simulation/Manifest.gz
+++ b/games-simulation/Manifest.gz
Binary files differ
diff --git a/games-simulation/corsix-th/Manifest b/games-simulation/corsix-th/Manifest
index 0fa1e3c2b8b3..4f15b98db28b 100644
--- a/games-simulation/corsix-th/Manifest
+++ b/games-simulation/corsix-th/Manifest
@@ -1,4 +1,6 @@
AUX corsix-th-0.64-cmake_lua_detection.patch 288 BLAKE2B 90673498871c16f48c752c5581dfec0a290966ef0ec79c977b69575b26a22843829679a7c0225caabe2b570b9b6a38e025115f3a2cf0597b0dad9dc78f01f36d SHA512 52dc61c7aa8c170da225801f2eb06140e9dc28c4d55853eac99b573475a21fb03b945de676898719927abd517b34ecce2aa5c4998ac6e6fcc673cf2aaf7cdb9e
DIST corsix-th-0.64.tar.gz 4062048 BLAKE2B 2b807a5c712a19cac80bae613065dd8c9e1219573a3c288c1433b6fa857c3a93632e9c51ba126a70626b4044d469ca1ebc815257f291fa9f86ea94491aae35fe SHA512 c02d07ae4fb9a1ce008f32c4b9ea12a949316feddca4e2a29e860e0d88efdfa0440d372b00b9d3eda5e5c3ca739085510ebe8650790d06a7e91255b7d0990e6c
+DIST corsix-th-0.65.1.tar.gz 4163922 BLAKE2B c1d9255e41521876716b377579642ed46b9fc54823816dc431f7b56ffa532af7091ae0b1e291bb1c4fb74165ca07786e0991a990c90bc3a13e234ba31c6fa706 SHA512 b7e964c22517b94cb1dafb0529368c87a2e58cf1f784062b9f2f72749ba69523b63d4f846ebd582c71cf5ca7e7c437a34717ca3877ad3737139ba2fd6a316577
EBUILD corsix-th-0.64-r100.ebuild 1952 BLAKE2B 02649e3c0f2de55cb02e036e330080f36aa07dd4e170ac18ea391adbaf041e3cac9d02abee22541442ec5c4dc0649f881b558c18f4af4f488b4525a823682486 SHA512 8e0708ae6c2fc61a59c3951a556e9ce38ae24c24903cc282e4712f47f5f44892e34c02ff52134be5136c6e5809cfc0bd9796ae550826bdda69ae683f7480d22f
+EBUILD corsix-th-0.65.1.ebuild 1923 BLAKE2B a7a1da03327d47ae76baca6f6db3d31595d4797209e9fcd63456e391071bf6ce930ac5b920addc0110825345cd24415133f5cb4bc33a82644ef648d0037bb834 SHA512 a16e7f70f62a92ffcca948d6c6c74a33b2d8e3b8b3cd38de95daf378dccb16852e8012a2a607f9eef9ca94cd00ec4f60f3607b8b63c691118eaec52d447beba6
MISC metadata.xml 716 BLAKE2B 16fe66f9f3fce58b6b17df3906fdcf4e9b7a9a49be872ba69cd5deeb47bffca495ff3a8b8c89fc71cbe8b3960954a462aff8c10c6afd34c18acef95931c382f8 SHA512 643ef59451c07fd3e61b22fb9891cc2478dff78c1e2a50ed455b15bf1c01e49d384af177c687e48b2bd6590278ac121458a94760a25bdc064ce309ff5ab3b868
diff --git a/games-simulation/corsix-th/corsix-th-0.65.1.ebuild b/games-simulation/corsix-th/corsix-th-0.65.1.ebuild
new file mode 100644
index 000000000000..96f236c3d3d4
--- /dev/null
+++ b/games-simulation/corsix-th/corsix-th-0.65.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit cmake lua-single xdg
+
+MY_PN="CorsixTH"
+
+DESCRIPTION="Open source clone of Theme Hospital"
+HOMEPAGE="https://corsixth.com"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc +midi +sound +truetype +videos"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}
+ $(lua_gen_cond_dep '
+ >=dev-lua/luafilesystem-1.5[${LUA_USEDEP}]
+ >=dev-lua/lpeg-0.9[${LUA_USEDEP}]
+ >=dev-lua/luasocket-3.0_rc1-r4[${LUA_USEDEP}]
+ ')
+ media-libs/libsdl2[opengl,video]
+ sound? ( media-libs/sdl2-mixer[midi?] )
+ truetype? ( >=media-libs/freetype-2.5.3:2 )
+ videos? ( >=media-video/ffmpeg-2.2.3:0= )
+"
+
+DEPEND="${RDEPEND}"
+
+# Technically, build-time generation of documentation could use any version
+# of Lua (or to be precise: if in src_configure cmake has been told to use
+# LuaJIT documentation generation looks for LuaJIT, otherwise any
+# dev-lang/lua slot will do; see the first few lines of the bundled file
+# CMake/GenerateDoc.cmake for details) - but since dev-lang/lua conflicts
+# with the other slots of same, try to keep the deptree sane until we get
+# rid of unslotted Lua.
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ ${LUA_DEPS}
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.64-cmake_lua_detection.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLUA_VERSION=$(lua_get_version)
+ -DWITH_AUDIO=$(usex sound)
+ -DWITH_FREETYPE2=$(usex truetype)
+ -DWITH_MOVIES=$(usex videos)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+ dodoc {changelog,CONTRIBUTING}.txt
+
+ docinto html
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
+}
diff --git a/games-simulation/gl117/Manifest b/games-simulation/gl117/Manifest
index 1a6914d62f08..4c2c3a1d9d12 100644
--- a/games-simulation/gl117/Manifest
+++ b/games-simulation/gl117/Manifest
@@ -1,4 +1,5 @@
-AUX gl117-1.3.2-mode.patch 394 BLAKE2B ee932b73f82100910bea6466edeb4a8a0d5782ac64baac4b64872cb95b3018391bd66550c5a2ff7575aff7449aa01e856769aabd0e4f9ef51bed71c4de7349e6 SHA512 b6bdfa938f19481dff3f4d275826f1308aea99c1a2fc78df6f2b49096ecabce6c476cbf7de64afd0ac0903ea0ac3b5d84e43a876ae333bd0db20b39a0085ca11
+AUX gl117-1.3.2-mode.patch 353 BLAKE2B c162beb97aff2708d3e74e215a729ed7b6f6b40ac971f5387b65d31eaf9abd15b9bc13794518ce2d079f55092ebc49adcc78dc7418ef15579984cc622cfc0abb SHA512 693f11b8a6db7aad431421b58deaff843e24319830efd8cb44c046e7e2b7ec830a29d08bad3f4ba33bdc8a71e58aebea7fb9de28c6a52bf1ee3c4223bf2413a5
DIST gl-117-1.3.2-src.tar.bz2 2411075 BLAKE2B efd2c7b9dd3f71bf0b8b1aac79f90dcc6286301997913346f8ee536b3f5981564438e6a805c658678b5ae0402f84da762b60472ddc553cab49f9ffb421d69993 SHA512 1d2382576c6399d8c84d56ddc7eb2b11b9e1e3ffeebcc1bd30e258ef231626d15d1be649f8c791f30e4f2f78aca2b4290c5d08036c5f482eef01eda8f4f48b5f
-EBUILD gl117-1.3.2-r1.ebuild 790 BLAKE2B 9e0539a943ce93f7db7bb0481a6c9baf4cf0642ff3fc13300a60e43825dfad17e3299d9fc8dd5644c35bb2af1c2595efbd19d8cdf5dec56b0637aa22c9fc2a96 SHA512 dfa801635069584401af3e9b7fed23ed79cd54217dfffe1a5f3666704d666a11fd470adfd437fe02d05e46179477981ab3b9128edacbc6663c635b069faa02f8
+DIST gl117.png 2274 BLAKE2B dfa2b8fe0e858e1f0fa1af27bd8e38d3bba55c31d4c26abe831cd08f01a9d198c2a38ec7c9c1c49af851da24cce692c489220624b93eae0ed4692139c73f8f7d SHA512 374b41af6cb5ec10e3b59b983f28206cb7bc88c3559a24332ef43bd4b135971c0541dbf6f3b5e97c7b7e329bc3d5bbfa5119b9be6cbec243193e5a4ac0220c3b
+EBUILD gl117-1.3.2-r1.ebuild 763 BLAKE2B bea26b402569d973ef86b1157d65a85fb85e2908035822f5ea99737225b0dc673d1fb505724760a9062f10cdb7e3b38fa2cb05235d5b55cb3e37bca6aea4da56 SHA512 87d472743d1ecb11c19bb127c73785e294e5c4d71822808bb2b2d83ce2c4fb00d365898a84263cf518c7be3dfdf68b8adadb645826471669f75912526581a179
MISC metadata.xml 329 BLAKE2B 69ad3f12c9a48f6cbb1094fb1952d75e5e317060ad8534cd95e1e94bf2e3bb824862ad2a050aa81f55970b0cb0d032197ae86b6336beb09835a9f6c56aba0a0f SHA512 a2756adb5a9afa30e93c7f7726706ed9b435f76631d268685f9fea734a4ef6e643a8f8fdae8f59cc979a1bfcb91e2778496828db50458d6adacd789b3b3763f9
diff --git a/games-simulation/gl117/files/gl117-1.3.2-mode.patch b/games-simulation/gl117/files/gl117-1.3.2-mode.patch
index d3f13084a96f..c63fdaa26074 100644
--- a/games-simulation/gl117/files/gl117-1.3.2-mode.patch
+++ b/games-simulation/gl117/files/gl117-1.3.2-mode.patch
@@ -1,5 +1,6 @@
---- a/src/main.cpp 2010-07-13 09:35:18.374122609 +0100
-+++ b/src/main.cpp 2010-07-13 09:35:45.334955120 +0100
+https://bugs.gentoo.org/327965
+--- a/src/main.cpp
++++ b/src/main.cpp
@@ -71,8 +71,7 @@ int mode = 0;
// pre-defined screen resolutions (x, y, bpp, fullscreen)
diff --git a/games-simulation/gl117/gl117-1.3.2-r1.ebuild b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
index f5c52f6068ab..8f27db3990a6 100644
--- a/games-simulation/gl117/gl117-1.3.2-r1.ebuild
+++ b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
@@ -1,37 +1,41 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=8
+
+inherit desktop
MY_P="gl-117-${PV}-src"
-DESCRIPTION="An action flight simulator"
-HOMEPAGE="http://www.heptargon.de/gl-117/gl-117.html"
-SRC_URI="mirror://sourceforge/gl-117/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
+DESCRIPTION="Action flight simulator"
+HOMEPAGE="https://sourceforge.net/projects/gl-117/"
+SRC_URI="
+ mirror://sourceforge/gl-117/${MY_P}.tar.bz2
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="
+RDEPEND="
media-libs/freeglut
- media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/libsdl[joystick,opengl,sound,video]
media-libs/sdl-mixer[mod]
virtual/glu
virtual/opengl"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${MY_P}
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-mode.patch
)
src_install() {
- DOCS="doc/gl-117.pdf AUTHORS ChangeLog FAQ NEWS README" \
- default
- newicon doc/src/falcon.jpg ${PN}.jpg
- make_desktop_entry gl-117 GL-117 /usr/share/pixmaps/${PN}.jpg
+ default
+
doman doc/gl-117.6
+ dodoc doc/gl-117.pdf
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry gl-117 GL-117
}
diff --git a/games-simulation/lincity-ng/Manifest b/games-simulation/lincity-ng/Manifest
index 4c7f25ad1079..ff3b8facf44b 100644
--- a/games-simulation/lincity-ng/Manifest
+++ b/games-simulation/lincity-ng/Manifest
@@ -1,3 +1,4 @@
+AUX lincity-ng-2.9_beta-flags.patch 235 BLAKE2B 262c4080bae5d88197cd6ff3ac20dd8740127504aefc5c947aef330ddfef6af6f0a423ec888e810398e2a5c5d3f5a2bab0ea6de9376b9be02187be5c61620ef3 SHA512 be56ba3aea08e425741c4ccb1cd87a23a595b5b974cdeb52e0e91b1b8579588bfee3b6052ab9728fbec41aa312107cabec19e1d7c27680d2c979351e5d8394ca
DIST lincity-ng-2.9_beta.tar.gz 115799513 BLAKE2B 038c69172af9a62b35199823ef56200e170a8eafef2849bc6d8797bbc20ffa01656d05b1ba0725d4d33e217602f6695d3bdf2774b90b85c6e257e13e019bebcb SHA512 194b7389d7172b7987eda14cbbf2dd91aa503af36db9cf3bdf07ab6ae5e0068ac00988fec6068d65da6bdf14dee623bba57a58192e2a9659e741a7c9036e6d65
-EBUILD lincity-ng-2.9_beta.ebuild 1382 BLAKE2B ddca268df7af315fffe16c84ff7224356e3174abc7d634268199f11e9b15e70b84b578bc218196e5cf9ecdb266d1cc26819cc71f862c4cc88c2361c8ec71339b SHA512 f2c0cf3735e6f5e42a309ff20f85d3e31dc810c79258d27944f8f3803ef3bc4f637ba54d829dba2a2d3171bb597950a0c3f5b00bc710517db5dc95c67e4365cc
-MISC metadata.xml 341 BLAKE2B 971b9b371fbe6bbb577214a2fcb2f39948f4f8abe02398fd7f6e86d650434f778bc8e1556a6d08be49149da35f848e7e8a23e56034626823704872e88ada99e5 SHA512 0c2607743dbc1b832fad2d9edf774b51c9e816cca447c5991cd3958f001fded11bfd0fd0b90316ddab7c3371b0ec98d6f4ada27054e5d74e3295cf2cd1beeb90
+EBUILD lincity-ng-2.9_beta.ebuild 1469 BLAKE2B 9533955630a368f8ac4373d357c95592eb11feb5db57e210f4910e9454af36275f6490ca40b5186edc1840f6ffc0bf10daad9bc5d76b3c78655f84ac8496de20 SHA512 76757c1dd3e8d5d5d1dfc5b3c781b90cff96e1204f3acb18b7bfe915c40bba1b0e4be672b99b5a0e07540f67d4cc34ebd261a30b8462ce8dce0bb4d5989230b6
+MISC metadata.xml 402 BLAKE2B bb9f0732f1f4d82689c556ea23ef87b93da2802b533f4aabec8f1e9d44eb2e6fe7d3740ff3bacc87983f240c651715f61356026d1e9c1de8ae7462ffcee48c8f SHA512 53b57dcf1dc3843d7a6d1f4425f357273e287e010c975f12e9bd178bec3ff415560ca3d391edbf3d7873dad8cef7d54132bc78a59caf4d0f5e50e879d71eb118
diff --git a/games-simulation/lincity-ng/files/lincity-ng-2.9_beta-flags.patch b/games-simulation/lincity-ng/files/lincity-ng-2.9_beta-flags.patch
new file mode 100644
index 000000000000..1c960123c216
--- /dev/null
+++ b/games-simulation/lincity-ng/files/lincity-ng-2.9_beta-flags.patch
@@ -0,0 +1,10 @@
+--- a/Jamrules
++++ b/Jamrules
+@@ -23,5 +23,4 @@
+ case optimize :
+- CFLAGS += -O3 -g -Wall ;
+- CXXFLAGS += -O3 -g -Wall ;
+- LIBS += -g ;
++ CFLAGS += -Wall ;
++ CXXFLAGS += -Wall ;
+ case debug :
diff --git a/games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild b/games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild
index c49cae5849f8..793d68044eab 100644
--- a/games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild
+++ b/games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild
@@ -1,22 +1,23 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools libtool multiprocessing toolchain-funcs
+inherit autotools multiprocessing toolchain-funcs
DESCRIPTION="City simulation game"
HOMEPAGE="https://github.com/lincity-ng/lincity-ng"
SRC_URI="https://github.com/lincity-ng/lincity-ng/archive/lincity-ng-${PV/_/-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P/_/-}"
-LICENSE="GPL-2 BitstreamVera CC-BY-SA-2.0"
+LICENSE="GPL-2+ BitstreamVera CC-BY-SA-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="dev-games/physfs
+RDEPEND="
+ dev-games/physfs
dev-libs/libxml2:2
- media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/libsdl[joystick,opengl,sound,video]
media-libs/sdl-gfx
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]
@@ -24,35 +25,38 @@ RDEPEND="dev-games/physfs
sys-libs/zlib
virtual/opengl"
DEPEND="${RDEPEND}"
-BDEPEND="dev-util/ftjam
+BDEPEND="
+ dev-libs/libxslt
+ dev-util/ftjam
+ sys-devel/gettext
virtual/pkgconfig"
-S="${WORKDIR}/${PN}-${P/_/-}"
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+)
src_prepare() {
default
- # Missing CREDITS files actually breaks the install.
- sed -i -r "s/\b(COPYING[^ ]*|CREDITS)\b//g" Jamfile || die
+ AT_M4DIR=mk/autoconf eautoreconf
+
+ # strip down autogen.sh / makerelease.sh for needed additional actions
+ sed -i -e '1a\set -e' -e '1n;/# generate Jam/,$!d;/^$/,$d' autogen.sh || die
+ sed -i -e '1a\set -e' -e '/^$/,$d' makerelease.sh || die
- # Can't use eautoreconf as it does weird jam stuff.
- autotools_run_tool ./autogen.sh
- elibtoolize
+ ./autogen.sh || die "Failed to generate Jamconfig.in"
+ ./makerelease.sh || die "Failed to generate CREDITS"
}
src_compile() {
- jam -q -dx \
- -j$(makeopts_jobs) \
- -sAR="$(tc-getAR) ru" \
- -sRANLIB="$(tc-getRANLIB)" \
- || die "jam failed"
+ tc-export CC RANLIB
+ export AR="$(tc-getAR) cru" #739376
+
+ jam -q -dx -j$(makeopts_jobs) || die
}
src_install() {
- jam -sDESTDIR="${D}" \
- -sappdocdir="${EPREFIX}/usr/share/doc/${PF}" \
- -sapplicationsdir="${EPREFIX}/usr/share/applications" \
- -spixmapsdir="${EPREFIX}/usr/share/pixmaps" \
- install \
- || die "jam install failed"
+ jam -q -dx -sDESTDIR="${D}" -sPACKAGE_VERSION=${PVR} install || die
+
+ rm "${ED}"/usr/share/doc/${PF}/COPYING* || die
}
diff --git a/games-simulation/lincity-ng/metadata.xml b/games-simulation/lincity-ng/metadata.xml
index 7dd75a46b634..af89c7a1eb31 100644
--- a/games-simulation/lincity-ng/metadata.xml
+++ b/games-simulation/lincity-ng/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Games Project</name>
</maintainer>
<upstream>
+ <remote-id type="github">lincity-ng/lincity-ng</remote-id>
<remote-id type="sourceforge">lincity-ng.berlios</remote-id>
</upstream>
</pkgmetadata>
diff --git a/games-simulation/lincity/Manifest b/games-simulation/lincity/Manifest
index 539a3b531e2f..afeb062be4f1 100644
--- a/games-simulation/lincity/Manifest
+++ b/games-simulation/lincity/Manifest
@@ -1,5 +1,6 @@
-AUX lincity-1.13.1-build.patch 2196 BLAKE2B 871577b9ac4b2536b9d46c094c6bd3492eb8e46188f2fc7d8efafa84d6e76914e60a579e30b1294e56daa96f8ab4a2b0247c0ddb5d0ce7d6d9e2180a7b0306cf SHA512 c0590673e7f04e16ffb6c9a25ce0f00d25dcaf689908117647e00989ed6db3a2c5d1db63abeb23e5c9a0f0999219515a53994ed4400f2712a8dea5b6eca5a8b3
-AUX lincity-1.13.1-gcc-10.patch 1552 BLAKE2B 7ead7d4f4ff699f20d4c06b3ac14cfae1ae234ba8f03ad7c9188fab3e38626c85767196f3dd1de7368b140d941c14485a77045a2f7775ea07bcdd00a5dccdd16 SHA512 c80aaa9b3d39fd7661c8b7d24f7e38e34389ba82520073ef6e24e6eaf8cd0e2394ade05f7fcc98d5b5597d2878b5465856fda509669871cf80ff2ac06d4734bb
+AUX lincity-1.13.1-build.patch 1476 BLAKE2B 941fca117f259915c0e55fd8febddb5c3b6b3d86e1eb9f332edbb76eb8c8361fc4e410d01a8526b73c694f059edf49e55c8f9e9635cea645f34c9fdbe3d0f819 SHA512 e2d014006e0425ab68c685b23febc27ae18500d0b62d00642964c1b37f77646143869f6fe199d34d6a5b931c7449ed0762b934f38e60f20d719bfc0a12d3ac28
+AUX lincity-1.13.1-gcc-10.patch 1540 BLAKE2B 9eb02f6f5820ddb6fdd0edbd25921f7f2a01595f1c1ac3d70e0683bd3fa625ee5a477e5df5d616eb334648ff01d8379970ecb72d272abadbd4867cac349cb0fa SHA512 433929f62f2dc425304bd34ccfdcbb92cbef17486c3628bb649d0c74e0fb68c5c5ab4219a2eb1028d197769ec02566db221c2e9666cfae84dc49e96f67e8d215
DIST lincity-1.13.1.tar.gz 1064236 BLAKE2B 1172ced3255048f3132f85cd9ae994c7e0558170f7e7a24909af1856669c4ad90d57acd76f330fb556656ed74843dda159005350760fc059c6b184cedf1e9393 SHA512 bc4ee7a1642b1efa25f9edaabd3aeb52d1ca1d016735c5094586f52fda3ec4e9080ff35fe518c1ccbfad9fd54babb370f4b9b6a158b4d2f43b7182155084eefc
-EBUILD lincity-1.13.1-r1.ebuild 976 BLAKE2B a8869f6a34959af3e537a327f186ed70c95d6d19d348e0ca0653337132cc27b64bb98e1399f8186d4735482825f04e7734852e307238e21a3bcf16f18bc8848e SHA512 bdcc7d91ed2c73fabea88eeb695c3f74b763119b91e2d1013794f276ceb84d3366c596d1627d9397279040d1bac22fc04d078ea2b0ca4073637322dec6a4c7e6
+DIST lincity.png 5377 BLAKE2B 2238140719a8c1b094fbe6d7b52b9224245f2c36f970e04aa3fcaf6090409145f17dad2c2a83f6528e695fd9d26d9c053c45978502b7e44f73cf25719d7ed3aa SHA512 40a8955fdc8397662ef0d084163e7dcad59e278429792bd7096e193a0d04791c2355a0dbd2c1f72a032bbfc71bc4e27e37a3d0d4e82de8e7170bb70205d983a3
+EBUILD lincity-1.13.1-r2.ebuild 989 BLAKE2B 6616dc088ae5d0b9712176727b1288719f81cb57db3a7910100a8b07f91133868b31ea1fc1d52571d97f2f91072ba4e6d6c9c875926bbe4bcca680c79a0d2e7e SHA512 80ce2dc386e4036ae2906c263ecb400940c85a02ab41c01243bc7fecd0e4f4c4920a9f6e71d581b032b01717212e2ed3fd45ada288c09e16d4195100a07defa4
MISC metadata.xml 330 BLAKE2B 27e534512b77895bcfea8da8f49e1fa4ce2c9a8df47cf0ce813a8a88893b3c69c03d25083412d22bea3d2d73dfe2baa6a26292b983409c28d6c40bd70e222f6f SHA512 c36fecc06a5c84b3a93dfd25ffeb05bb14a5a96676eb1d7e976903ef7892a10c22ee7afa894c581c0bc3079ce2e30574143cc6b49195b346463c48f3e34ff1c0
diff --git a/games-simulation/lincity/files/lincity-1.13.1-build.patch b/games-simulation/lincity/files/lincity-1.13.1-build.patch
index f7f41f954baf..a5244b5387f3 100644
--- a/games-simulation/lincity/files/lincity-1.13.1-build.patch
+++ b/games-simulation/lincity/files/lincity-1.13.1-build.patch
@@ -1,16 +1,5 @@
---- lincity-1.13.1.orig/intl/Makefile.in
-+++ lincity-1.13.1/intl/Makefile.in
-@@ -32,7 +32,7 @@
- libdir = @libdir@
- includedir = @includedir@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = /usr/share/locale
- gettextsrcdir = $(datadir)/gettext/intl
- aliaspath = $(localedir)
- subdir = intl
---- lincity-1.13.1.orig/mouse.c
-+++ lincity-1.13.1/mouse.c
+--- a/mouse.c
++++ b/mouse.c
@@ -1057,7 +1057,7 @@
and set to 1 if the existing transport if the more expensive sort
(e.g. GROUP_RAIL when overwriting GROUP_ROAD).
@@ -20,8 +9,8 @@
mt_erase(int x, int y)
{
if (x < 0 || y < 0 || x >= WORLD_SIDE_LEN || y >= WORLD_SIDE_LEN)
---- lincity-1.13.1.orig/pixmap.c
-+++ lincity-1.13.1/pixmap.c
+--- a/pixmap.c
++++ b/pixmap.c
@@ -390,7 +390,7 @@
likes it in the file. Still need to fix this in autoconf,
but for now this will do. */
@@ -31,8 +20,8 @@
pixmap_index (int x, int y)
{
return y*pixmap_width + x;
---- lincity-1.13.1.orig/pixmap.h
-+++ lincity-1.13.1/pixmap.h
+--- a/pixmap.h
++++ b/pixmap.h
@@ -19,7 +19,7 @@
void initialize_pixmap (void);
void resize_pixmap (int new_width, int new_height);
@@ -51,19 +40,8 @@
pixmap_index (int x, int y) {
return y*pixmap_width + x;
}
---- lincity-1.13.1.orig/po/Makefile.in.in
-+++ lincity-1.13.1/po/Makefile.in.in
-@@ -21,7 +21,7 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = /usr/share/locale
- gettextsrcdir = $(datadir)/gettext/po
-
- INSTALL = @INSTALL@
---- lincity-1.13.1.orig/readpng.c
-+++ lincity-1.13.1/readpng.c
+--- a/readpng.c
++++ b/readpng.c
@@ -3,6 +3,7 @@
* This file is part of lincity (see COPYRIGHT for copyright information).
* ---------------------------------------------------------------------- */
diff --git a/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch b/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch
index 77f3a41dcf6c..a1d6ea0f2e70 100644
--- a/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch
+++ b/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch
@@ -1,7 +1,8 @@
+https://bugs.gentoo.org/570574
https://bugs.gentoo.org/706394
---- lincity-1.13.1/fileutil.c 2004-07-03 08:26:33.000000000 -0000
-+++ lincity-1.13.1/fileutil.c 2020-02-26 09:16:31.406614385 -0000
+--- a/fileutil.c
++++ b/fileutil.c
@@ -105,7 +105,7 @@
* ---------------------------------------------------------------------- */
char LIBDIR[LC_PATH_MAX];
@@ -11,8 +12,8 @@ https://bugs.gentoo.org/706394
int lc_save_dir_len;
static char *lc_temp_filename;
---- lincity-1.13.1/ldsvguts.c 2003-10-10 04:11:29.000000000 -0000
-+++ lincity-1.13.1/ldsvguts.c 2020-02-26 09:17:22.410992011 -0000
+--- a/ldsvguts.c
++++ b/ldsvguts.c
@@ -91,8 +91,6 @@
* Private Global Variables
* ---------------------------------------------------------------------- */
@@ -22,8 +23,8 @@ https://bugs.gentoo.org/706394
/* ---------------------------------------------------------------------- *
* Public functions
* ---------------------------------------------------------------------- */
---- lincity-1.13.1/main.c 2004-07-03 07:59:05.000000000 -0000
-+++ lincity-1.13.1/main.c 2020-02-26 09:17:04.222857373 -0000
+--- a/main.c
++++ b/main.c
@@ -96,9 +96,8 @@
#endif
#endif
@@ -35,8 +36,28 @@ https://bugs.gentoo.org/706394
#ifdef CS_PROFILE
int prof_countdown = PROFILE_COUNTDOWN;
---- lincity-1.13.1/screen.h 2004-06-22 13:24:19.000000000 -0000
-+++ lincity-1.13.1/screen.h 2020-02-26 09:14:31.473725606 -0000
+--- a/mouse.c
++++ b/mouse.c
+@@ -1094,7 +1094,7 @@
+ return 0;
+ }
+
+-inline int
++static inline int
+ mt_temp(int x, int y)
+ {
+ if (x < 0 || y < 0 || x >= WORLD_SIDE_LEN || y >= WORLD_SIDE_LEN)
+@@ -1128,7 +1128,7 @@
+ return 0;
+ }
+
+-inline int
++static inline int
+ mt_perm(int x, int y)
+ {
+ /* By now, it has already been mt_erase()'d */
+--- a/screen.h
++++ b/screen.h
@@ -20,7 +20,7 @@
extern unsigned char start_font2[4096];
extern unsigned char start_font3[4096];
diff --git a/games-simulation/lincity/lincity-1.13.1-r1.ebuild b/games-simulation/lincity/lincity-1.13.1-r1.ebuild
deleted file mode 100644
index 6479c984045d..000000000000
--- a/games-simulation/lincity/lincity-1.13.1-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils flag-o-matic
-
-DESCRIPTION="city/country simulation game for X and Linux SVGALib"
-HOMEPAGE="http://lincity.sourceforge.net/"
-SRC_URI="mirror://sourceforge/lincity/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-# dep fix (bug #82318)
-RDEPEND="media-libs/libpng:0
- x11-libs/libSM
- x11-libs/libXext
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-build.patch
- "${FILESDIR}"/${P}-gcc-10.patch
-)
-
-src_prepare() {
- default
-
- append-cflags -std=gnu89 # build with gcc5 (bug #570574)
-}
-
-src_configure() {
- econf \
- $(use_enable nls) \
- --with-gzip \
- --with-x
-}
-
-src_compile() {
- # build system logic is severely broken
- emake
- emake X_PROGS
-}
-
-src_install() {
- default
- dodoc Acknowledgements CHANGES README* TODO
- make_desktop_entry xlincity Lincity
- dobin xlincity
-}
diff --git a/games-simulation/lincity/lincity-1.13.1-r2.ebuild b/games-simulation/lincity/lincity-1.13.1-r2.ebuild
new file mode 100644
index 000000000000..c67386702def
--- /dev/null
+++ b/games-simulation/lincity/lincity-1.13.1-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="City simulation game for X"
+HOMEPAGE="http://lincity.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/lincity/${P}.tar.gz
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libpng:=
+ virtual/libintl
+ x11-libs/libXext"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
+)
+
+src_configure() {
+ local econfargs=(
+ --with-gzip
+ --with-x
+ --without-svga
+ ac_cv_lib_ICE_IceConnectionNumber=no # not actually used
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_compile() {
+ emake
+ emake X_PROGS
+}
+
+src_install() {
+ default
+
+ dobin x${PN}
+
+ newman {,x}${PN}.6
+ rm "${ED}"/usr/share/man/man6/${PN}.6
+
+ dodoc Acknowledgements
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry x${PN} ${PN^}
+}