summaryrefslogtreecommitdiff
path: root/games-simulation/gl117/gl117-1.3.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/gl117/gl117-1.3.2-r1.ebuild')
-rw-r--r--games-simulation/gl117/gl117-1.3.2-r1.ebuild38
1 files changed, 21 insertions, 17 deletions
diff --git a/games-simulation/gl117/gl117-1.3.2-r1.ebuild b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
index f5c52f6068ab..8f27db3990a6 100644
--- a/games-simulation/gl117/gl117-1.3.2-r1.ebuild
+++ b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
@@ -1,37 +1,41 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=8
+
+inherit desktop
MY_P="gl-117-${PV}-src"
-DESCRIPTION="An action flight simulator"
-HOMEPAGE="http://www.heptargon.de/gl-117/gl-117.html"
-SRC_URI="mirror://sourceforge/gl-117/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
+DESCRIPTION="Action flight simulator"
+HOMEPAGE="https://sourceforge.net/projects/gl-117/"
+SRC_URI="
+ mirror://sourceforge/gl-117/${MY_P}.tar.bz2
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="
+RDEPEND="
media-libs/freeglut
- media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/libsdl[joystick,opengl,sound,video]
media-libs/sdl-mixer[mod]
virtual/glu
virtual/opengl"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${MY_P}
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-mode.patch
)
src_install() {
- DOCS="doc/gl-117.pdf AUTHORS ChangeLog FAQ NEWS README" \
- default
- newicon doc/src/falcon.jpg ${PN}.jpg
- make_desktop_entry gl-117 GL-117 /usr/share/pixmaps/${PN}.jpg
+ default
+
doman doc/gl-117.6
+ dodoc doc/gl-117.pdf
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry gl-117 GL-117
}