summaryrefslogtreecommitdiff
path: root/games-simulation/lincity/files/lincity-1.13.1-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/lincity/files/lincity-1.13.1-build.patch')
-rw-r--r--games-simulation/lincity/files/lincity-1.13.1-build.patch38
1 files changed, 8 insertions, 30 deletions
diff --git a/games-simulation/lincity/files/lincity-1.13.1-build.patch b/games-simulation/lincity/files/lincity-1.13.1-build.patch
index f7f41f954baf..a5244b5387f3 100644
--- a/games-simulation/lincity/files/lincity-1.13.1-build.patch
+++ b/games-simulation/lincity/files/lincity-1.13.1-build.patch
@@ -1,16 +1,5 @@
---- lincity-1.13.1.orig/intl/Makefile.in
-+++ lincity-1.13.1/intl/Makefile.in
-@@ -32,7 +32,7 @@
- libdir = @libdir@
- includedir = @includedir@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = /usr/share/locale
- gettextsrcdir = $(datadir)/gettext/intl
- aliaspath = $(localedir)
- subdir = intl
---- lincity-1.13.1.orig/mouse.c
-+++ lincity-1.13.1/mouse.c
+--- a/mouse.c
++++ b/mouse.c
@@ -1057,7 +1057,7 @@
and set to 1 if the existing transport if the more expensive sort
(e.g. GROUP_RAIL when overwriting GROUP_ROAD).
@@ -20,8 +9,8 @@
mt_erase(int x, int y)
{
if (x < 0 || y < 0 || x >= WORLD_SIDE_LEN || y >= WORLD_SIDE_LEN)
---- lincity-1.13.1.orig/pixmap.c
-+++ lincity-1.13.1/pixmap.c
+--- a/pixmap.c
++++ b/pixmap.c
@@ -390,7 +390,7 @@
likes it in the file. Still need to fix this in autoconf,
but for now this will do. */
@@ -31,8 +20,8 @@
pixmap_index (int x, int y)
{
return y*pixmap_width + x;
---- lincity-1.13.1.orig/pixmap.h
-+++ lincity-1.13.1/pixmap.h
+--- a/pixmap.h
++++ b/pixmap.h
@@ -19,7 +19,7 @@
void initialize_pixmap (void);
void resize_pixmap (int new_width, int new_height);
@@ -51,19 +40,8 @@
pixmap_index (int x, int y) {
return y*pixmap_width + x;
}
---- lincity-1.13.1.orig/po/Makefile.in.in
-+++ lincity-1.13.1/po/Makefile.in.in
-@@ -21,7 +21,7 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = /usr/share/locale
- gettextsrcdir = $(datadir)/gettext/po
-
- INSTALL = @INSTALL@
---- lincity-1.13.1.orig/readpng.c
-+++ lincity-1.13.1/readpng.c
+--- a/readpng.c
++++ b/readpng.c
@@ -3,6 +3,7 @@
* This file is part of lincity (see COPYRIGHT for copyright information).
* ---------------------------------------------------------------------- */