summaryrefslogtreecommitdiff
path: root/games-simulation/lincity/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/lincity/files')
-rw-r--r--games-simulation/lincity/files/lincity-1.13.1-build.patch38
-rw-r--r--games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch37
2 files changed, 37 insertions, 38 deletions
diff --git a/games-simulation/lincity/files/lincity-1.13.1-build.patch b/games-simulation/lincity/files/lincity-1.13.1-build.patch
index f7f41f954baf..a5244b5387f3 100644
--- a/games-simulation/lincity/files/lincity-1.13.1-build.patch
+++ b/games-simulation/lincity/files/lincity-1.13.1-build.patch
@@ -1,16 +1,5 @@
---- lincity-1.13.1.orig/intl/Makefile.in
-+++ lincity-1.13.1/intl/Makefile.in
-@@ -32,7 +32,7 @@
- libdir = @libdir@
- includedir = @includedir@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = /usr/share/locale
- gettextsrcdir = $(datadir)/gettext/intl
- aliaspath = $(localedir)
- subdir = intl
---- lincity-1.13.1.orig/mouse.c
-+++ lincity-1.13.1/mouse.c
+--- a/mouse.c
++++ b/mouse.c
@@ -1057,7 +1057,7 @@
and set to 1 if the existing transport if the more expensive sort
(e.g. GROUP_RAIL when overwriting GROUP_ROAD).
@@ -20,8 +9,8 @@
mt_erase(int x, int y)
{
if (x < 0 || y < 0 || x >= WORLD_SIDE_LEN || y >= WORLD_SIDE_LEN)
---- lincity-1.13.1.orig/pixmap.c
-+++ lincity-1.13.1/pixmap.c
+--- a/pixmap.c
++++ b/pixmap.c
@@ -390,7 +390,7 @@
likes it in the file. Still need to fix this in autoconf,
but for now this will do. */
@@ -31,8 +20,8 @@
pixmap_index (int x, int y)
{
return y*pixmap_width + x;
---- lincity-1.13.1.orig/pixmap.h
-+++ lincity-1.13.1/pixmap.h
+--- a/pixmap.h
++++ b/pixmap.h
@@ -19,7 +19,7 @@
void initialize_pixmap (void);
void resize_pixmap (int new_width, int new_height);
@@ -51,19 +40,8 @@
pixmap_index (int x, int y) {
return y*pixmap_width + x;
}
---- lincity-1.13.1.orig/po/Makefile.in.in
-+++ lincity-1.13.1/po/Makefile.in.in
-@@ -21,7 +21,7 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = /usr/share/locale
- gettextsrcdir = $(datadir)/gettext/po
-
- INSTALL = @INSTALL@
---- lincity-1.13.1.orig/readpng.c
-+++ lincity-1.13.1/readpng.c
+--- a/readpng.c
++++ b/readpng.c
@@ -3,6 +3,7 @@
* This file is part of lincity (see COPYRIGHT for copyright information).
* ---------------------------------------------------------------------- */
diff --git a/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch b/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch
index 77f3a41dcf6c..a1d6ea0f2e70 100644
--- a/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch
+++ b/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch
@@ -1,7 +1,8 @@
+https://bugs.gentoo.org/570574
https://bugs.gentoo.org/706394
---- lincity-1.13.1/fileutil.c 2004-07-03 08:26:33.000000000 -0000
-+++ lincity-1.13.1/fileutil.c 2020-02-26 09:16:31.406614385 -0000
+--- a/fileutil.c
++++ b/fileutil.c
@@ -105,7 +105,7 @@
* ---------------------------------------------------------------------- */
char LIBDIR[LC_PATH_MAX];
@@ -11,8 +12,8 @@ https://bugs.gentoo.org/706394
int lc_save_dir_len;
static char *lc_temp_filename;
---- lincity-1.13.1/ldsvguts.c 2003-10-10 04:11:29.000000000 -0000
-+++ lincity-1.13.1/ldsvguts.c 2020-02-26 09:17:22.410992011 -0000
+--- a/ldsvguts.c
++++ b/ldsvguts.c
@@ -91,8 +91,6 @@
* Private Global Variables
* ---------------------------------------------------------------------- */
@@ -22,8 +23,8 @@ https://bugs.gentoo.org/706394
/* ---------------------------------------------------------------------- *
* Public functions
* ---------------------------------------------------------------------- */
---- lincity-1.13.1/main.c 2004-07-03 07:59:05.000000000 -0000
-+++ lincity-1.13.1/main.c 2020-02-26 09:17:04.222857373 -0000
+--- a/main.c
++++ b/main.c
@@ -96,9 +96,8 @@
#endif
#endif
@@ -35,8 +36,28 @@ https://bugs.gentoo.org/706394
#ifdef CS_PROFILE
int prof_countdown = PROFILE_COUNTDOWN;
---- lincity-1.13.1/screen.h 2004-06-22 13:24:19.000000000 -0000
-+++ lincity-1.13.1/screen.h 2020-02-26 09:14:31.473725606 -0000
+--- a/mouse.c
++++ b/mouse.c
+@@ -1094,7 +1094,7 @@
+ return 0;
+ }
+
+-inline int
++static inline int
+ mt_temp(int x, int y)
+ {
+ if (x < 0 || y < 0 || x >= WORLD_SIDE_LEN || y >= WORLD_SIDE_LEN)
+@@ -1128,7 +1128,7 @@
+ return 0;
+ }
+
+-inline int
++static inline int
+ mt_perm(int x, int y)
+ {
+ /* By now, it has already been mt_erase()'d */
+--- a/screen.h
++++ b/screen.h
@@ -20,7 +20,7 @@
extern unsigned char start_font2[4096];
extern unsigned char start_font3[4096];