summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin32585 -> 32580 bytes
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild42
-rw-r--r--app-vim/pydiction/Manifest4
-rw-r--r--app-vim/pydiction/pydiction-1.2.3-r1.ebuild30
-rw-r--r--app-vim/pydiction/pydiction-1.2.3-r2.ebuild2
-rw-r--r--app-vim/pydiction/pydiction-1.2.3.ebuild25
-rw-r--r--app-vim/vimpython/Manifest2
-rw-r--r--app-vim/vimpython/vimpython-1.13-r2.ebuild2
9 files changed, 4 insertions, 105 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index fdee975782e2..2ef4674d5a10 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 87fec053d7d8..9b33793775ae 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,6 +1,4 @@
-DIST gentoo-syntax-20181023.tar.bz2 18299 BLAKE2B ea037425ab00b05e4a52f943817fb264492793c842b6c9250450ab715fafebc55d0b5b95ff49945f62258f2dc70f357eeef3a5d908592c995cdc6e940f2f15af SHA512 a6bd592dd46ad80a4126321826dbbc4c130624027e7e71f0ea87fb164963e980e3ab3e1db1e87ee0ddad602f2ea2e9e7d955a0016c00eb8aef4c01c29057b737
DIST gentoo-syntax-20190609.tar.bz2 18401 BLAKE2B db738540fc85d8edd0269ade33e174db08b9231237f1138da9a3f6ecff7c188a041b312975629be652a5384d0c914ad8d7a3ac5ef14670e4bc0859fbdf3dcbc7 SHA512 70fbf6e37eee2e5b007eb59b76492f41046884a8310a6074ca5fbab666ec74d46ab3e57bbf2ae784db2e17bfd1c4801b18b71cf37f746e02ff640de1f6821ec7
-EBUILD gentoo-syntax-20181023.ebuild 1289 BLAKE2B eb217dfaed0680a9dd2e4c6727ee4f07255b04187887f5cff6eada0b56a77ba290173db5394212fe6700750bf9dc73d68170be347f2590723b8c381d2e0e42c9 SHA512 0992ed4df494b14567d259b65e6d15978e3f92f29d54f72c7f72920bbdb2d8fa796d4bfd659b5653c522998eb7f4073a688da84aa1637fa2f6409107f8a880f1
EBUILD gentoo-syntax-20190609.ebuild 1289 BLAKE2B eb217dfaed0680a9dd2e4c6727ee4f07255b04187887f5cff6eada0b56a77ba290173db5394212fe6700750bf9dc73d68170be347f2590723b8c381d2e0e42c9 SHA512 0992ed4df494b14567d259b65e6d15978e3f92f29d54f72c7f72920bbdb2d8fa796d4bfd659b5653c522998eb7f4073a688da84aa1637fa2f6409107f8a880f1
EBUILD gentoo-syntax-99999999.ebuild 1087 BLAKE2B 9b7c64f1ec0215aa53e39c0c4db8352c47b19ee89a894dc95ef4a867415337ff901befaadf2ce468804e4167410c1d034002ca476c90925096875b3dc27b8868 SHA512 5f0e991bcc491e807ea86d89c47dcc8d6879c35d0f42d191a4e2cd4d40f117022e70cfb92503184e638273daed9780363066d07667c138592be1e1b6f4435b99
MISC metadata.xml 585 BLAKE2B 7f904a47ab12627ae911fa96328c50af2cb16b785fa0b60cace8a586b17de344625b749b52ef6b89b4751aba74bc25339b3e6c9105ee47d15b5c6539b5d902ee SHA512 dfed3c4c2b3697b00896591dc4b23eb6433ce77b4aaaab05119ca0b11e355e321b2cf5f0ab5e0b2dd075abd1a266908e07b80846a11d50f17155d7ab35e6c742
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild
deleted file mode 100644
index f1853ed776bb..000000000000
--- a/app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit vim-plugin
-
-DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
-HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
-SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
-
-LICENSE="vim"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="ignore-glep31"
-
-VIM_PLUGIN_HELPFILES="gentoo-syntax"
-VIM_PLUGIN_MESSAGES="filetype"
-
-src_prepare() {
- default
- if use ignore-glep31 ; then
- for f in ftplugin/*.vim ; do
- ebegin "Removing UTF-8 rules from ${f} ..."
- sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
- || die "waah! bad sed voodoo. need more goats."
- eend $?
- done
- fi
-}
-
-pkg_postinst() {
- vim-plugin_pkg_postinst
-
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- if use ignore-glep31 1>/dev/null ; then
- ewarn "You have chosen to disable the rules which ensure GLEP 31"
- ewarn "compliance. When editing ebuilds, please make sure you get"
- ewarn "the character set correct."
- fi
- fi
-}
diff --git a/app-vim/pydiction/Manifest b/app-vim/pydiction/Manifest
index cfdd017e4729..5de811d040c7 100644
--- a/app-vim/pydiction/Manifest
+++ b/app-vim/pydiction/Manifest
@@ -1,5 +1,3 @@
DIST pydiction-1.2.3.zip 475441 BLAKE2B 709d4de30d21ff0ba27b5b0c11276731bdef03d754c1799857ceba7edbea4fc0640714cda4103ed58878b02cc00feed5d6b08df2647139fa84910cf92db51dea SHA512 91da1d8a9be89095072724d77bdcaa342fbd5479f5027d7ed7bb2d4a382c7385b2b7fae91c1cd94605232b34a96370a86096e3c32db0d106cbcda2a82f409922
-EBUILD pydiction-1.2.3-r1.ebuild 696 BLAKE2B 3cbe5ad26cdf78fe9b7b5b86a4874fada7ec0807e1672fde592bbf8948bcefc42e7efb9e4551b254d442a22aa017609d5f74265cec1cfaab8a731252d0d41469 SHA512 0c879875cd8dc4928d385048fa9b92a1c8f2f25810764d3d2417232b6e62b58398d0dd4d2bc5b2d2797d0829f73d165c8b83e9800640ac016e2ebf3d166718d5
-EBUILD pydiction-1.2.3-r2.ebuild 943 BLAKE2B a47b3f982ead8e42ab6b70a093adb22db14e56df41e5a9cb56e6b9a6448ca0d352ec35c8d29b460d117dba24f24cc0dcaab63fd8eee1553c5ab6110bb95d61b6 SHA512 b21910ce6ed256798b36398230a86d761022cdeabdf6de06a54389c864b69faeb115e3472da16e8e5e27719818c6edfc83abf378832fc4700b0061ac77064969
-EBUILD pydiction-1.2.3.ebuild 598 BLAKE2B 240a494c6547fafa7d1f98a241a9e3072e4c758b1dcb7bc9f3bd6996d33ba94df765fd5ff8993729d49570e96416bc59b60c15644971625fec7e7786e79b2b56 SHA512 11d845c3d011daab5bcc676581a347974731166f689e7c2e41f6a0fe680f865079c2275d14632c3cbd901b187bb1ee3a829a07ceec77f32332f66ec74ca6d5e6
+EBUILD pydiction-1.2.3-r2.ebuild 939 BLAKE2B 644f6d8d022791ca1c7f9f6f41d0ca0f01efeeb7dd7dd0b76a83652baa4004e849c730724b56f0ccd507aa14e032a3784d2be8c8f4280d2f5f256dba6125a161 SHA512 1bfac6b60ee74c5adae8215034a9fa62558fbf805645cb72cd299ba3608f08a246d55ee72516dab49953613e80e1b32efcf1896f68f57bbf9f5aa1cff1dc5f14
MISC metadata.xml 361 BLAKE2B 4cd18ca933890f32a2aca909c66c48ea1539fc4d4d558657e5fb76c66a26be7c9b24882b7688b54407e044ba1e4d641e659da10065360ddba91dad4aa391da5e SHA512 f205ce2b8f61bcc7d966345b9928efccdc2adb4ce6a36166c774134bd8959a3757a3a9a556aaa2d6c6f7b71b945be84e41903a58e66f844c4258326a66b2b667
diff --git a/app-vim/pydiction/pydiction-1.2.3-r1.ebuild b/app-vim/pydiction/pydiction-1.2.3-r1.ebuild
deleted file mode 100644
index 12ae4f48a14f..000000000000
--- a/app-vim/pydiction/pydiction-1.2.3-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit vim-plugin python-r1
-
-DESCRIPTION="vim plugin: tab-complete your Python code"
-HOMEPAGE="https://rkulla.github.io/pydiction/"
-SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
-
-LICENSE="vim"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="app-arch/unzip"
-RDEPEND="${PYTHON_DEPS}"
-
-S="${WORKDIR}/${PN}-master"
-
-src_install() {
- insinto "/usr/share/${PN}"
- local pyfiles=( complete-dict pydiction.py )
- doins "${pyfiles[@]}"
- rm -v "${pyfiles[@]}" || die
- vim-plugin_src_install
-}
diff --git a/app-vim/pydiction/pydiction-1.2.3-r2.ebuild b/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
index 7e8c76ffa53d..8ef22c6cc197 100644
--- a/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
+++ b/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://rkulla.github.io/pydiction/"
SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
LICENSE="vim"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ppc ppc64 x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="app-arch/unzip"
diff --git a/app-vim/pydiction/pydiction-1.2.3.ebuild b/app-vim/pydiction/pydiction-1.2.3.ebuild
deleted file mode 100644
index c4fae8228716..000000000000
--- a/app-vim/pydiction/pydiction-1.2.3.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit vim-plugin
-
-DESCRIPTION="vim plugin: Tab-complete your Python code"
-HOMEPAGE="https://rkulla.github.io/pydiction/"
-SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
-LICENSE="vim"
-KEYWORDS="amd64 ppc ppc64 x86"
-
-DEPEND="app-arch/unzip"
-RDEPEND="dev-lang/python:*"
-
-S="${WORKDIR}/${PN}-master"
-
-src_install() {
- insinto "/usr/share/${PN}"
- local pyfiles=( complete-dict pydiction.py )
- doins "${pyfiles[@]}"
- rm -v "${pyfiles[@]}" || die
- vim-plugin_src_install
-}
diff --git a/app-vim/vimpython/Manifest b/app-vim/vimpython/Manifest
index 2fd22460adc8..dd98aa64c14d 100644
--- a/app-vim/vimpython/Manifest
+++ b/app-vim/vimpython/Manifest
@@ -1,4 +1,4 @@
DIST vimpython-1.13.tar.bz2 4270 BLAKE2B 7973aea8ea397f3f2edcf8a2845ab47cad3015925dd9e42e37a7ada47f25073b68d6d8f8c378a86d90e39c0aae63aba784753679b4d04a5aad268db157400ae2 SHA512 467217ad160f02d3ecdc8c43e35966e496e6c5f99bef115bd4905795c0fd5b8f68f68bc8edd64ca1dbb1c6fbc088ef6ae996f524f0343943702f2a92dcc144ce
EBUILD vimpython-1.13-r1.ebuild 385 BLAKE2B fb67a5dc1f6072159f92d02dbbc205e8869ddbc8b62669098cae1533f7b7fe5fd80e2783690e2b504ea4a5cf390d1a3a7df4a9d98ed9a97a47b42ae749f0c15a SHA512 5427cad779f09e12eb12510db56ebd6eee635127725120a0a95276de44121a9d757223eff8e2ec52b7ef44b64892db8ed60628c00acd31e52c3309c6d5cdbfa4
-EBUILD vimpython-1.13-r2.ebuild 484 BLAKE2B 59b60e61cd592de8ee530d111daad2b0ebf65d5c2a74789e9fc1b7a8f5db6a3bbe23108add554e83da7af8da6331a925aa4dad02a9085893b2c1875b547a13db SHA512 7caf3cffd51c23816c6a94ea57ffea9e2ebc6231f721901e1f793724b503b74be0d551f0444ad499d9433842052da44284c849675eff3d59a045f3b847378cf6
+EBUILD vimpython-1.13-r2.ebuild 479 BLAKE2B 2faef39f1207b4bbad70251fb373c13e6a6fcf1280e1ab8a8ceeb0b6111ed95c1c1de0903dcb23354a3397f2af7a27e05b71aec6a7e7fc3efa4bfd839266ef8d SHA512 4cec1c9c4a22d0a7641da4c6199fa273bb8217bda44afaa0b061e61dd4b93149a8e16ad06fdaa9ab3b23f7ce62c0d5f81425e7762d88ffa9ff45fb51a407ccb1
MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/vimpython/vimpython-1.13-r2.ebuild b/app-vim/vimpython/vimpython-1.13-r2.ebuild
index 994b4447c131..3713d9288a6a 100644
--- a/app-vim/vimpython/vimpython-1.13-r2.ebuild
+++ b/app-vim/vimpython/vimpython-1.13-r2.ebuild
@@ -10,7 +10,7 @@ inherit vim-plugin python-single-r1
DESCRIPTION="vim plugin: A set of menus/shortcuts to work with Python files"
HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=30"
LICENSE="vim"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+KEYWORDS="~alpha amd64 ia64 ppc sparc x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"