summaryrefslogtreecommitdiff
path: root/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /sci-mathematics/diagrtb/diagrtb-2.64.ebuild
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'sci-mathematics/diagrtb/diagrtb-2.64.ebuild')
-rw-r--r--sci-mathematics/diagrtb/diagrtb-2.64.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
index 7d68ff7897a9..59b01102533f 100644
--- a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
+++ b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils fortran-2
+inherit cmake fortran-2
DESCRIPTION="Calculation of some eigenvectors of a large real, symmetrical, matrix"
HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
@@ -17,10 +17,12 @@ RESTRICT="mirror bindist"
S="${WORKDIR}"/Source_RTB2011
+DOCS=( diagrtb.README )
+
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -28,5 +30,5 @@ src_configure() {
-DEXAMPLES=$(usex examples)
)
- cmake-utils_src_configure
+ cmake_src_configure
}