summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /sci-mathematics
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/4ti2/4ti2-1.6.7.ebuild15
-rw-r--r--sci-mathematics/4ti2/Manifest4
-rw-r--r--sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch6
-rw-r--r--sci-mathematics/Manifest.gzbin13331 -> 13334 bytes
-rw-r--r--sci-mathematics/diagrtb/Manifest4
-rw-r--r--sci-mathematics/diagrtb/diagrtb-2.64.ebuild12
-rw-r--r--sci-mathematics/diagrtb/files/CMakeLists.txt1
-rw-r--r--sci-mathematics/ginac/Manifest4
-rw-r--r--sci-mathematics/ginac/ginac-1.6.6.ebuild58
-rw-r--r--sci-mathematics/ginac/ginac-1.7.11.ebuild2
10 files changed, 18 insertions, 88 deletions
diff --git a/sci-mathematics/4ti2/4ti2-1.6.7.ebuild b/sci-mathematics/4ti2/4ti2-1.6.7.ebuild
index ec2bd5017ed2..0307e26bdbae 100644
--- a/sci-mathematics/4ti2/4ti2-1.6.7.ebuild
+++ b/sci-mathematics/4ti2/4ti2-1.6.7.ebuild
@@ -1,27 +1,24 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
-HOMEPAGE="http://www.4ti2.de/"
+HOMEPAGE="https://4ti2.github.io"
SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
RDEPEND="
sci-mathematics/glpk:=[gmp]
dev-libs/gmp:0=[cxx]"
DEPEND="${RDEPEND}"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.3.2-gold.patch
-)
+PATCHES=( "${FILESDIR}"/${PN}-1.3.2-gold.patch )
src_prepare() {
default
@@ -33,13 +30,11 @@ src_prepare() {
src_configure() {
econf \
--enable-shared \
- $(use_enable static-libs static)
+ --disable-static
}
src_install() {
default
- if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
- fi
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/sci-mathematics/4ti2/Manifest b/sci-mathematics/4ti2/Manifest
index 48be983b098e..77cc3593b06e 100644
--- a/sci-mathematics/4ti2/Manifest
+++ b/sci-mathematics/4ti2/Manifest
@@ -1,6 +1,6 @@
-AUX 4ti2-1.3.2-gold.patch 652 BLAKE2B a3b47b440f9417d883df52356e58267b096a273ddd725c29e97a969eb3e2281edc8ecd9342bfc1a187464b4d476c22dc095ca8060f433cd2c793c22e5a181ae0 SHA512 60b14d7b287b69adbce420f37dad5d83ce21bfa4329ea0810c67f054d35a71f6795b0a8206b268ec9cfa08f796a4cd80a34d816c691e8e3e77adcbc5217b43a7
+AUX 4ti2-1.3.2-gold.patch 434 BLAKE2B 38162dea9fa7e7072966fc7c5fc72c05e2d122dbfbb25aa0027f992f0fe23bd1232245c670b8f3d3a2b75e67319a217aead99850ec6d1a025c6c4a890605b2c3 SHA512 109f89dcf1f66fae079d9ba4c265b0a9ad0a60b88848ae38175d98c51b8b8fce3e92b0f862191340f4a8dd8c60a768c77b1504d0a797553b5cd1fe5bc95189ff
DIST 4ti2-1.6.6.tar.gz 5640126 BLAKE2B e52fdfd9b406b86236795b1ba2494d9686f3c93961359bf409ddcdfeb0067e3b0904473b66268315795c8941ba0cb93dbe5e4c3cea402379bd07ee65a1951e5d SHA512 89f36aaf3d8f41bb31b37b44a013ea966d9664880473ad0d6d1825ffb00afec1eff3139c09ac6b684f0679e2ae0d201a84396bb721aa1f63dc1deca592392c41
DIST 4ti2-1.6.7.tar.gz 5649869 BLAKE2B ab0e7da1de88e5e99ead0b8fa7f7a72773b84ae903a31dc3134e83364ea45069889f8ce9812bb471cf72b824fe013756d557489b4d2ab31216141d5b6347acfc SHA512 38d638fe01ff3cef1aebae1eefd276cf02f808978851b4465e132f77d3ab34ea51d512e2ea28a42ac65263b458c43cf420dc5f8ac930f959dd0c14916cef9841
EBUILD 4ti2-1.6.6.ebuild 800 BLAKE2B df8476dc0f7617d68027bad16b76f9aa74708d2d21d7858ce95fca8b31e6077a2d5c4edfdade3e4efe35354c17b0ea7ac45bd119e1a1cf4b7a928481c95c2c71 SHA512 3c086bc2381b313e6ad4ee263739eaf2ccf6d752063f6ba6bc58b306a9b91256e9500fbf2346fe180ad295aff5b67b298808fcdbd8c02f0ed433b40e74f8c593
-EBUILD 4ti2-1.6.7.ebuild 905 BLAKE2B 8c7e27c7348adfcc660346ed683ad27cad8f93efdc4e13267bf27151e3b5bf0464b01cc4d07a0818fc6d5602655c476cd5db24a35fa5f3b60deaa03ed4ef92de SHA512 59321fb3f4a8e47a51263b4a43cce541926e37907f4789da9bdba4fb769f70e4e8faf8a16f8802c340eea7949f77ef765f79f1af5a58586e6a106ecd01bed54a
+EBUILD 4ti2-1.6.7.ebuild 840 BLAKE2B 75fc0c12dfdfe831db000ba402df60eb060d0f1cc792ce4647a655c69e8b59411377a62b2db1d558d65c5efde9fa7acf44c06970e4e448de251d81a2ad414252 SHA512 329924d6707be8358a89b37aa435419b7e3a01fc1c216f75a8673908334e31e088e6db82dd22ae1487e8473b19310dab2728d064494c3cd187f9e162d9efbccd
MISC metadata.xml 446 BLAKE2B ce737e287f6b8f420aee86ca0ce72aa4952474a3ba717239dc8d10261038faddbc9b06f93a04bc8f8c48b36606254780865bbc5038564d4fb9252241e45a7a4b SHA512 2c7950b353c54597eebcff1f50e5045f792ef37cfe59f0142160bdf5ea47ff6be57bd698b051e6c56863b109fde983c1aeeca87827289abde96838af1aa3f7d1
diff --git a/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch b/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch
index bb1e8c4aad39..9037e9836375 100644
--- a/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch
+++ b/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch
@@ -1,9 +1,3 @@
- m4/glpk-check.m4 | 2 +-
- src/groebner/Makefile.am | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/groebner/Makefile.am b/src/groebner/Makefile.am
-index 992c4ae..ba2f463 100644
--- a/src/groebner/Makefile.am
+++ b/src/groebner/Makefile.am
@@ -269,7 +269,7 @@ lib4ti2int64_la_SOURCES = $(lib4ti2sources)
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index f222dc80c338..42ea685a4619 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/diagrtb/Manifest b/sci-mathematics/diagrtb/Manifest
index 5f47af2db7cb..f508a1d72223 100644
--- a/sci-mathematics/diagrtb/Manifest
+++ b/sci-mathematics/diagrtb/Manifest
@@ -1,4 +1,4 @@
-AUX CMakeLists.txt 364 BLAKE2B 40ddcaf52204b990c0e0aa0c2cb1055d606f7bf1d36da9cbbc98c709444ad8dc91f57d09ead34fed6abe17b5d2e0afd76bc6f391e068391049621d950e15d2ef SHA512 24938f1b63bd943e6a00829f9a8bffc5774de46926d9d822e14a34b1e718bdfd31d5783fce829632203654aa7508755d5b9afa3c1822d43fcb685b81c3bd155a
+AUX CMakeLists.txt 303 BLAKE2B 6a6fa54b5a994e595f71d9d29ac023a35b41fe902a77d0a672905e51c90c0d384efe22b1bae2be5569d475934ae36f2167f1bf5331f4738e1457e7bf041ac9f5 SHA512 441ba0772c3f74f53337e7e87a31a26e9dd0ef3cb791214673b68822827e2153eb2e7b3fd6f88eca3f36ed96546418e3c8f9a6079cb9123a885146ffb73c71f4
DIST diagrtb-2.64.tar.gz 2429842 BLAKE2B 69c66e12ffda708a9d2b73d576a44600c854e4848d60a1f195a39dcd3be1dcb368b33e233d296f939e78a8b77b6baf1d8f77161b999c55b7a159b11a099b5c88 SHA512 90b1cb40d6d31cf40e27fcd50cdf864e7de036a415c56c1406f6af58339788b6a2f000abe117ad4200d3086f589e4ee916e3a7e2dd52522581de2244ad444a2c
-EBUILD diagrtb-2.64.ebuild 711 BLAKE2B 6f40d86e5e6a71d32538cbdf38b20c7576e055aef8ca89982ab15b9a133f45c76c5d3fa61969bfaacc3ce7d81f7bbfad1a6cfd220d1d4adc7e37c3a7a7eb6d7e SHA512 9bfd2036a3f3847871f36b51016b630c5f968dde95c9f1b3a7756cdc45a0e5d8718680b451374acbde931336316ab6010caaa215f3155e9f7e4894ede73d1ee8
+EBUILD diagrtb-2.64.ebuild 715 BLAKE2B 3ff3c6e82310907e309d890ba18f6192b79920537cfdf4d994800800c9c772b0e1eaa62bb9142bdbe798a084d912c71ce223ce81e78619c09aededbf37bf75e2 SHA512 ed9345219fa2544f56467c46b7731629ff2218da68c6b3a00d0773a1a69981f27e932883556f0e7b31769eda7919eca33f27b9fe17ae3e613d956090db3ec8b9
MISC metadata.xml 1227 BLAKE2B 1bd9f1fd8996212fd68bc6bf9ecb2e0acbd249bcb1ee9c858c3b37ad4948e3367b287f05801a6be877508e64ff3925f97f32ad052dc26f290ce9fca4a3d301d8 SHA512 868e64815be28cc00c952f682e31dd07a6fa2d244a97ab15805be62ad288531284da74aeb4525210477c00952ebe039de503af572ecd1aad0ceef7160a0578fd
diff --git a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
index 7d68ff7897a9..59b01102533f 100644
--- a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
+++ b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils fortran-2
+inherit cmake fortran-2
DESCRIPTION="Calculation of some eigenvectors of a large real, symmetrical, matrix"
HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
@@ -17,10 +17,12 @@ RESTRICT="mirror bindist"
S="${WORKDIR}"/Source_RTB2011
+DOCS=( diagrtb.README )
+
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -28,5 +30,5 @@ src_configure() {
-DEXAMPLES=$(usex examples)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/sci-mathematics/diagrtb/files/CMakeLists.txt b/sci-mathematics/diagrtb/files/CMakeLists.txt
index d1eb6c62f09f..ef022328bce9 100644
--- a/sci-mathematics/diagrtb/files/CMakeLists.txt
+++ b/sci-mathematics/diagrtb/files/CMakeLists.txt
@@ -6,7 +6,6 @@ option (EXAMPLES "Instal additional example files" OFF)
add_executable(diagrtb diagrtb.f)
install (TARGETS diagrtb DESTINATION bin)
-install (FILES diagrtb.README DESTINATION share/doc/diagrtb)
if ( EXAMPLES )
install (DIRECTORY ../Try_RTB2011 DESTINATION share/diagrtb/examples)
diff --git a/sci-mathematics/ginac/Manifest b/sci-mathematics/ginac/Manifest
index 28420b80883e..9ad58a500805 100644
--- a/sci-mathematics/ginac/Manifest
+++ b/sci-mathematics/ginac/Manifest
@@ -1,6 +1,4 @@
AUX ginac-1.5.1-pkgconfig.patch 340 BLAKE2B 4e45d5af711f0a6bb833bd805340527be8972b8587f47ffe34b9e473b2783f6cb98af2b2397b199bfca1c7522250c68249112ac67a750ec59f31e26628978bd0 SHA512 b88c7ef69686733a3e817d9d4961246eb64aebf753b51bf8f6ea5c6fdfef41e52b6a20656e074f0bcc42dfe7965a440642d9036628a139f2c87bbde5f59d76d1
-DIST ginac-1.6.6.tar.bz2 1028211 BLAKE2B 3f939e82cfa833ee5ba6714d4db38edf80de4e380b0bcacfe23992ca3c5eefbd719506cf77f57aebc1517968eff7d26c8d24d14167c596e5e7145458367074e8 SHA512 495ef255dd32e71ee91257a515c0566e56525e0c54c8955c19beaf9e2e55457f7d8171c7e5f6e4f29f555f5d262bbaf4edf4f033166c4904c016987a5029e958
DIST ginac-1.7.11.tar.bz2 1077491 BLAKE2B 741e9c8adfec15c225c3656b935707f86292b98310b50533269b238d1a9746bf54d186074c879fdbdd23f915dde225d9ee34fdbd87977835e8f9e78af364d77d SHA512 35a029915c946fcc10ba7b78df6fe1ece9a9f2f6bc172816a923c35f5b495154ab356526b904ac2a16a1bd6b0a81c480c5abb39ef40238ca7b32d1acbf97276c
-EBUILD ginac-1.6.6.ebuild 1400 BLAKE2B 7813592727485b9e4ffe56a4f5cbde1250823b239e621fdbbcd9485b25ab0062efc4cd09cdf2556c19fbaee1b34c8ab2b27d001f3b16c19fce5f748ad093b9ec SHA512 363562d721e28744c64b535404e8bab606c040df3d36af53b5e04156401db9c88210ed623317cd52a482b276585dc3741b3233cc0cf942abd2f1d55a790db8a3
-EBUILD ginac-1.7.11.ebuild 1474 BLAKE2B 80960c7c7d3b8aa3196c3bb606abca7d174e02ab3e7048ce267ac74b37ad4dde177581274c081e81237f9fc366eb3c64a29239a3f13ca352dad5db1e87ade20a SHA512 2ace30976f57eb93dca8b6a4dbf851b9ac5bcdfdc09ad6dc0838358a55784e04168266e5281eab8d4096c699bc8c02b44f600a1c80d7d11be3d590c8b7d19f0c
+EBUILD ginac-1.7.11.ebuild 1473 BLAKE2B 8add0d658de3be7f6b01e4866afbc289f27cba4a208d372b582b2ffd2e2bb1279f5b0f317fdc0746b3d79742a3be639f1cbdc1b8fcbcc4109392f15c667e5ec7 SHA512 38cbd823741cd188884bc7f03298ee7df2e9ea12beb10d2b3e848d3cad3ca0b2174974efa0a146b832d30cad7b1bc7a19057a9b3e86e2787447f4cc1e12f9a7f
MISC metadata.xml 685 BLAKE2B 78804186606452771e8b37a00dd41458fd7ffabd1813303528cda8596cebdd54c5daea16f324b7d23dfcf679255e73f1cff84116b0bf8a81cd79bb559dcd77ae SHA512 d0075823063455623b875bf678448b146243347879eb9ca5a4fb9324183d8dcda9c060145d5b874fead55491625ef08289b349b8abf1bf105e09ac9ebc647c37
diff --git a/sci-mathematics/ginac/ginac-1.6.6.ebuild b/sci-mathematics/ginac/ginac-1.6.6.ebuild
deleted file mode 100644
index 5ef31d19d3c2..000000000000
--- a/sci-mathematics/ginac/ginac-1.6.6.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils
-
-DESCRIPTION="C++ library and tools for symbolic calculations"
-SRC_URI="http://www.ginac.de/${P}.tar.bz2"
-HOMEPAGE="https://www.ginac.de/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
-
-RDEPEND=">=sci-libs/cln-1.2.2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen
- media-gfx/transfig
- virtual/texi2dvi
- dev-texlive/texlive-fontsrecommended
- )"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch )
-
-src_configure() {
- local myeconfargs=( --disable-rpath )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- if use doc; then
- export VARTEXFONTS="${T}"/fonts
- cd "${BUILD_DIR}/doc/reference"
- emake html pdf
- cd "${BUILD_DIR}/doc/tutorial"
- emake ginac.pdf ginac.html
- fi
-}
-
-src_install() {
- autotools-utils_src_install
- if use doc; then
- cd "${BUILD_DIR}"/doc
- insinto /usr/share/doc/${PF}
- newins tutorial/ginac.pdf tutorial.pdf
- newins reference/reference.pdf reference.pdf
- insinto /usr/share/doc/${PF}/html/reference
- doins -r reference/html_files/*
- insinto /usr/share/doc/${PF}/html
- newins tutorial/ginac.html tutorial.html
- insinto /usr/share/doc/${PF}/examples
- doins "${S}"/doc/examples/*.cpp examples/ginac-examples.*
- fi
-}
diff --git a/sci-mathematics/ginac/ginac-1.7.11.ebuild b/sci-mathematics/ginac/ginac-1.7.11.ebuild
index 6bd2388f1c08..af38764f9a32 100644
--- a/sci-mathematics/ginac/ginac-1.7.11.ebuild
+++ b/sci-mathematics/ginac/ginac-1.7.11.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="https://www.ginac.de/"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
IUSE="doc examples"
RDEPEND=">=sci-libs/cln-1.2.2"