summaryrefslogtreecommitdiff
path: root/sci-mathematics/diagrtb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /sci-mathematics/diagrtb
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'sci-mathematics/diagrtb')
-rw-r--r--sci-mathematics/diagrtb/Manifest4
-rw-r--r--sci-mathematics/diagrtb/diagrtb-2.64.ebuild12
-rw-r--r--sci-mathematics/diagrtb/files/CMakeLists.txt1
3 files changed, 9 insertions, 8 deletions
diff --git a/sci-mathematics/diagrtb/Manifest b/sci-mathematics/diagrtb/Manifest
index 5f47af2db7cb..f508a1d72223 100644
--- a/sci-mathematics/diagrtb/Manifest
+++ b/sci-mathematics/diagrtb/Manifest
@@ -1,4 +1,4 @@
-AUX CMakeLists.txt 364 BLAKE2B 40ddcaf52204b990c0e0aa0c2cb1055d606f7bf1d36da9cbbc98c709444ad8dc91f57d09ead34fed6abe17b5d2e0afd76bc6f391e068391049621d950e15d2ef SHA512 24938f1b63bd943e6a00829f9a8bffc5774de46926d9d822e14a34b1e718bdfd31d5783fce829632203654aa7508755d5b9afa3c1822d43fcb685b81c3bd155a
+AUX CMakeLists.txt 303 BLAKE2B 6a6fa54b5a994e595f71d9d29ac023a35b41fe902a77d0a672905e51c90c0d384efe22b1bae2be5569d475934ae36f2167f1bf5331f4738e1457e7bf041ac9f5 SHA512 441ba0772c3f74f53337e7e87a31a26e9dd0ef3cb791214673b68822827e2153eb2e7b3fd6f88eca3f36ed96546418e3c8f9a6079cb9123a885146ffb73c71f4
DIST diagrtb-2.64.tar.gz 2429842 BLAKE2B 69c66e12ffda708a9d2b73d576a44600c854e4848d60a1f195a39dcd3be1dcb368b33e233d296f939e78a8b77b6baf1d8f77161b999c55b7a159b11a099b5c88 SHA512 90b1cb40d6d31cf40e27fcd50cdf864e7de036a415c56c1406f6af58339788b6a2f000abe117ad4200d3086f589e4ee916e3a7e2dd52522581de2244ad444a2c
-EBUILD diagrtb-2.64.ebuild 711 BLAKE2B 6f40d86e5e6a71d32538cbdf38b20c7576e055aef8ca89982ab15b9a133f45c76c5d3fa61969bfaacc3ce7d81f7bbfad1a6cfd220d1d4adc7e37c3a7a7eb6d7e SHA512 9bfd2036a3f3847871f36b51016b630c5f968dde95c9f1b3a7756cdc45a0e5d8718680b451374acbde931336316ab6010caaa215f3155e9f7e4894ede73d1ee8
+EBUILD diagrtb-2.64.ebuild 715 BLAKE2B 3ff3c6e82310907e309d890ba18f6192b79920537cfdf4d994800800c9c772b0e1eaa62bb9142bdbe798a084d912c71ce223ce81e78619c09aededbf37bf75e2 SHA512 ed9345219fa2544f56467c46b7731629ff2218da68c6b3a00d0773a1a69981f27e932883556f0e7b31769eda7919eca33f27b9fe17ae3e613d956090db3ec8b9
MISC metadata.xml 1227 BLAKE2B 1bd9f1fd8996212fd68bc6bf9ecb2e0acbd249bcb1ee9c858c3b37ad4948e3367b287f05801a6be877508e64ff3925f97f32ad052dc26f290ce9fca4a3d301d8 SHA512 868e64815be28cc00c952f682e31dd07a6fa2d244a97ab15805be62ad288531284da74aeb4525210477c00952ebe039de503af572ecd1aad0ceef7160a0578fd
diff --git a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
index 7d68ff7897a9..59b01102533f 100644
--- a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
+++ b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils fortran-2
+inherit cmake fortran-2
DESCRIPTION="Calculation of some eigenvectors of a large real, symmetrical, matrix"
HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
@@ -17,10 +17,12 @@ RESTRICT="mirror bindist"
S="${WORKDIR}"/Source_RTB2011
+DOCS=( diagrtb.README )
+
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -28,5 +30,5 @@ src_configure() {
-DEXAMPLES=$(usex examples)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/sci-mathematics/diagrtb/files/CMakeLists.txt b/sci-mathematics/diagrtb/files/CMakeLists.txt
index d1eb6c62f09f..ef022328bce9 100644
--- a/sci-mathematics/diagrtb/files/CMakeLists.txt
+++ b/sci-mathematics/diagrtb/files/CMakeLists.txt
@@ -6,7 +6,6 @@ option (EXAMPLES "Instal additional example files" OFF)
add_executable(diagrtb diagrtb.f)
install (TARGETS diagrtb DESTINATION bin)
-install (FILES diagrtb.README DESTINATION share/doc/diagrtb)
if ( EXAMPLES )
install (DIRECTORY ../Try_RTB2011 DESTINATION share/diagrtb/examples)