summaryrefslogtreecommitdiff
path: root/sci-astronomy/esomidas/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-astronomy/esomidas/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-astronomy/esomidas/files')
-rw-r--r--sci-astronomy/esomidas/files/esomidas-17.02-gentoo-setup.patch12
-rw-r--r--sci-astronomy/esomidas/files/esomidas-17.02-output_to_stdout.patch42
-rw-r--r--sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch33
3 files changed, 87 insertions, 0 deletions
diff --git a/sci-astronomy/esomidas/files/esomidas-17.02-gentoo-setup.patch b/sci-astronomy/esomidas/files/esomidas-17.02-gentoo-setup.patch
new file mode 100644
index 000000000000..f6fb0515ee74
--- /dev/null
+++ b/sci-astronomy/esomidas/files/esomidas-17.02-gentoo-setup.patch
@@ -0,0 +1,12 @@
+--- a/install/unix/preinstall 2017-06-29 23:49:01.295996178 +0000
++++ b/install/unix/preinstall 2017-06-29 23:50:21.835445329 +0000
+@@ -124,6 +124,9 @@
+ if [ -d "Debian" -a -f "/etc/debian_version" ]; then
+ system="Debian"
+
++elif [ -d "Gentoo" -a -f "/etc/gentoo-release" ]; then
++ system="Gentoo"
++
+ elif [ "$uname" = "Darwin" ]; then
+ system="Darwin"
+
diff --git a/sci-astronomy/esomidas/files/esomidas-17.02-output_to_stdout.patch b/sci-astronomy/esomidas/files/esomidas-17.02-output_to_stdout.patch
new file mode 100644
index 000000000000..bd24c3801d99
--- /dev/null
+++ b/sci-astronomy/esomidas/files/esomidas-17.02-output_to_stdout.patch
@@ -0,0 +1,42 @@
+From: Ole Streicher <debian@liska.ath.cx>
+Date: Wed, 1 Mar 2017 09:31:31 +0100
+Subject: Run compilation in foreground and write log to stdout instead of a
+ file.
+
+---
+ install/unix/install3 | 14 ++------------
+ 1 file changed, 2 insertions(+), 12 deletions(-)
+
+diff --git a/install/unix/install3 b/install/unix/install3
+index ef2a415..1cc0b4e 100755
+--- a/install/unix/install3
++++ b/install/unix/install3
+@@ -112,8 +112,6 @@ fi
+
+ echo ""
+ echo "WARNING: MIDAS installation will delete all dependent files."
+-echo " It will run in background and the output will be sent to"
+-echo " the file <$MID_HOME/tmp/install.$$>"
+ echo ""
+ echo "Do you want to continue [yn]? (y): " $SV_NONL
+ unset answ
+@@ -138,17 +136,9 @@ fi
+
+ # do we have the 'time' command?
+ if [ $CMND_YES = 2 ] ; then
+- /bin/bash $MID_INSTALL/install -i > $MID_HOME/tmp/install.$$ 2>&1 &
++ /bin/bash $MID_INSTALL/install -i
+ else
+- time /bin/bash $MID_INSTALL/install -i > $MID_HOME/tmp/install.$$ 2>&1 &
++ time /bin/bash $MID_INSTALL/install -i
+ fi
+
+-echo "Running install in background"
+-echo "Results are coming in $MID_HOME/tmp/install.$$"
+-if [ "$1" = "-a" ]; then
+- echo "Waiting for MIDAS installation to finish..." $SV_NONL
+- wait
+- echo "Finished."
+- echo ""
+-fi
+ exit 0
diff --git a/sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch b/sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch
new file mode 100644
index 000000000000..d56ec03346c9
--- /dev/null
+++ b/sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch
@@ -0,0 +1,33 @@
+diff -ruN 17FEBpl1.2.orig/lib/makefile 17FEBpl1.2/lib/makefile
+--- 17FEBpl1.2.orig/lib/makefile 2017-04-26 11:44:02.000000000 +0200
++++ 17FEBpl1.2/lib/makefile 2017-09-25 21:08:51.359595847 +0200
+@@ -58,7 +58,7 @@
+ ## Ubuntu version 13.10 on
+ ##
+ ## $(SH_CMD) -o $(LIBMIDAS_SH) *.o $(DEV_NULL)
+- $(SH_CMD) -o $(LIBMIDAS_SH) *.o -lm $(F2C_LIBS) $(DEV_NULL)
++ $(SH_CMD) -o $(LIBMIDAS_SH) *.o -lm $(F2C_LIBS) $(RPC_LIB) $(DEV_NULL)
+
+ # for the AltLinux distro we had to change the line above to:
+ # $(SH_CMD) -o $(LIBMIDAS_SH) *.o -lm $(DEV_NULL)
+diff -ruN 17FEBpl1.2.orig/libsrc/os/unix/makefile 17FEBpl1.2/libsrc/os/unix/makefile
+--- 17FEBpl1.2.orig/libsrc/os/unix/makefile 2017-04-26 11:44:32.000000000 +0200
++++ 17FEBpl1.2/libsrc/os/unix/makefile 2017-09-25 21:08:48.747583816 +0200
+@@ -19,7 +19,7 @@
+
+ include ../../../local/default.mk
+
+-CFLAGS += $(C_OPT) $(DEBUG) $(MEM_OPT) $(SH_OPT) $(OSSYS) $(SYS) -I$(INC)
++CFLAGS += $(C_OPT) $(DEBUG) $(MEM_OPT) $(SH_OPT) $(OSSYS) $(SYS) -I$(INC) $(RPC_OPT)
+
+ LIB = $(LIBDIR)/libos.a
+
+@@ -43,7 +43,7 @@
+ # testos.exe only for checking the linking process, in cannot be executed...
+
+ testos.exe: testos.o $(LIB)
+- $(LDCC) testos.o $(LIB) $(MLIB) $(SLIB) -o $@
++ $(LDCC) testos.o $(LIB) $(MLIB) $(SLIB) $(RPC_LIB) -o $@
+ $(STRIP) $@
+
+ $(LIB): $(OBJ)