summaryrefslogtreecommitdiff
path: root/sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch')
-rw-r--r--sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch b/sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch
new file mode 100644
index 000000000000..d56ec03346c9
--- /dev/null
+++ b/sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch
@@ -0,0 +1,33 @@
+diff -ruN 17FEBpl1.2.orig/lib/makefile 17FEBpl1.2/lib/makefile
+--- 17FEBpl1.2.orig/lib/makefile 2017-04-26 11:44:02.000000000 +0200
++++ 17FEBpl1.2/lib/makefile 2017-09-25 21:08:51.359595847 +0200
+@@ -58,7 +58,7 @@
+ ## Ubuntu version 13.10 on
+ ##
+ ## $(SH_CMD) -o $(LIBMIDAS_SH) *.o $(DEV_NULL)
+- $(SH_CMD) -o $(LIBMIDAS_SH) *.o -lm $(F2C_LIBS) $(DEV_NULL)
++ $(SH_CMD) -o $(LIBMIDAS_SH) *.o -lm $(F2C_LIBS) $(RPC_LIB) $(DEV_NULL)
+
+ # for the AltLinux distro we had to change the line above to:
+ # $(SH_CMD) -o $(LIBMIDAS_SH) *.o -lm $(DEV_NULL)
+diff -ruN 17FEBpl1.2.orig/libsrc/os/unix/makefile 17FEBpl1.2/libsrc/os/unix/makefile
+--- 17FEBpl1.2.orig/libsrc/os/unix/makefile 2017-04-26 11:44:32.000000000 +0200
++++ 17FEBpl1.2/libsrc/os/unix/makefile 2017-09-25 21:08:48.747583816 +0200
+@@ -19,7 +19,7 @@
+
+ include ../../../local/default.mk
+
+-CFLAGS += $(C_OPT) $(DEBUG) $(MEM_OPT) $(SH_OPT) $(OSSYS) $(SYS) -I$(INC)
++CFLAGS += $(C_OPT) $(DEBUG) $(MEM_OPT) $(SH_OPT) $(OSSYS) $(SYS) -I$(INC) $(RPC_OPT)
+
+ LIB = $(LIBDIR)/libos.a
+
+@@ -43,7 +43,7 @@
+ # testos.exe only for checking the linking process, in cannot be executed...
+
+ testos.exe: testos.o $(LIB)
+- $(LDCC) testos.o $(LIB) $(MLIB) $(SLIB) -o $@
++ $(LDCC) testos.o $(LIB) $(MLIB) $(SLIB) $(RPC_LIB) -o $@
+ $(STRIP) $@
+
+ $(LIB): $(OBJ)