summaryrefslogtreecommitdiff
path: root/dev-ros/roslib/roslib-1.15.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-ros/roslib/roslib-1.15.8.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-ros/roslib/roslib-1.15.8.ebuild')
-rw-r--r--dev-ros/roslib/roslib-1.15.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/roslib/roslib-1.15.8.ebuild b/dev-ros/roslib/roslib-1.15.8.ebuild
new file mode 100644
index 000000000000..ce412cbff520
--- /dev/null
+++ b/dev-ros/roslib/roslib-1.15.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=core/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Base dependencies and support libraries for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep ">=dev-python/rospkg-1.0.37[\${PYTHON_USEDEP}]")
+ dev-libs/boost:=[threads(+)]
+ dev-ros/rospack
+ dev-ros/ros_environment
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}/../../"
+ ros-catkin_src_test
+}