summaryrefslogtreecommitdiff
path: root/dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild')
-rw-r--r--dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild b/dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild
new file mode 100644
index 000000000000..e28046b6462d
--- /dev/null
+++ b/dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command to print aggregated diagnostic contents to the command line"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+"
+RDEPEND="${DEPEND}"