summaryrefslogtreecommitdiff
path: root/dev-ros/move_base/move_base-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/move_base/move_base-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/move_base/move_base-9999.ebuild')
-rw-r--r--dev-ros/move_base/move_base-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/move_base/move_base-9999.ebuild b/dev-ros/move_base/move_base-9999.ebuild
new file mode 100644
index 000000000000..2905e24c89be
--- /dev/null
+++ b/dev-ros/move_base/move_base-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Given a goal in the world, will attempt to reach it with a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.15.1
+ dev-ros/roscpp
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/actionlib
+ dev-ros/base_local_planner
+ dev-ros/clear_costmap_recovery
+ dev-ros/navfn
+ dev-ros/rotate_recovery
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/tf
+ dev-ros/move_base_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"