summaryrefslogtreecommitdiff
path: root/dev-ros/move_base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/move_base
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/move_base')
-rw-r--r--dev-ros/move_base/Manifest6
-rw-r--r--dev-ros/move_base/metadata.xml11
-rw-r--r--dev-ros/move_base/move_base-1.15.1-r2.ebuild37
-rw-r--r--dev-ros/move_base/move_base-1.15.2.ebuild37
-rw-r--r--dev-ros/move_base/move_base-9999.ebuild37
5 files changed, 128 insertions, 0 deletions
diff --git a/dev-ros/move_base/Manifest b/dev-ros/move_base/Manifest
new file mode 100644
index 000000000000..b333b1fc150f
--- /dev/null
+++ b/dev-ros/move_base/Manifest
@@ -0,0 +1,6 @@
+DIST navigation-1.15.1.tar.gz 346480 BLAKE2B 29f9a0b6f2c62bd21a7cb87a64b490c845bb7db4af338fd094744abb22402df7eedc8c164b64f93f2d67dabaff99ca3b946b45e93173bed74834d9e3668726ad SHA512 25c5093bf7acca9d15d46bb2d0ae7e4ce0fa45f18b32d1626668dcbd33732317e8535b978e7225d86391472c517f05acb7736f31a7c511c8736ab8a22c7af4b0
+DIST navigation-1.15.2.tar.gz 348985 BLAKE2B 866779425828b1e4c3a044654ae41f33643646ca70cf6841f23bce265add2c420bf0934a41a6b29fa65fc421228a31dc15e9fb0f6cc4295ce12adbbb627b43d4 SHA512 582422756b31b4d83e929e3c723e7205e772b9775fcf618c9bd5d3c54af1f20e9bc8a0143626750c0c3cffeb0cbea8f8706b7e66f62dc037cfe12b05f23ee142
+EBUILD move_base-1.15.1-r2.ebuild 882 BLAKE2B c68f44cfe1582a8a66fee799f3a844daf4e507555510b565773c9741e489637bd5ed07b20538647b2599c4e842ffb2c28460e44baa2440c83549d80fefa16bc6 SHA512 80bd499cba6b095210a0d424ced28d65e5ebcece7d61b857db8eb0a78644f39099b22f2e82b9d14694963f58d51cca74509898c3038f8092f8fe958caed84b0b
+EBUILD move_base-1.15.2.ebuild 882 BLAKE2B c68f44cfe1582a8a66fee799f3a844daf4e507555510b565773c9741e489637bd5ed07b20538647b2599c4e842ffb2c28460e44baa2440c83549d80fefa16bc6 SHA512 80bd499cba6b095210a0d424ced28d65e5ebcece7d61b857db8eb0a78644f39099b22f2e82b9d14694963f58d51cca74509898c3038f8092f8fe958caed84b0b
+EBUILD move_base-9999.ebuild 882 BLAKE2B c68f44cfe1582a8a66fee799f3a844daf4e507555510b565773c9741e489637bd5ed07b20538647b2599c4e842ffb2c28460e44baa2440c83549d80fefa16bc6 SHA512 80bd499cba6b095210a0d424ced28d65e5ebcece7d61b857db8eb0a78644f39099b22f2e82b9d14694963f58d51cca74509898c3038f8092f8fe958caed84b0b
+MISC metadata.xml 337 BLAKE2B ecfbf3d0b63a1b876065d04b3d52daa0442e3bcaf060836731012a1e698b3aea06ff292d892035feb2fb0fc257d6d8462d013ccc67f2650177c9cdba4d051d44 SHA512 f5df7464100fa15a3d2ad11cc620007500a5cb5ea7be67ac45819a541dd4ae53ce476231d475acf4dfe7e7bf0c31281325dc4e003867d1cc01a29353bb5ea09e
diff --git a/dev-ros/move_base/metadata.xml b/dev-ros/move_base/metadata.xml
new file mode 100644
index 000000000000..7408fdf7047f
--- /dev/null
+++ b/dev-ros/move_base/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-planning/navigation</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/move_base/move_base-1.15.1-r2.ebuild b/dev-ros/move_base/move_base-1.15.1-r2.ebuild
new file mode 100644
index 000000000000..2905e24c89be
--- /dev/null
+++ b/dev-ros/move_base/move_base-1.15.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Given a goal in the world, will attempt to reach it with a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.15.1
+ dev-ros/roscpp
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/actionlib
+ dev-ros/base_local_planner
+ dev-ros/clear_costmap_recovery
+ dev-ros/navfn
+ dev-ros/rotate_recovery
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/tf
+ dev-ros/move_base_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"
diff --git a/dev-ros/move_base/move_base-1.15.2.ebuild b/dev-ros/move_base/move_base-1.15.2.ebuild
new file mode 100644
index 000000000000..2905e24c89be
--- /dev/null
+++ b/dev-ros/move_base/move_base-1.15.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Given a goal in the world, will attempt to reach it with a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.15.1
+ dev-ros/roscpp
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/actionlib
+ dev-ros/base_local_planner
+ dev-ros/clear_costmap_recovery
+ dev-ros/navfn
+ dev-ros/rotate_recovery
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/tf
+ dev-ros/move_base_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"
diff --git a/dev-ros/move_base/move_base-9999.ebuild b/dev-ros/move_base/move_base-9999.ebuild
new file mode 100644
index 000000000000..2905e24c89be
--- /dev/null
+++ b/dev-ros/move_base/move_base-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Given a goal in the world, will attempt to reach it with a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.15.1
+ dev-ros/roscpp
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/actionlib
+ dev-ros/base_local_planner
+ dev-ros/clear_costmap_recovery
+ dev-ros/navfn
+ dev-ros/rotate_recovery
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/tf
+ dev-ros/move_base_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"