summaryrefslogtreecommitdiff
path: root/www-plugins/pdfjs/pdfjs-2.1.266.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/pdfjs/pdfjs-2.1.266.ebuild')
-rw-r--r--www-plugins/pdfjs/pdfjs-2.1.266.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/www-plugins/pdfjs/pdfjs-2.1.266.ebuild b/www-plugins/pdfjs/pdfjs-2.1.266.ebuild
new file mode 100644
index 000000000000..8cf32af52960
--- /dev/null
+++ b/www-plugins/pdfjs/pdfjs-2.1.266.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A PDF reader in JavaScript"
+HOMEPAGE="https://mozilla.github.io/pdf.js/"
+SRC_URI="https://github.com/mozilla/pdf.js/releases/download/v${PV}/${P}-dist.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/pdf.js/
+
+ doins -r build
+ doins -r web
+}