summaryrefslogtreecommitdiff
path: root/sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild')
-rw-r--r--sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild b/sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild
new file mode 100644
index 000000000000..e96418f15b69
--- /dev/null
+++ b/sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN="INTEL-SA-00075-Linux-Detection-And-Mitigation-Tools"
+
+DESCRIPTION="Tools from Intel to detect and mitigate the AMT/MEI vulnerability"
+HOMEPAGE="https://downloadcenter.intel.com/download/26799/INTEL-SA-00075-Linux-Detection-and-Mitigation-Tools"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=("${FILESDIR}/${PN}-makefile.patch")
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}