summaryrefslogtreecommitdiff
path: root/sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-18 12:04:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-18 12:04:39 +0100
commit2d01b3d133c0fbf17de8d7b47905585af88bd6e4 (patch)
treef74eb9a3d16ed25f8c15b825f4d28b759ae99a42 /sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild
parent97bacba3ead078e5db8b87ab651a3ffa7d82f60f (diff)
gentoo auto-resync : 18:04:2024 - 12:04:39
Diffstat (limited to 'sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild')
-rw-r--r--sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild b/sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild
new file mode 100644
index 000000000000..e96418f15b69
--- /dev/null
+++ b/sys-apps/intel-sa-00075-tools/intel-sa-00075-tools-1.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN="INTEL-SA-00075-Linux-Detection-And-Mitigation-Tools"
+
+DESCRIPTION="Tools from Intel to detect and mitigate the AMT/MEI vulnerability"
+HOMEPAGE="https://downloadcenter.intel.com/download/26799/INTEL-SA-00075-Linux-Detection-and-Mitigation-Tools"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=("${FILESDIR}/${PN}-makefile.patch")
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}