summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-functions
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gentoo-functions')
-rw-r--r--sys-apps/gentoo-functions/Manifest2
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.15.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
index eed28fb9da5b..99b12f56889b 100644
--- a/sys-apps/gentoo-functions/Manifest
+++ b/sys-apps/gentoo-functions/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-functions-0.14.tar.gz 11330 BLAKE2B 72543941f2954e35d3671c1c482eda44ae00cf0c636a1d706c5b90c56dfbb985d20c156b6de650e5d33ff9fac0abaf9fc50b1172832c2bd5276f6adfe5baf3b8 SHA512 e1e0fee9f3e8b79478aaf2b9a54c8623c858e62f72f2885ea88f7006631cf513bdfaac7122f2a5fc97379bde57851793bf7d6c63a1c63a6923a7f13a73d803fc
+DIST gentoo-functions-0.15.tar.gz 11236 BLAKE2B da3df4ee809c33a7aa275757380584abcc70dc5f54d32b2e9d3336a9453cfc935e932df065a65a7458b885a449774713fead5aea99ea5e7ee522e5493d35482b SHA512 b2a42e5b43c487d62e036eade88b5cc8e0f4eb249c783837a0293cdbba4ed8a1eea8742d531885bcc56eefa337853c41d257b6a9880fc0e7420b490bb6f98fd4
EBUILD gentoo-functions-0.14.ebuild 856 BLAKE2B a6b02beaf3908fcce0a652d49d2168992be2a5ea96c106606b8415a80c965f347a3786b06f62b0bee0727ef894990f9673fb0184768939856abb9e4f7c50c4ca SHA512 053d4d88f29f95f54320a1663f361a8a012591d2b9e5c1872a1772c8f0fc64f86e7b54311aca3e96e77f78714507f9bde9e779cab23fb6657b85f622a5a3df4b
+EBUILD gentoo-functions-0.15.ebuild 864 BLAKE2B 7516cfa9a50f69cbcd702945da6b83fa6975727f2f03af81243f18c8da302ea31fede39cb5831507e2e77ce50c9b8f336bcaeb20ae69a854bb4c2c86cfe112e8 SHA512 1c0b8e1d97910207d2d128998631799dd39ac3af3393cd3da8c11e6bfed58046afef8473953af2bec9b2b32f1107484d3dc26c773e69e5645205b1cd028ab506
EBUILD gentoo-functions-9999.ebuild 864 BLAKE2B 7516cfa9a50f69cbcd702945da6b83fa6975727f2f03af81243f18c8da302ea31fede39cb5831507e2e77ce50c9b8f336bcaeb20ae69a854bb4c2c86cfe112e8 SHA512 1c0b8e1d97910207d2d128998631799dd39ac3af3393cd3da8c11e6bfed58046afef8473953af2bec9b2b32f1107484d3dc26c773e69e5645205b1cd028ab506
MISC metadata.xml 492 BLAKE2B cd68fc088438ae1171d801f7aeb93ac09a21dd2e628ab14c11e2f3f28fba3ad3653005d087ab5c44362b9b6fbc66b1c14256176c6f181313cbf3aa6a01c6739b SHA512 991fa3c3f302d26f4beb103c5dab1b943599aa83ca538b04a785ba608059471047061296d219b637a8b16185105c0ace8b0ff511ec2d94c840be27d96ac8e3c6
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.15.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.15.ebuild
new file mode 100644
index 000000000000..6ab30b8f6eb4
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2014-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="base functions required by all Gentoo systems"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_configure() {
+ tc-export CC
+ append-lfs-flags
+ export ROOTPREFIX="${EPREFIX}"
+ export PREFIX="${EPREFIX}/usr"
+}