summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-functions/gentoo-functions-0.15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gentoo-functions/gentoo-functions-0.15.ebuild')
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.15.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.15.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.15.ebuild
new file mode 100644
index 000000000000..6ab30b8f6eb4
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2014-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="base functions required by all Gentoo systems"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_configure() {
+ tc-export CC
+ append-lfs-flags
+ export ROOTPREFIX="${EPREFIX}"
+ export PREFIX="${EPREFIX}/usr"
+}