summaryrefslogtreecommitdiff
path: root/sci-libs/symmetrica
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/symmetrica')
-rw-r--r--sci-libs/symmetrica/Manifest3
-rw-r--r--sci-libs/symmetrica/metadata.xml24
-rw-r--r--sci-libs/symmetrica/symmetrica-3.0.1.ebuild24
3 files changed, 51 insertions, 0 deletions
diff --git a/sci-libs/symmetrica/Manifest b/sci-libs/symmetrica/Manifest
new file mode 100644
index 000000000000..ecdb905ef818
--- /dev/null
+++ b/sci-libs/symmetrica/Manifest
@@ -0,0 +1,3 @@
+DIST symmetrica-3.0.1.tar.xz 789336 BLAKE2B 88521356bdc006413e0922b49b23f345da96bbe8cb2a4a6ae12bf53fe46150078f086e6d1f6e514817453f2a868b6eb578b716c05f5459397ed8d766d321ec24 SHA512 1e4c42e1ae9fcdf246dff1c1f01522d6cd416c12302363f82356018847df2f64d2f5ea6256459832d195e8e333ae14743794d5a53346e92d8ba1bb1c0949c271
+EBUILD symmetrica-3.0.1.ebuild 541 BLAKE2B 22f83c5bbc0417db88d50edc92c6322522d71252c9cf8b4a06bbe62478a20cb38f2dc57b9e04dd2ad47cb22da42bdfdc5113995f6d0e2a99d3c9c2b2bc596fd2 SHA512 0fcf66b30e39bc57963a8e3cbb735de24bee62f262755756176dc6fde66d13c9d59ef2c5e9291619cdf067e0a6762af953710238e663aa77d47fbc3b2afeeef3
+MISC metadata.xml 758 BLAKE2B cd3bc063da1f4ec9e18b045427b2ae77ff7c786c23ceb5e627589e644d384381a2b330c31713d5099bd12657c68dc4c4d91d0a80dfe6afb59568f60a948ead16 SHA512 69bc2b7f8dffeb94dba8af9bfefe537e5c9f946587a9e2b6e41e9f27927cd980fe1f1ab7f0a7d94f18f1c82ab577c79fb21ae7d05bf99fccdb2ddb40d7f62b38
diff --git a/sci-libs/symmetrica/metadata.xml b/sci-libs/symmetrica/metadata.xml
new file mode 100644
index 000000000000..3704ab7e98b1
--- /dev/null
+++ b/sci-libs/symmetrica/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="gitlab">https://gitlab.com/sagemath/symmetrica</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/symmetrica/symmetrica-3.0.1.ebuild b/sci-libs/symmetrica/symmetrica-3.0.1.ebuild
new file mode 100644
index 000000000000..eab633507c88
--- /dev/null
+++ b/sci-libs/symmetrica/symmetrica-3.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C library for representation theory, combinatorics, and more"
+HOMEPAGE="https://gitlab.com/sagemath/symmetrica"
+SRC_URI="https://gitlab.com/sagemath/symmetrica/uploads/b3d8e1ad5ab2449c30bbc3147e7a5e53/symmetrica-3.0.1.tar.xz"
+
+LICENSE="ISC"
+SLOT="0/2"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DOCS=( README.md )
+
+src_configure(){
+ econf $(use_enable doc)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}