summaryrefslogtreecommitdiff
path: root/sci-libs/symmetrica/symmetrica-3.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/symmetrica/symmetrica-3.0.1.ebuild')
-rw-r--r--sci-libs/symmetrica/symmetrica-3.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-libs/symmetrica/symmetrica-3.0.1.ebuild b/sci-libs/symmetrica/symmetrica-3.0.1.ebuild
new file mode 100644
index 000000000000..eab633507c88
--- /dev/null
+++ b/sci-libs/symmetrica/symmetrica-3.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C library for representation theory, combinatorics, and more"
+HOMEPAGE="https://gitlab.com/sagemath/symmetrica"
+SRC_URI="https://gitlab.com/sagemath/symmetrica/uploads/b3d8e1ad5ab2449c30bbc3147e7a5e53/symmetrica-3.0.1.tar.xz"
+
+LICENSE="ISC"
+SLOT="0/2"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DOCS=( README.md )
+
+src_configure(){
+ econf $(use_enable doc)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}