summaryrefslogtreecommitdiff
path: root/sci-libs/cdd+/cdd+-077a.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cdd+/cdd+-077a.ebuild')
-rw-r--r--sci-libs/cdd+/cdd+-077a.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/sci-libs/cdd+/cdd+-077a.ebuild b/sci-libs/cdd+/cdd+-077a.ebuild
index b0f5d66efdd8..12930c685aba 100644
--- a/sci-libs/cdd+/cdd+-077a.ebuild
+++ b/sci-libs/cdd+/cdd+-077a.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit epatch multilib toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Another implementation of the double description method"
HOMEPAGE="http://www.ifor.math.ethz.ch/~fukuda/cdd_home/"
@@ -12,27 +12,25 @@ SRC_URI="ftp://ftp.ifor.math.ethz.ch/pub/fukuda/cdd/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE=""
DEPEND="dev-libs/gmp:0="
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-headers.patch \
- "${FILESDIR}"/${P}-gentoo.patch \
- "${FILESDIR}"/${P}-gcc-5.patch \
- "${FILESDIR}"/${P}-qa-const-char.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-headers.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-gcc-5.patch
+ "${FILESDIR}"/${P}-qa-const-char.patch
+ "${FILESDIR}"/${P}-gcc11-dynamic-exceptions.patch
+)
src_compile() {
emake \
CC="$(tc-getCC)" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- GMPLIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- GMPINCLUDE="${EPREFIX}/usr/include" \
+ GMPLIBDIR="${ESYSROOT}/usr/$(get_libdir)" \
+ GMPINCLUDE="${ESYSROOT}/usr/include" \
all
-
}
src_install() {