summaryrefslogtreecommitdiff
path: root/sci-libs/cdd+/cdd+-077a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /sci-libs/cdd+/cdd+-077a.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'sci-libs/cdd+/cdd+-077a.ebuild')
-rw-r--r--sci-libs/cdd+/cdd+-077a.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/sci-libs/cdd+/cdd+-077a.ebuild b/sci-libs/cdd+/cdd+-077a.ebuild
index b0f5d66efdd8..12930c685aba 100644
--- a/sci-libs/cdd+/cdd+-077a.ebuild
+++ b/sci-libs/cdd+/cdd+-077a.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit epatch multilib toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Another implementation of the double description method"
HOMEPAGE="http://www.ifor.math.ethz.ch/~fukuda/cdd_home/"
@@ -12,27 +12,25 @@ SRC_URI="ftp://ftp.ifor.math.ethz.ch/pub/fukuda/cdd/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE=""
DEPEND="dev-libs/gmp:0="
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-headers.patch \
- "${FILESDIR}"/${P}-gentoo.patch \
- "${FILESDIR}"/${P}-gcc-5.patch \
- "${FILESDIR}"/${P}-qa-const-char.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-headers.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-gcc-5.patch
+ "${FILESDIR}"/${P}-qa-const-char.patch
+ "${FILESDIR}"/${P}-gcc11-dynamic-exceptions.patch
+)
src_compile() {
emake \
CC="$(tc-getCC)" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- GMPLIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- GMPINCLUDE="${EPREFIX}/usr/include" \
+ GMPLIBDIR="${ESYSROOT}/usr/$(get_libdir)" \
+ GMPINCLUDE="${ESYSROOT}/usr/include" \
all
-
}
src_install() {