summaryrefslogtreecommitdiff
path: root/sci-libs/branca
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/branca')
-rw-r--r--sci-libs/branca/Manifest4
-rw-r--r--sci-libs/branca/branca-0.4.2.ebuild30
-rw-r--r--sci-libs/branca/files/branca-0.4.2-test.patch14
-rw-r--r--sci-libs/branca/metadata.xml16
4 files changed, 64 insertions, 0 deletions
diff --git a/sci-libs/branca/Manifest b/sci-libs/branca/Manifest
new file mode 100644
index 000000000000..ae0b6b5ac69b
--- /dev/null
+++ b/sci-libs/branca/Manifest
@@ -0,0 +1,4 @@
+AUX branca-0.4.2-test.patch 358 BLAKE2B 087756ebe2507101eaf8c18b2726294b3eec99f7708fff092217b6083ea4f85878c2671671fb8bfbddf92822b60dbdcc737bc0eef0d46b33e1e74f00e244c470 SHA512 81d6542e259c7233e3a2c926b07cadd9fbc930db7d25f552d8febb70f3d689f57f01c49c0b6cc5e795e7fa817a7989a05a8b2768162d730b021bb6a4f2ff3925
+DIST branca-0.4.2.tar.gz 59337 BLAKE2B 7d7f101a3dcc07c0210f968da2ed41f4a75177b625ce46252024da7dbba82618dbe60886c615c9461c724af76b45c7710f631bc65d5743cee7f18a2052f9db49 SHA512 cefb3b0f41d515492902ef4046cf7f10b638aca8409f5b08f201550ed5a971a441d13243b1ce38ac0b8c0f76cde1329955d26c1856e1f3c25014a6ce0d805fd6
+EBUILD branca-0.4.2.ebuild 690 BLAKE2B 73e8827c08d67736567ea7d848b72f273f20a995d292624f24856cd64bd6666baba2e3fd5f6a5d58f669c3507365bc0e724da9bca413042ea594a2d11c8c4dca SHA512 692c3d5af1abc488ce49f3566ebb7e3013508ea9657e34214a637f523a147232f009e65e1404be1e0fc028621591b803ff8035165135d3a30da197293849e487
+MISC metadata.xml 566 BLAKE2B a5480589b81b88e433fc25420876d44f2d2c44bac5283c7b06c203d6fbe05afc46f0f17c2d35721894dc88d52686bf5a7386eeb55a8142695ec45961cf0d75f1 SHA512 fa78103653a5554470eb01f24e6c32412697c99fe9d3b1a75a18918c9fde42b649748c2bd9534af41e61f16255bd0794b86354fcd0d0f1942fb017316a2d78b7
diff --git a/sci-libs/branca/branca-0.4.2.ebuild b/sci-libs/branca/branca-0.4.2.ebuild
new file mode 100644
index 000000000000..f536554b7301
--- /dev/null
+++ b/sci-libs/branca/branca-0.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="spinoff from folium, host the non-map-specific features."
+HOMEPAGE="https://github.com/python-visualization/branca"
+SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m 'not headless'
+}
diff --git a/sci-libs/branca/files/branca-0.4.2-test.patch b/sci-libs/branca/files/branca-0.4.2-test.patch
new file mode 100644
index 000000000000..8c1525d69bf7
--- /dev/null
+++ b/sci-libs/branca/files/branca-0.4.2-test.patch
@@ -0,0 +1,14 @@
+--- a/setup.cfg 2021-07-30 21:13:41.303271681 +0200
++++ b/setup.cfg 2021-07-30 21:13:49.133164898 +0200
+@@ -11,11 +11,6 @@
+ parentdir_prefix =
+
+ [tool:pytest]
+-flake8-max-line-length = 105
+-flake8-ignore =
+- docs/* ALL
+- versioneer.py ALL
+- branca/_version.py ALL
+ markers =
+ headless: mark headless tests (deselect with '-m "not headless"')
+
diff --git a/sci-libs/branca/metadata.xml b/sci-libs/branca/metadata.xml
new file mode 100644
index 000000000000..6e83a06af3af
--- /dev/null
+++ b/sci-libs/branca/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ This library is a spinoff from folium, that would host the non-map-specific features.
+ It may become a HTML+JS generation library in the future.
+ It is based on Jinja2 only.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">python-visualization/branca</remote-id>
+ </upstream>
+</pkgmetadata>