summaryrefslogtreecommitdiff
path: root/sci-libs/branca/branca-0.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/branca/branca-0.4.2.ebuild')
-rw-r--r--sci-libs/branca/branca-0.4.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/branca/branca-0.4.2.ebuild b/sci-libs/branca/branca-0.4.2.ebuild
new file mode 100644
index 000000000000..f536554b7301
--- /dev/null
+++ b/sci-libs/branca/branca-0.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="spinoff from folium, host the non-map-specific features."
+HOMEPAGE="https://github.com/python-visualization/branca"
+SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m 'not headless'
+}