summaryrefslogtreecommitdiff
path: root/sci-chemistry/autodock
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/autodock')
-rw-r--r--sci-chemistry/autodock/Manifest4
-rw-r--r--sci-chemistry/autodock/autodock-4.2.6.ebuild68
-rw-r--r--sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch12
3 files changed, 48 insertions, 36 deletions
diff --git a/sci-chemistry/autodock/Manifest b/sci-chemistry/autodock/Manifest
index 065022beda3e..45cbb04a2703 100644
--- a/sci-chemistry/autodock/Manifest
+++ b/sci-chemistry/autodock/Manifest
@@ -1,4 +1,4 @@
-AUX autodock-4.2.6-buildsystem.patch 1500 BLAKE2B d295cdc7e46ecad118b7747aa26c97c5d08d54f28fecbb09e1c356fcf1e977164acb57dfa3ecc57fef28e4a37b6d16f9741c1fdb6c8f1c3b3a3b3d9085fd75f6 SHA512 08a7643e2973f2ebdd01c54acb1e3e0802ea3d7a33cbed4c03f58d29c7e13a246418feb4a61088dae18c3ab78db6fd5b3c11f9974dec59fe46dbf7cfbbe98c3a
+AUX autodock-4.2.6-buildsystem.patch 1480 BLAKE2B 3f1884ee05e062cb630b43fe3e8ecf6f827ada23d5d3060a5bb3d7e854f7c5e2d2b1f7a476c4effcdcbab4292b33fae093474773a31a6995465d00dbbb721246 SHA512 9c5b05f4831049c2c064358df26124526973110ddd31ffa7930f185694f9258dfce648085a96f05a2173aa61b4cdcda7a6fe170a56160708e031fb248f9e6bbe
DIST autodocksuite-4.2.6-src.tar.gz 35438010 BLAKE2B 88e036ecc0492fb83f31b90fd0983ec57d889a61d17249f672a3e30e942f6c329dc2494088a8fc7c5bc39a5bdbb38fb1514f1750c7145374f202a928d477faa9 SHA512 75b8878f948c4f6bc28adb442997192dad0c36bbede2fd698623903cb27b06b4df3ba038bfc70fc13b4bdee864fd2344f0f7208be2020da4e01a00b842b46bbb
-EBUILD autodock-4.2.6.ebuild 2202 BLAKE2B f425ab34d6941523d6c8b1c8740b4b8a2aa89b49c965466af77c8dda0cc4ef3d24a9c5a40ad82156497f24f6d3afb341e697838446d96195fd6a990b909160b4 SHA512 516d12bbf27984ecd844bae777c408790f7288b08d025fc618920458181dc57abbe3442b69270c1209afa6ebb45b11e774f60e1721452d790119270157336252
+EBUILD autodock-4.2.6.ebuild 2337 BLAKE2B 3302c9d3690f3faf97ef2265512de2c31b0b83752ed92375ecc822e42125eb50324a97197131b5280c71e1a165d1052f4250d06ed412d0b86034464168e9ef49 SHA512 3f215c0d54059f77da1623a9d5602e81e652d84382b327c3deee86f8cdb2d5392476d62288452881977f1582fa36474c648e7e519b5cf7fd7d1a926778697941
MISC metadata.xml 271 BLAKE2B a446884cbe7a6789e0bcd82759f57bf1ab7b29c5ab714057ffa821c90f799d1fa9f9310c187ee4c3a8ae2476f6ea9d15f368045779f1581e68d02802c61c884c SHA512 3e6e6047a29e07123b81279cae1de17bc4bd4c3d7d8a8d26560114a18185f473d038fc220fa81c7213fa203ce197bad8b1c272d9b7e41cd770a953fa6308ff92
diff --git a/sci-chemistry/autodock/autodock-4.2.6.ebuild b/sci-chemistry/autodock/autodock-4.2.6.ebuild
index 6cfe76fbbfd0..b4dce2e439b4 100644
--- a/sci-chemistry/autodock/autodock-4.2.6.ebuild
+++ b/sci-chemistry/autodock/autodock-4.2.6.ebuild
@@ -1,38 +1,56 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
+# Tests require python2
+#PYTHON_COMPAT=( python2_7 )
-inherit autotools eutils python-any-r1 versionator
+inherit autotools readme.gentoo-r1 #python-any-r1
MY_PN="autodocksuite"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="A suite of automated docking tools"
HOMEPAGE="http://autodock.scripps.edu/"
-SRC_URI="http://autodock.scripps.edu/downloads/autodock-registration/tars/dist$(delete_all_version_separators)/${MY_P}-src.tar.gz"
+SRC_URI="http://autodock.scripps.edu/downloads/autodock-registration/tars/dist$(ver_rs 1- '')/${MY_P}-src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="examples openmp test"
-RESTRICT="!test? ( test )"
+
+IUSE="examples openmp" #test
+#RESTRICT="!test? ( test )"
+
+# False positives caused by nested configure scripts
+QA_CONFIGURE_OPTIONS=".*"
RDEPEND=""
-DEPEND="test? ( ${PYTHON_DEPS} )"
+DEPEND=""
+#DEPEND="test? ( ${PYTHON_DEPS} )"
S="${WORKDIR}/src"
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+The AutoDock development team requests all users to fill out the
+registration form at:
+
+http://autodock.scripps.edu/downloads/autodock-registration
+
+The number of unique users of AutoDock is used by Prof. Arthur J.
+Olson and the Scripps Research Institude to support grant
+applications.
+"
+
PATCHES=(
"${FILESDIR}"/${P}-buildsystem.patch
)
src_prepare() {
- local i
+ default
- epatch "${PATCHES[@]}"
+ local i
sed \
-e "s/\tcsh/\tsh/" \
@@ -58,15 +76,15 @@ src_compile() {
emake -C autogrid
}
-src_test() {
- elog "Testing autodock"
- cd "${S}/autodock/Tests" || die
- cp ../*.dat . || die
- ${EPYTHON} test_autodock4.py || die "AutoDock tests failed."
- einfo "Testing autogrid"
- cd "${S}/autogrid/Tests" || die
- ${EPYTHON} test_autogrid4.py || die "AutoGrid tests failed."
-}
+#src_test() {
+# elog "Testing autodock"
+# cd "${S}/autodock/Tests" || die
+# cp ../*.dat . || die
+# ${EPYTHON} test_autodock4.py || die "AutoDock tests failed."
+# einfo "Testing autogrid"
+# cd "${S}/autogrid/Tests" || die
+# ${EPYTHON} test_autogrid4.py || die "AutoGrid tests failed."
+#}
src_install() {
if use openmp; then
@@ -79,7 +97,7 @@ src_install() {
insinto /usr/share/${PN}
doins -r \
autodock/{AD4_parameters.dat,AD4_PARM99.dat} \
- $(usex examples "autodoc/EXAMPLES" "")
+ $(usex examples "autodock/EXAMPLES" "")
DOCS=(
RELEASENOTES
@@ -88,15 +106,9 @@ src_install() {
autodock/USERGUIDES/AutoDock4.2_UserGuide.pdf
)
einstalldocs
+ readme.gentoo_create_doc
}
pkg_postinst() {
- elog "The AutoDock development team requests all users to fill out the"
- elog "registration form at:"
- echo
- elog "\thttp://autodock.scripps.edu/downloads/autodock-registration"
- echo
- elog "The number of unique users of AutoDock is used by Prof. Arthur J."
- elog "Olson and the Scripps Research Institude to support grant"
- elog "applications."
+ readme.gentoo_print_elog
}
diff --git a/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch b/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch
index ae44ffeb3159..443dfcd868ce 100644
--- a/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch
+++ b/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch
@@ -1,11 +1,11 @@
- src/autodock/Makefile.am | 6 +++---
- src/autogrid/Makefile.am | 4 ++--
+ a/autodock/Makefile.am | 6 +++---
+ b/autogrid/Makefile.am | 4 ++--
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/src/autodock/Makefile.am b/src/autodock/Makefile.am
index 799a3c4..911897b 100644
---- a/src/autodock/Makefile.am
-+++ b/src/autodock/Makefile.am
+--- a/autodock/Makefile.am
++++ b/autodock/Makefile.am
@@ -459,7 +459,8 @@ endif
BUILT_SOURCES = $(autodock4_SOURCES) default_parameters.h
@@ -28,8 +28,8 @@ index 799a3c4..911897b 100644
diff --git a/src/autogrid/Makefile.am b/src/autogrid/Makefile.am
index b531099..b78b380 100644
---- a/src/autogrid/Makefile.am
-+++ b/src/autogrid/Makefile.am
+--- a/autogrid/Makefile.am
++++ b/autogrid/Makefile.am
@@ -94,9 +94,9 @@ autogrid4_SOURCES = main.cpp \
BUILT_SOURCES = default_parameters.h