summaryrefslogtreecommitdiff
path: root/sci-biology/last
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/last')
-rw-r--r--sci-biology/last/Manifest5
-rw-r--r--sci-biology/last/files/last-299-fix-build-system.patch74
-rw-r--r--sci-biology/last/files/last-299-portable-shebangs.patch99
-rw-r--r--sci-biology/last/last-299-r1.ebuild45
-rw-r--r--sci-biology/last/metadata.xml8
5 files changed, 0 insertions, 231 deletions
diff --git a/sci-biology/last/Manifest b/sci-biology/last/Manifest
deleted file mode 100644
index d2fab5c0d3f4..000000000000
--- a/sci-biology/last/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX last-299-fix-build-system.patch 2021 BLAKE2B 6b2c1e5830c0076a444841c9740bba9bc5389dd1996efc2ca79989d61162f1594e46f0b7b982a7d50b25284e6394e0e427f7dfe3fc7cc22dbdc15d12f3f8a11c SHA512 42df26ce39dd8d263581f20aee0a3fbea0c849fcb5b1627554f9d0b3d3cea55a13b7f42fca9048611a50fdd9e784fa2b537a876b6ded411601c78b2e13e2e19c
-AUX last-299-portable-shebangs.patch 2762 BLAKE2B cb92f32c7118cca83114ffb534d0db04d258a63825592721eb80ed0a699aa9adfbe0df6eb0b33de8647e238b295103632333e89847b9a6b1b4bea9e940113316 SHA512 343483b421e79996aee5480608cdf8b085e8c9c48f5b1f6a6e6e6bbddca9f8d9e1e3561924bc29bc9c60f30cc4c5e7e81d79e60847e35b3a9f7a53f7e3b8c3f6
-DIST last-299.zip 453159 BLAKE2B 3f8ddc24a2eba189880f2547f458ebbc2b349f0517c25165257f4cf3a90f68d8df313f7eece3930c33376aa0e16185c54b586b6f411975a1fb15e6426c535ca0 SHA512 74e89129cc17482ec1a99e2d940ca62374c130fea2fa53ea7d2c3703b6ca5751f348110909d61562c4839d8fb1793619c2f41c25c8968b3ab53f0c7191f4a00b
-EBUILD last-299-r1.ebuild 843 BLAKE2B ce536c49888cb0ca7620c24f1767c95b99547f9b05f5dabe744884b6bb1b5f6c19ca3cb8697799ef0817720b52fab870ec508c70c82897bdf3581e05b16e3112 SHA512 7892c3a4ab3f6a23af11a5b548f4f7d992497c25bb4eed8e0a9dcac3da9b9a41d7b8f2b97f88599c7831fee5c064b421b0876fe0b3c444395015a4a0918f57e2
-MISC metadata.xml 267 BLAKE2B 7cf386952842945148119de3263231db4d1046d5f54811f7e303ed8ec4d27cbc1960b99c92daf6f32e5b981c2fb9f50ec666be6193865d6e18541b7427a152a9 SHA512 91ab266d9ab24401bc0fec759c5b6cfcf44a3c5669fc31c7301d79770839bb5dfa0e155d949392ef06176b4a0b2c32b91b1b54b0027f972db61f0a5e54644403
diff --git a/sci-biology/last/files/last-299-fix-build-system.patch b/sci-biology/last/files/last-299-fix-build-system.patch
deleted file mode 100644
index 0a89cea60278..000000000000
--- a/sci-biology/last/files/last-299-fix-build-system.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-Make build system respect user flags
-
---- a/makefile
-+++ b/makefile
-@@ -1,6 +1,5 @@
--CXXFLAGS = -O3
- all:
-- @cd src && $(MAKE) CXXFLAGS="$(CXXFLAGS)"
-+ $(MAKE) -C src
-
- prefix = /usr/local
- exec_prefix = $(prefix)
-@@ -10,15 +9,15 @@
- cp src/last?? scripts/*.?? $(bindir)
-
- clean:
-- @cd src && $(MAKE) clean
-+ $(MAKE) -C src clean
-
- html:
-- @cd doc && $(MAKE)
-+ $(MAKE) -C doc
-
- distdir = last-`hg id -n`
-
- dist: log html
-- @cd src && $(MAKE) version.hh
-+ $(MAKE) -C src version.hh
- rsync -rC --exclude 'last??' doc examples makefile s* *.txt $(distdir)
- zip -qrm $(distdir) $(distdir)
-
---- a/src/makefile
-+++ b/src/makefile
-@@ -1,12 +1,9 @@
--CXX = g++
--CC = gcc
--
--CXXFLAGS = -O3 -Wall -Wextra -Wcast-qual -Wswitch-enum -Wundef \
---Wcast-align -Wno-long-long -ansi -pedantic
-+last_CXXFLAGS = -Wall -Wextra -Wcast-qual -Wswitch-enum -Wundef \
-+-Wcast-align -Wno-long-long -pedantic
- # -Wconversion
- # -fomit-frame-pointer ?
-
--CFLAGS = -Wall
-+last_CFLAGS = -Wall
-
- DBSRC = Alphabet.cc MultiSequence.cc CyclicSubsetSeed.cc \
- SubsetSuffixArray.cc LastdbArguments.cc io.cc fileMap.cc \
-@@ -49,17 +46,20 @@
-
- all: lastdb lastal lastex
-
-+.cpp.o:
-+ $(CXX) $(CPPFLAGS) $(last_CXXFLAGS) $(CXXFLAGS) -c -o $@ $<
-+
- lastdb: $(DBSRC) $(DBINC) makefile
-- $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(DBSRC)
-+ $(CXX) $(CPPFLAGS) $(last_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(DBSRC)
-
- lastal: $(ALSRC) $(ALINC) makefile $(OBJ)
-- $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(ALSRC) $(OBJ)
-+ $(CXX) $(CPPFLAGS) $(last_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(ALSRC) $(OBJ)
-
- lastex: $(EXSRC) $(EXINC) makefile
-- $(CXX) -Igumbel_params $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(EXSRC)
-+ $(CXX) $(CPPFLAGS) -Igumbel_params $(last_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(EXSRC)
-
- $(OBJ): CA_code/*.c CA_code/*.h makefile
-- $(CC) $(CPPFLAGS) $(CFLAGS) -c CA_code/lambda_calculator.c
-+ $(CC) $(CPPFLAGS) $(last_CFLAGS) $(CFLAGS) -c -o $@ CA_code/lambda_calculator.c
-
- clean:
- rm -f lastdb lastal lastex $(OBJ)
diff --git a/sci-biology/last/files/last-299-portable-shebangs.patch b/sci-biology/last/files/last-299-portable-shebangs.patch
deleted file mode 100644
index 03ecbdcbde20..000000000000
--- a/sci-biology/last/files/last-299-portable-shebangs.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-Make shebangs portable and prefix friendly
-See also: https://blogs.gentoo.org/mgorny/2016/02/08/a-quick-note-on-portable-shebangs/
-
---- a/scripts/last-dotplot.py
-+++ b/scripts/last-dotplot.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python2
-
- # Read pair-wise alignments in MAF or LAST tabular format: write an
- # "Oxford grid", a.k.a. dotplot.
---- a/scripts/last-map-probs.py
-+++ b/scripts/last-map-probs.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python2
-
- # Copyright 2010, 2011, 2012 Martin C. Frith
-
---- a/scripts/last-merge-batches.py
-+++ b/scripts/last-merge-batches.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python2
-
- # Copyright 2010, 2011 Martin C. Frith
-
---- a/scripts/last-pair-probs.py
-+++ b/scripts/last-pair-probs.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python2
-
- # Copyright 2011, 2012, 2013 Martin C. Frith
-
---- a/scripts/last-reduce-alignments.sh
-+++ b/scripts/last-reduce-alignments.sh
-@@ -1,4 +1,4 @@
--#! /bin/sh
-+#!/usr/bin/env sh
-
- # This script reads MAF-format alignments with lastal header
- # information, removes "uninteresting" alignments, and writes the
---- a/scripts/last-remove-dominated.py
-+++ b/scripts/last-remove-dominated.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python2
-
- # Read MAF-format alignments, and write those are not "dominated" by
- # any other one. X dominates Y if they overlap on the top sequence,
---- a/scripts/last-split-probs.py
-+++ b/scripts/last-split-probs.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python2
-
- # Copyright 2012 Martin C. Frith
-
---- a/scripts/maf-convert.py
-+++ b/scripts/maf-convert.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python2
- # Copyright 2010, 2011 Martin C. Frith
- # Read MAF-format alignments: write them in other formats.
- # Seems to work with Python 2.x, x>=4
---- a/scripts/maf-cull.py
-+++ b/scripts/maf-cull.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python2
-
- # Read MAF-format alignments. Write them, omitting alignments whose
- # coordinates in the top-most sequence are contained in those of >=
---- a/scripts/maf-join.py
-+++ b/scripts/maf-join.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python2
-
- # Copyright 2009, 2010, 2011 Martin C. Frith
-
---- a/scripts/maf-sort.sh
-+++ b/scripts/maf-sort.sh
-@@ -1,4 +1,4 @@
--#! /bin/sh
-+#!/usr/bin/env sh
-
- # Sort MAF-format alignments by sequence name, then strand, then start
- # position, then end position, of the top sequence. Also, merge
---- a/scripts/maf-swap.py
-+++ b/scripts/maf-swap.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python2
-
- # Read MAF-format alignments, and write them, after moving the Nth
- # sequence to the top in each alignment.
diff --git a/sci-biology/last/last-299-r1.ebuild b/sci-biology/last/last-299-r1.ebuild
deleted file mode 100644
index b6adee215970..000000000000
--- a/sci-biology/last/last-299-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit toolchain-funcs python-single-r1
-
-DESCRIPTION="Genome-scale comparison of biological sequences"
-HOMEPAGE="http://last.cbrc.jp/"
-SRC_URI="http://last.cbrc.jp/${P}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="app-arch/unzip"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-299-fix-build-system.patch
- "${FILESDIR}"/${PN}-299-portable-shebangs.patch
-)
-
-src_configure() {
- tc-export CC CXX
-}
-
-src_install() {
- local DOCS=( doc/*.txt ChangeLog.txt README.txt )
- local HTML_DOCS=( doc/*html )
- einstalldocs
-
- dobin src/last{al,db,ex}
-
- cd scripts || die
- local i
- for i in *py; do
- newbin ${i} ${i%.py}
- done
- dobin *sh
-}
diff --git a/sci-biology/last/metadata.xml b/sci-biology/last/metadata.xml
deleted file mode 100644
index 959160fe46b1..000000000000
--- a/sci-biology/last/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
-</pkgmetadata>