summaryrefslogtreecommitdiff
path: root/net-libs/liblockfile
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/liblockfile')
-rw-r--r--net-libs/liblockfile/Manifest2
-rw-r--r--net-libs/liblockfile/liblockfile-1.17.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/net-libs/liblockfile/Manifest b/net-libs/liblockfile/Manifest
index acbbbe099892..dd4efa522a5c 100644
--- a/net-libs/liblockfile/Manifest
+++ b/net-libs/liblockfile/Manifest
@@ -1,5 +1,7 @@
AUX Makefile.Darwin.in 2436 BLAKE2B 63d9ce283549b26921cfd317639da45723ab5129e79dc0df0f4c2fa2489264db1991b6e9b2e76fb04906b85325d171af7dc2bb4f7f880cdb76fcdca76b50cd2f SHA512 e39931c63a20d49f6010dd668132295cfd3e02f39566715448665715ee909de3179c1db496b78261866794cdb21ecb14ccdd505f45aea5d8d0b7b196c344f9a1
AUX liblockfile-1.16-makefile.patch 2851 BLAKE2B 52f6fcb117e6f49dc5c824766c067303c25d03095efb395e47d716b9bb0eb9a6affc7330d7537220f99afa64bb6ec14061de078f9313609d762bff066542c3ee SHA512 dd9cbf566ac8a933c4cee19a33cbe818904cf7be5aed05f2a17b87312267ac1716631c9fead4663b1979158363ff07218b0a486ee40c029fcd2a23142b59f275
DIST liblockfile-1.16.tar.gz 68591 BLAKE2B f41df23ee405425265dbf5ca66dacf8e5dac84f40c16d192f1afbb40399f2a68bb92f5e24bbf0d2fb7fc143a92f8fa2713ebccbab70ceb9e67d9c7ae21f42802 SHA512 ee75ecf0dd25744de4e3ce7d6b12483ead2deaf0cd6a527e8493100c5d714751fe97e057873c8c7b04a935f9b46a5ea502950f15d3ce54ecc63d997ab1cee33d
+DIST liblockfile-1.17.tar.gz 69834 BLAKE2B a3c88174d96fb84dc1226102a1678aecec35945b89adb6e143f32674188ff7406f89b05f7219748bf0e9c6207ff3b28b5b800706ffc11b733c294e1e1c232784 SHA512 2169ac2219950d6ec7def6b5cc712cc04d1a185dc9c09b364c8d47b7b3d15c3482a2200b591872da87eb784717b2ba3537fbc39d7075c329cc8ba48039473a83
EBUILD liblockfile-1.16.ebuild 1311 BLAKE2B 1495377f36328625a0407a76b1bc1a373f8ce3bbdae66600e3e00c6315d584bc29331794b568480c1118c3ce160dc80466a5a9e252dc05a00409c0283c6b41a0 SHA512 d4c32d400e2ec2bfcaec81b91e8bd50c61e546dadc33a69a193aaa5d4a258c8a8d05fe603f024a29ddb988932144ec14107b52c59c8b66fd33a8750a36674b08
+EBUILD liblockfile-1.17.ebuild 1339 BLAKE2B ad231a19f023856b49cd817eb7ddd13fd6b56e4a025407e3b7ae1294b1587af438cb1ee2fc34e2e5b3d026ca69750e10de3cb09d7933a01dc54d36263eb95982 SHA512 b995d514738241d26706f9009a3429be19c18aa5f7c6b92072437249d60516606e4f83fbfbeaa938ea72f8688d652084556e4e10835bd5ee5cd862d79d295782
MISC metadata.xml 251 BLAKE2B 40a09dc2a759fb83efc9e99d0165f78db9941c583d8063bfb4305a2f53e1fbe6a578bb333b488f82ff6d66c78d8816f8cc474350fb1adfb3caa4dccc3dc30de1 SHA512 45a605b4ec729f1fa1ef76330eb4b8427995af409786e0946ed79ef73f06e9c59ba89ddd34070db3cb600f113f05d5003a07bcc4e6ce70bfe699f0a10dbabe88
diff --git a/net-libs/liblockfile/liblockfile-1.17.ebuild b/net-libs/liblockfile/liblockfile-1.17.ebuild
new file mode 100644
index 000000000000..82d39902f7c3
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.17.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Implements functions designed to lock the standard mailboxes"
+HOMEPAGE="https://github.com/miquels/liblockfile"
+SRC_URI="https://github.com/miquels/liblockfile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="acct-group/mail"
+DEPEND="${RDEPEND}"
+
+DOCS=( Changelog README )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.16-makefile.patch"
+)
+
+src_prepare() {
+ default
+
+ # I don't feel like making the Makefile portable
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ cp "${FILESDIR}"/Makefile.Darwin.in Makefile.in || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local grp=mail
+
+ if use prefix ; then
+ # We never want to use LDCONFIG
+ export LDCONFIG=${EPREFIX}/bin/true
+ # In unprivileged installs this is "mail"
+ grp=$(id -g)
+ fi
+
+ local myeconfargs=(
+ --with-mailgroup=${grp}
+ --enable-shared
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${ED}" -type f -name "*.a" -delete || die
+ fi
+}