summaryrefslogtreecommitdiff
path: root/net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch')
-rw-r--r--net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch b/net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch
new file mode 100644
index 000000000000..4901678bfd6c
--- /dev/null
+++ b/net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch
@@ -0,0 +1,22 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0e8fbdee8b..3662aabdfe 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2309,6 +2309,7 @@ target_include_directories(grpc_test_util
+ ${_gRPC_ZLIB_INCLUDE_DIR}
+ )
+ target_link_libraries(grpc_test_util
++ PRIVATE
+ ${_gRPC_ALLTARGETS_LIBRARIES}
+ absl::failure_signal_handler
+ absl::stacktrace
+@@ -2322,7 +2323,8 @@ endif()
+
+ endif()
+ if(gRPC_BUILD_TESTS)
+-
++find_package(GTest REQUIRED)
++target_link_libraries(grpc_test_util PUBLIC GTest::gtest GTest::gmock)
+ add_library(grpc_test_util_unsecure
+ test/core/util/cmdline.cc
+ test/core/util/fuzzer_util.cc