summaryrefslogtreecommitdiff
path: root/net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch')
-rw-r--r--net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch b/net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch
new file mode 100644
index 000000000000..4901678bfd6c
--- /dev/null
+++ b/net-libs/grpc/files/grpc-1.41.0-link-system-gtest.patch
@@ -0,0 +1,22 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0e8fbdee8b..3662aabdfe 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2309,6 +2309,7 @@ target_include_directories(grpc_test_util
+ ${_gRPC_ZLIB_INCLUDE_DIR}
+ )
+ target_link_libraries(grpc_test_util
++ PRIVATE
+ ${_gRPC_ALLTARGETS_LIBRARIES}
+ absl::failure_signal_handler
+ absl::stacktrace
+@@ -2322,7 +2323,8 @@ endif()
+
+ endif()
+ if(gRPC_BUILD_TESTS)
+-
++find_package(GTest REQUIRED)
++target_link_libraries(grpc_test_util PUBLIC GTest::gtest GTest::gmock)
+ add_library(grpc_test_util_unsecure
+ test/core/util/cmdline.cc
+ test/core/util/fuzzer_util.cc