summaryrefslogtreecommitdiff
path: root/net-im/prosody
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/prosody')
-rw-r--r--net-im/prosody/Manifest2
-rw-r--r--net-im/prosody/prosody-0.11.10.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index 421184aa8fbd..57e8a6128ba3 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -2,6 +2,8 @@ AUX prosody-0.11.7-gentoo.patch 1419 BLAKE2B 30a1ef43f6d3b00a07f621dc701e97ba45f
AUX prosody.initd-r5 987 BLAKE2B 3e381f48cbc9c5361bdc6cb9ab4a13daf055cd35389036b4ed2efb6df4c5ea5bb4ff43947bdb29d09b263a7eb0ed7ffeda8425723f4e0a76387245ae02a2661f SHA512 56e8e5524c6b383355bb1106ffaac614196dd48a8d9fd1f62ece87fbe6278f7d2ea7a683027dd6dcfeb2bc7331d84e95868f8c0501dfc7e11ef77aa08ebdde17
AUX prosody.service-r2 228 BLAKE2B 61741cb7ecf64777b516a1fcb4e8e8c5c7b9c5d92dafbf7f691c36910f41d0b81d701bf8f287aea89fa368071c0c94a38f56ff3134055eb01842b578d8b57991 SHA512 0499588d1fd6e970575785b4bdaf631428601bec8a57051558c1d4c82bc74462f17d7568b8d433b14f15c51c94b181f4240d9f4574d51dcfeda291f0a68eb6f1
AUX prosody.tmpfilesd-r1 36 BLAKE2B dfb5025508cc62b4cd53de35b83f47bfee61821fbfe3301c1b67a4324ab753067cd3ecd84f56ae9a0241395a50d90ce2ec49c9333dc3378798a290e638a56cf9 SHA512 13a99fb925f7c3584dbfcbc98b3b929b67e165f70d700a25a861e512becd8a21ca48ee385da67ead23beeb68a43aaa10a2cfd342d1b3184883fede5d985cb599
+DIST prosody-0.11.10.tar.gz 438888 BLAKE2B 590f97f4eb8a333701eca516de3c3bcee9cf093267d2000af03b48d32396a1be21a0cf2f8ff542e7fbcb8419138bab5cf411f71b17666593559004a8a9674367 SHA512 419d8f8465f1807015f0a52d8f35ee89892b0869084dae38b60fc833d63c3d70892d8e59ae00039cd15e0e25f46d042954896f51f8c0520650a877f5296707cb
DIST prosody-0.11.9.tar.gz 431647 BLAKE2B b6cf013a53c91675b50f601031b4843a826d011c4e06b06b27968413f4807a083811465b836531652fb47adc3bdb2ac82308a3c79953d80d6839ca23c669ab80 SHA512 fabbbbb1acb3de4ff01e3e8c6e9e4dc37cb161259f1649683a1f9d925ed9f1709e052bfc831cba3f1861a9cca599f2b725ee739bfcb57164d6f50ac07011b52a
+EBUILD prosody-0.11.10.ebuild 2857 BLAKE2B 3e37641c2e758b610d419e4c8d5fc03105451fec839ae3dd9e23a36d21335ffd345b86955078f1383ccd09176d6819aa650e31293201d24978fc045697f97779 SHA512 ad230ee0c472d4bb7bd004e5c22cae4ef712e39f9315770d1976232c128cff4883673a8a485ea9842ad618505cf0b1917b06999348f2795c0aee9f56baf29aee
EBUILD prosody-0.11.9.ebuild 2855 BLAKE2B 5ef0b0509a1785f01fd408585cbea1d9de23e65df65768eaa4f0e7e6aae65f321cc8e19c2a539283445b23034ba1a2238f14c7f51152d265c3d814668ac63ec2 SHA512 fdac2d0644f9e0f4f8544cca19ee3bedcecce696125d10af6709432f6001b0df02b24f57c6ad0367b2b89b67f03f6681e9a3d357f803c5c0a0db1956c1b7bba2
MISC metadata.xml 669 BLAKE2B e8f1d6b1df790563b92637351fe3f824f48c34b95234ad950b2376fcd010195d1d25d0023d468ab6ca98fc068df3e83db88513eb6c1a12a7b93426302516e71b SHA512 6336b469b3fee51cc6b2b7e23398430294ed7ce0b53525515d22dc1dd5f70b97a0388d654378d34fc809164aa5c9bdcd4a3d2078df75c2bac8a954f0fe549710
diff --git a/net-im/prosody/prosody-0.11.10.ebuild b/net-im/prosody/prosody-0.11.10.ebuild
new file mode 100644
index 000000000000..83f73dc728a1
--- /dev/null
+++ b/net-im/prosody/prosody-0.11.10.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+LUA_REQ_USE="deprecated(+)"
+
+inherit lua-single systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="Prosody is a modern XMPP communication server"
+HOMEPAGE="https://prosody.im/"
+SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~x86"
+IUSE="icu +idn +libevent mysql postgres selinux +sqlite +ssl test +zlib"
+REQUIRED_USE="
+ ^^ ( icu idn )
+ ${LUA_REQUIRED_USE}
+"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ $(lua_gen_cond_dep 'dev-lua/luaexpat[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/luafilesystem[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/luasocket[${LUA_USEDEP}]')
+ net-im/jabber-base
+ icu? ( dev-libs/icu:= )
+ idn? ( net-dns/libidn:= )
+ libevent? ( $(lua_gen_cond_dep 'dev-lua/luaevent[${LUA_USEDEP}]') )
+ dev-libs/openssl:0=
+ lua_single_target_lua5-1? ( $(lua_gen_cond_dep 'dev-lua/lua-bit32[lua_targets_lua5-1(-)]') )
+ mysql? ( $(lua_gen_cond_dep 'dev-lua/luadbi[mysql,${LUA_USEDEP}]') )
+ postgres? ( $(lua_gen_cond_dep 'dev-lua/luadbi[postgres,${LUA_USEDEP}]') )
+ sqlite? ( $(lua_gen_cond_dep 'dev-lua/luadbi[sqlite,${LUA_USEDEP}]') )
+ ssl? ( $(lua_gen_cond_dep 'dev-lua/luasec[${LUA_USEDEP}]') )
+ zlib? ( $(lua_gen_cond_dep 'dev-lua/lua-zlib[${LUA_USEDEP}]') )
+ ${LUA_DEPS}
+"
+
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-jabber )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]') )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.11.7-gentoo.patch" )
+
+src_prepare() {
+ default
+
+ # Set correct plugin path for optional net-im/prosody-modules package
+ sed -e "s/GENTOO_LIBDIR/$(get_libdir)/g" -i prosody.cfg.lua.dist || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --add-cflags="${CFLAGS}"
+ --add-ldflags="${LDFLAGS}"
+ --c-compiler="$(tc-getCC)"
+ --datadir="${EPREFIX}/var/spool/jabber"
+ --idn-library="$(usex idn 'idn' 'icu')"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --linker="$(tc-getCC)"
+ --lua-version="$(usex lua_single_target_luajit '5.1' $(ver_cut 1-2 $(lua_get_version)))"
+ --no-example-certs
+ --ostype="linux"
+ --prefix="${EPREFIX}/usr"
+ --runwith="${ELUA}"
+ --sysconfdir="${EPREFIX}/etc/jabber"
+ --with-lua-include="${EPREFIX}/$(lua_get_include_dir)"
+ --with-lua-lib="${EPREFIX}/$(lua_get_cmod_dir)"
+ )
+
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure "${myeconfargs[@]}" || die
+
+ rm makefile || die
+ mv GNUmakefile Makefile || die
+}
+
+src_install() {
+ default
+
+ keepdir /var/spool/jabber
+
+ newinitd "${FILESDIR}"/prosody.initd-r5 prosody
+ systemd_newunit "${FILESDIR}"/prosody.service-r2 prosody.service
+
+ newtmpfiles "${FILESDIR}"/prosody.tmpfilesd-r1 prosody.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process prosody.conf
+}