summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Manifest.gzbin10573 -> 10572 bytes
-rw-r--r--net-im/dino/Manifest4
-rw-r--r--net-im/dino/dino-0.2.1.ebuild24
-rw-r--r--net-im/dino/dino-9999.ebuild24
-rw-r--r--net-im/prosody/Manifest2
-rw-r--r--net-im/prosody/prosody-0.11.10.ebuild102
-rw-r--r--net-im/skypeforlinux/Manifest2
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.75.0.140.ebuild99
8 files changed, 217 insertions, 40 deletions
diff --git a/net-im/Manifest.gz b/net-im/Manifest.gz
index 225297dc236d..481cfff146d7 100644
--- a/net-im/Manifest.gz
+++ b/net-im/Manifest.gz
Binary files differ
diff --git a/net-im/dino/Manifest b/net-im/dino/Manifest
index a51b097bd388..e11ed10a7649 100644
--- a/net-im/dino/Manifest
+++ b/net-im/dino/Manifest
@@ -1,4 +1,4 @@
DIST dino-0.2.1.tar.gz 514504 BLAKE2B 42fae18bb7cda276c1eadeefdea130069f9929dfde62855f00ab6b88912fe9db3374315f40ff8f53350cf38e45fe61b0fd6256ef390cdbed6a65a3f2d79ac80a SHA512 b71497ec115945eadf7d33bb973f68465a20284aa75f37f1ae25fc30c1c423ce28cb10f7e9123c47f82e77e97170b8fa72c75389dacc3a2aa3d487a9c9610d49
-EBUILD dino-0.2.1.ebuild 1820 BLAKE2B 7b3ab574fbeca05dafb1df85b5af8d0c69edbcf606f5dadb06a4f73f1b3384022b2f55854c1570c248a8d15b983b26c7152d19a7c6627c2cd6823ff3df92396c SHA512 9fefc28a8334c858ef59421f06f0f88c2208d57484bdeb4bd5ac582164ce7838ac39c6f8833a36a19cd1625b2a559a223214eb25241fb7f7961a42372cc6a715
-EBUILD dino-9999.ebuild 1869 BLAKE2B 02a95b918e0fc456f2731d8253fbd67ce4eeb659e19a21749ee8aba87bff85693ba4342d9f12fcd73f0a466ee252b31f5bb1e3273bf944b181e85392ab5bf63e SHA512 86a3193e2a90172aa52b42ae6fcca6b8ccdc37be5c63a9783fef2ca9912dc5b4ec2dbe9688b23dadf38280d5e2e96c0cbffd963b3643da148618bd93823473da
+EBUILD dino-0.2.1.ebuild 1648 BLAKE2B a060d33c0d9b8ea88a6fedadb7ce4964bfb0c51f7a79fcce46f8f2bb77b32b48f41eca7113f7ccbe5e58d57bd262cc89930b41c0c597c6e5bd12550bb91747b4 SHA512 6f9ba82b543c598ce897917e7d12126d87d9dd1925748dfe55ac61f891dab216ebb5c1efd6fbdf02741be85d16f210e4f90888972bd75342ff3ac99eda72e8e0
+EBUILD dino-9999.ebuild 1697 BLAKE2B a129d51469bb007a1c023ef216ebe6076bce93cd24ae24e541fc14654151662db336bc3a22b0efa2e6d7991123a395d4d5ee58c4df4fbb00f9d768580874f2e1 SHA512 8d01a975b53058c4df68ccff058d24f47b6f072d6f98c06cc4fb4764abc7bc2f9b4143eb4472149fe1908220f7e61f964b7e24fd51e04f7b32014b331da979f9
MISC metadata.xml 641 BLAKE2B 31f6c748c2bfe6279a574bf88b94caf476e1769159bdefc2fe4c35095d4e46cb30d6ad232f84cc614f83d1d319004398947fe65f0f9d1fc80dbdeef9497942de SHA512 a1b16eca16c3b7df169db8c7f8a2670cf97fab0c2913dad3ece312aa4e90429944148438b9d2bfd01661912ecffd950104b8324e83b691243841f810e6105ad5
diff --git a/net-im/dino/dino-0.2.1.ebuild b/net-im/dino/dino-0.2.1.ebuild
index c640a0cc338e..b9cbc662d434 100644
--- a/net-im/dino/dino-0.2.1.ebuild
+++ b/net-im/dino/dino-0.2.1.ebuild
@@ -5,13 +5,15 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="ninja"
VALA_MIN_API_VERSION="0.34"
-inherit cmake gnome2-utils vala xdg-utils
+inherit cmake vala xdg
DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
HOMEPAGE="https://dino.im"
+
LICENSE="GPL-3"
SLOT="0"
-IUSE="+gpg +http +omemo +notification-sound"
+IUSE="+gpg +http +omemo +notification-sound test"
+RESTRICT="!test? ( test )"
MY_REPO_URI="https://github.com/dino/dino"
if [[ ${PV} == "9999" ]]; then
@@ -66,28 +68,12 @@ src_configure() {
"-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
"-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
"-DVALA_EXECUTABLE=${VALAC}"
+ "-DBUILD_TESTS=$(usex test)"
)
- if has test ${FEATURES}; then
- mycmakeargs+=("-DBUILD_TESTS=yes")
- fi
-
cmake_src_configure
}
src_test() {
"${BUILD_DIR}"/xmpp-vala-test || die
}
-
-update_caches() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postinst() {
- update_caches
-}
-
-pkg_postrm() {
- update_caches
-}
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
index e0058ccbf6e7..408e90c29689 100644
--- a/net-im/dino/dino-9999.ebuild
+++ b/net-im/dino/dino-9999.ebuild
@@ -5,13 +5,15 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="ninja"
VALA_MIN_API_VERSION="0.34"
-inherit cmake gnome2-utils vala xdg-utils
+inherit cmake vala xdg
DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
HOMEPAGE="https://dino.im"
+
LICENSE="GPL-3"
SLOT="0"
-IUSE="+gpg +http +omemo +notification-sound"
+IUSE="+gpg +http +omemo +notification-sound test"
+RESTRICT="!test? ( test )"
MY_REPO_URI="https://github.com/dino/dino"
if [[ ${PV} == "9999" ]]; then
@@ -68,28 +70,12 @@ src_configure() {
"-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
"-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
"-DVALA_EXECUTABLE=${VALAC}"
+ "-DBUILD_TESTS=$(usex test)"
)
- if has test ${FEATURES}; then
- mycmakeargs+=("-DBUILD_TESTS=yes")
- fi
-
cmake_src_configure
}
src_test() {
"${BUILD_DIR}"/xmpp-vala-test || die
}
-
-update_caches() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postinst() {
- update_caches
-}
-
-pkg_postrm() {
- update_caches
-}
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index 421184aa8fbd..57e8a6128ba3 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -2,6 +2,8 @@ AUX prosody-0.11.7-gentoo.patch 1419 BLAKE2B 30a1ef43f6d3b00a07f621dc701e97ba45f
AUX prosody.initd-r5 987 BLAKE2B 3e381f48cbc9c5361bdc6cb9ab4a13daf055cd35389036b4ed2efb6df4c5ea5bb4ff43947bdb29d09b263a7eb0ed7ffeda8425723f4e0a76387245ae02a2661f SHA512 56e8e5524c6b383355bb1106ffaac614196dd48a8d9fd1f62ece87fbe6278f7d2ea7a683027dd6dcfeb2bc7331d84e95868f8c0501dfc7e11ef77aa08ebdde17
AUX prosody.service-r2 228 BLAKE2B 61741cb7ecf64777b516a1fcb4e8e8c5c7b9c5d92dafbf7f691c36910f41d0b81d701bf8f287aea89fa368071c0c94a38f56ff3134055eb01842b578d8b57991 SHA512 0499588d1fd6e970575785b4bdaf631428601bec8a57051558c1d4c82bc74462f17d7568b8d433b14f15c51c94b181f4240d9f4574d51dcfeda291f0a68eb6f1
AUX prosody.tmpfilesd-r1 36 BLAKE2B dfb5025508cc62b4cd53de35b83f47bfee61821fbfe3301c1b67a4324ab753067cd3ecd84f56ae9a0241395a50d90ce2ec49c9333dc3378798a290e638a56cf9 SHA512 13a99fb925f7c3584dbfcbc98b3b929b67e165f70d700a25a861e512becd8a21ca48ee385da67ead23beeb68a43aaa10a2cfd342d1b3184883fede5d985cb599
+DIST prosody-0.11.10.tar.gz 438888 BLAKE2B 590f97f4eb8a333701eca516de3c3bcee9cf093267d2000af03b48d32396a1be21a0cf2f8ff542e7fbcb8419138bab5cf411f71b17666593559004a8a9674367 SHA512 419d8f8465f1807015f0a52d8f35ee89892b0869084dae38b60fc833d63c3d70892d8e59ae00039cd15e0e25f46d042954896f51f8c0520650a877f5296707cb
DIST prosody-0.11.9.tar.gz 431647 BLAKE2B b6cf013a53c91675b50f601031b4843a826d011c4e06b06b27968413f4807a083811465b836531652fb47adc3bdb2ac82308a3c79953d80d6839ca23c669ab80 SHA512 fabbbbb1acb3de4ff01e3e8c6e9e4dc37cb161259f1649683a1f9d925ed9f1709e052bfc831cba3f1861a9cca599f2b725ee739bfcb57164d6f50ac07011b52a
+EBUILD prosody-0.11.10.ebuild 2857 BLAKE2B 3e37641c2e758b610d419e4c8d5fc03105451fec839ae3dd9e23a36d21335ffd345b86955078f1383ccd09176d6819aa650e31293201d24978fc045697f97779 SHA512 ad230ee0c472d4bb7bd004e5c22cae4ef712e39f9315770d1976232c128cff4883673a8a485ea9842ad618505cf0b1917b06999348f2795c0aee9f56baf29aee
EBUILD prosody-0.11.9.ebuild 2855 BLAKE2B 5ef0b0509a1785f01fd408585cbea1d9de23e65df65768eaa4f0e7e6aae65f321cc8e19c2a539283445b23034ba1a2238f14c7f51152d265c3d814668ac63ec2 SHA512 fdac2d0644f9e0f4f8544cca19ee3bedcecce696125d10af6709432f6001b0df02b24f57c6ad0367b2b89b67f03f6681e9a3d357f803c5c0a0db1956c1b7bba2
MISC metadata.xml 669 BLAKE2B e8f1d6b1df790563b92637351fe3f824f48c34b95234ad950b2376fcd010195d1d25d0023d468ab6ca98fc068df3e83db88513eb6c1a12a7b93426302516e71b SHA512 6336b469b3fee51cc6b2b7e23398430294ed7ce0b53525515d22dc1dd5f70b97a0388d654378d34fc809164aa5c9bdcd4a3d2078df75c2bac8a954f0fe549710
diff --git a/net-im/prosody/prosody-0.11.10.ebuild b/net-im/prosody/prosody-0.11.10.ebuild
new file mode 100644
index 000000000000..83f73dc728a1
--- /dev/null
+++ b/net-im/prosody/prosody-0.11.10.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+LUA_REQ_USE="deprecated(+)"
+
+inherit lua-single systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="Prosody is a modern XMPP communication server"
+HOMEPAGE="https://prosody.im/"
+SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~x86"
+IUSE="icu +idn +libevent mysql postgres selinux +sqlite +ssl test +zlib"
+REQUIRED_USE="
+ ^^ ( icu idn )
+ ${LUA_REQUIRED_USE}
+"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ $(lua_gen_cond_dep 'dev-lua/luaexpat[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/luafilesystem[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/luasocket[${LUA_USEDEP}]')
+ net-im/jabber-base
+ icu? ( dev-libs/icu:= )
+ idn? ( net-dns/libidn:= )
+ libevent? ( $(lua_gen_cond_dep 'dev-lua/luaevent[${LUA_USEDEP}]') )
+ dev-libs/openssl:0=
+ lua_single_target_lua5-1? ( $(lua_gen_cond_dep 'dev-lua/lua-bit32[lua_targets_lua5-1(-)]') )
+ mysql? ( $(lua_gen_cond_dep 'dev-lua/luadbi[mysql,${LUA_USEDEP}]') )
+ postgres? ( $(lua_gen_cond_dep 'dev-lua/luadbi[postgres,${LUA_USEDEP}]') )
+ sqlite? ( $(lua_gen_cond_dep 'dev-lua/luadbi[sqlite,${LUA_USEDEP}]') )
+ ssl? ( $(lua_gen_cond_dep 'dev-lua/luasec[${LUA_USEDEP}]') )
+ zlib? ( $(lua_gen_cond_dep 'dev-lua/lua-zlib[${LUA_USEDEP}]') )
+ ${LUA_DEPS}
+"
+
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-jabber )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]') )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.11.7-gentoo.patch" )
+
+src_prepare() {
+ default
+
+ # Set correct plugin path for optional net-im/prosody-modules package
+ sed -e "s/GENTOO_LIBDIR/$(get_libdir)/g" -i prosody.cfg.lua.dist || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --add-cflags="${CFLAGS}"
+ --add-ldflags="${LDFLAGS}"
+ --c-compiler="$(tc-getCC)"
+ --datadir="${EPREFIX}/var/spool/jabber"
+ --idn-library="$(usex idn 'idn' 'icu')"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --linker="$(tc-getCC)"
+ --lua-version="$(usex lua_single_target_luajit '5.1' $(ver_cut 1-2 $(lua_get_version)))"
+ --no-example-certs
+ --ostype="linux"
+ --prefix="${EPREFIX}/usr"
+ --runwith="${ELUA}"
+ --sysconfdir="${EPREFIX}/etc/jabber"
+ --with-lua-include="${EPREFIX}/$(lua_get_include_dir)"
+ --with-lua-lib="${EPREFIX}/$(lua_get_cmod_dir)"
+ )
+
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure "${myeconfargs[@]}" || die
+
+ rm makefile || die
+ mv GNUmakefile Makefile || die
+}
+
+src_install() {
+ default
+
+ keepdir /var/spool/jabber
+
+ newinitd "${FILESDIR}"/prosody.initd-r5 prosody
+ systemd_newunit "${FILESDIR}"/prosody.service-r2 prosody.service
+
+ newtmpfiles "${FILESDIR}"/prosody.tmpfilesd-r1 prosody.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process prosody.conf
+}
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 0843fc92976e..1e16826b1f2c 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -2,8 +2,10 @@ DIST skypeforlinux_8.72.0.94-1.x86_64.rpm 118230043 BLAKE2B 9d7d8609c117947fbab4
DIST skypeforlinux_8.73.0.129-1.x86_64.rpm 123370656 BLAKE2B 831188ea01a8ae27b6c5b557f7e752740a3f32928bd113bd6d8fffd31badfbff4a8f088e8e0b8fdc1b1b133ff5e6b692db3b83df4669da5d92725847a3555280 SHA512 153afbf9e7b3ad8d3ca9002835d54038e8450868df2506a61cd278ddfe3329241a913d0caef9ad0179c3f8a6a2d8f7138e4fff74c7ef7b12ddbdbe60f78e58a2
DIST skypeforlinux_8.73.0.92-1.x86_64.rpm 119323419 BLAKE2B e201be43c6f331555d3759e9484d13c1d0613dd9e60ce67c3dafec27fa9d183ddc89e1c23feb1722ace2fd492185f8402be6abec80c748e6ad1f666878a72025 SHA512 dc6b72dc43443ad7747a30adef7b08afb50b4cc40a61cff2eb8989c9f68ae817c221d4ce2812d5d54cb9a4ac5f2accfe350efdfab622096d2d0805953fbddd13
DIST skypeforlinux_8.74.0.152-1.x86_64.rpm 123390893 BLAKE2B 746f1ac2f777ff79a47444052fdad86d2a67f7278eb809d57fedc681ca5648320d16b32e100b50b36bcaea853dff266eb0b47bdb9c8ba48582c63a09b3eeabda SHA512 f1c40c58305cecec899f9be1a477103ff9dc7e0d02ea68a9ebc15b4e80292d5a3925fbcf6451cae0c2b854b3b3f74abe101715a7f3afdc2ea954e18759cab37d
+DIST skypeforlinux_8.75.0.140-1.x86_64.rpm 123300996 BLAKE2B a1b0d4696489be33721fb38a832756edc0a437b93c269e512aba6ccd882e66fc9c84ba7d7a741e2761a097d7697985e32b0a65766c556cf17045a26fec6fc010 SHA512 21eb3cea11878e41f0694951dbf6447d225983c026ab7572ed8a9a5f31c38231c7b7f3ca7363535f27ef958c58db500c6d61ddfb95056145500500a9f0b30aed
EBUILD skypeforlinux-8.72.0.94.ebuild 3160 BLAKE2B 4ada892e98d1c7c911ee821382f57bf8d17748862143a2e178a5e4402ea3bb13a63d65b4719ff4126d4005cfd28b3ab5ceb5d0fee697dcf5509d717ac8fc5f0a SHA512 978a18853d478585145a3187ab242d33785a79f7f67cd97ac51e3fea67b6e2717e0cc04e1bab0b800e95f46b6ce288e8606b4ea86bfec2b53e419e6f7595db69
EBUILD skypeforlinux-8.73.0.129.ebuild 3160 BLAKE2B 4ada892e98d1c7c911ee821382f57bf8d17748862143a2e178a5e4402ea3bb13a63d65b4719ff4126d4005cfd28b3ab5ceb5d0fee697dcf5509d717ac8fc5f0a SHA512 978a18853d478585145a3187ab242d33785a79f7f67cd97ac51e3fea67b6e2717e0cc04e1bab0b800e95f46b6ce288e8606b4ea86bfec2b53e419e6f7595db69
EBUILD skypeforlinux-8.73.0.92.ebuild 3160 BLAKE2B 4ada892e98d1c7c911ee821382f57bf8d17748862143a2e178a5e4402ea3bb13a63d65b4719ff4126d4005cfd28b3ab5ceb5d0fee697dcf5509d717ac8fc5f0a SHA512 978a18853d478585145a3187ab242d33785a79f7f67cd97ac51e3fea67b6e2717e0cc04e1bab0b800e95f46b6ce288e8606b4ea86bfec2b53e419e6f7595db69
EBUILD skypeforlinux-8.74.0.152.ebuild 3160 BLAKE2B 4ada892e98d1c7c911ee821382f57bf8d17748862143a2e178a5e4402ea3bb13a63d65b4719ff4126d4005cfd28b3ab5ceb5d0fee697dcf5509d717ac8fc5f0a SHA512 978a18853d478585145a3187ab242d33785a79f7f67cd97ac51e3fea67b6e2717e0cc04e1bab0b800e95f46b6ce288e8606b4ea86bfec2b53e419e6f7595db69
+EBUILD skypeforlinux-8.75.0.140.ebuild 3160 BLAKE2B 4ada892e98d1c7c911ee821382f57bf8d17748862143a2e178a5e4402ea3bb13a63d65b4719ff4126d4005cfd28b3ab5ceb5d0fee697dcf5509d717ac8fc5f0a SHA512 978a18853d478585145a3187ab242d33785a79f7f67cd97ac51e3fea67b6e2717e0cc04e1bab0b800e95f46b6ce288e8606b4ea86bfec2b53e419e6f7595db69
MISC metadata.xml 460 BLAKE2B 136f61594a68e6efed725d448cd9fcd0e0c72f884cd64ef5f8c3adbc39fd4322a4ed8ef692fa500bb00488e616520efdec943be7c4d0381345247776a8258d42 SHA512 d82b35cfa2dc12b2629f7084f071d3d3cd83e2d6246cb4c2544883f28becde6677a1739f7c028e69352267561441419d135774daa1177a803d485d38880191a8
diff --git a/net-im/skypeforlinux/skypeforlinux-8.75.0.140.ebuild b/net-im/skypeforlinux/skypeforlinux-8.75.0.140.ebuild
new file mode 100644
index 000000000000..a44feb7c8927
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.75.0.140.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}