summaryrefslogtreecommitdiff
path: root/net-im/dino
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/dino')
-rw-r--r--net-im/dino/Manifest4
-rw-r--r--net-im/dino/dino-0.2.1.ebuild24
-rw-r--r--net-im/dino/dino-9999.ebuild24
3 files changed, 12 insertions, 40 deletions
diff --git a/net-im/dino/Manifest b/net-im/dino/Manifest
index a51b097bd388..e11ed10a7649 100644
--- a/net-im/dino/Manifest
+++ b/net-im/dino/Manifest
@@ -1,4 +1,4 @@
DIST dino-0.2.1.tar.gz 514504 BLAKE2B 42fae18bb7cda276c1eadeefdea130069f9929dfde62855f00ab6b88912fe9db3374315f40ff8f53350cf38e45fe61b0fd6256ef390cdbed6a65a3f2d79ac80a SHA512 b71497ec115945eadf7d33bb973f68465a20284aa75f37f1ae25fc30c1c423ce28cb10f7e9123c47f82e77e97170b8fa72c75389dacc3a2aa3d487a9c9610d49
-EBUILD dino-0.2.1.ebuild 1820 BLAKE2B 7b3ab574fbeca05dafb1df85b5af8d0c69edbcf606f5dadb06a4f73f1b3384022b2f55854c1570c248a8d15b983b26c7152d19a7c6627c2cd6823ff3df92396c SHA512 9fefc28a8334c858ef59421f06f0f88c2208d57484bdeb4bd5ac582164ce7838ac39c6f8833a36a19cd1625b2a559a223214eb25241fb7f7961a42372cc6a715
-EBUILD dino-9999.ebuild 1869 BLAKE2B 02a95b918e0fc456f2731d8253fbd67ce4eeb659e19a21749ee8aba87bff85693ba4342d9f12fcd73f0a466ee252b31f5bb1e3273bf944b181e85392ab5bf63e SHA512 86a3193e2a90172aa52b42ae6fcca6b8ccdc37be5c63a9783fef2ca9912dc5b4ec2dbe9688b23dadf38280d5e2e96c0cbffd963b3643da148618bd93823473da
+EBUILD dino-0.2.1.ebuild 1648 BLAKE2B a060d33c0d9b8ea88a6fedadb7ce4964bfb0c51f7a79fcce46f8f2bb77b32b48f41eca7113f7ccbe5e58d57bd262cc89930b41c0c597c6e5bd12550bb91747b4 SHA512 6f9ba82b543c598ce897917e7d12126d87d9dd1925748dfe55ac61f891dab216ebb5c1efd6fbdf02741be85d16f210e4f90888972bd75342ff3ac99eda72e8e0
+EBUILD dino-9999.ebuild 1697 BLAKE2B a129d51469bb007a1c023ef216ebe6076bce93cd24ae24e541fc14654151662db336bc3a22b0efa2e6d7991123a395d4d5ee58c4df4fbb00f9d768580874f2e1 SHA512 8d01a975b53058c4df68ccff058d24f47b6f072d6f98c06cc4fb4764abc7bc2f9b4143eb4472149fe1908220f7e61f964b7e24fd51e04f7b32014b331da979f9
MISC metadata.xml 641 BLAKE2B 31f6c748c2bfe6279a574bf88b94caf476e1769159bdefc2fe4c35095d4e46cb30d6ad232f84cc614f83d1d319004398947fe65f0f9d1fc80dbdeef9497942de SHA512 a1b16eca16c3b7df169db8c7f8a2670cf97fab0c2913dad3ece312aa4e90429944148438b9d2bfd01661912ecffd950104b8324e83b691243841f810e6105ad5
diff --git a/net-im/dino/dino-0.2.1.ebuild b/net-im/dino/dino-0.2.1.ebuild
index c640a0cc338e..b9cbc662d434 100644
--- a/net-im/dino/dino-0.2.1.ebuild
+++ b/net-im/dino/dino-0.2.1.ebuild
@@ -5,13 +5,15 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="ninja"
VALA_MIN_API_VERSION="0.34"
-inherit cmake gnome2-utils vala xdg-utils
+inherit cmake vala xdg
DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
HOMEPAGE="https://dino.im"
+
LICENSE="GPL-3"
SLOT="0"
-IUSE="+gpg +http +omemo +notification-sound"
+IUSE="+gpg +http +omemo +notification-sound test"
+RESTRICT="!test? ( test )"
MY_REPO_URI="https://github.com/dino/dino"
if [[ ${PV} == "9999" ]]; then
@@ -66,28 +68,12 @@ src_configure() {
"-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
"-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
"-DVALA_EXECUTABLE=${VALAC}"
+ "-DBUILD_TESTS=$(usex test)"
)
- if has test ${FEATURES}; then
- mycmakeargs+=("-DBUILD_TESTS=yes")
- fi
-
cmake_src_configure
}
src_test() {
"${BUILD_DIR}"/xmpp-vala-test || die
}
-
-update_caches() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postinst() {
- update_caches
-}
-
-pkg_postrm() {
- update_caches
-}
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
index e0058ccbf6e7..408e90c29689 100644
--- a/net-im/dino/dino-9999.ebuild
+++ b/net-im/dino/dino-9999.ebuild
@@ -5,13 +5,15 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="ninja"
VALA_MIN_API_VERSION="0.34"
-inherit cmake gnome2-utils vala xdg-utils
+inherit cmake vala xdg
DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
HOMEPAGE="https://dino.im"
+
LICENSE="GPL-3"
SLOT="0"
-IUSE="+gpg +http +omemo +notification-sound"
+IUSE="+gpg +http +omemo +notification-sound test"
+RESTRICT="!test? ( test )"
MY_REPO_URI="https://github.com/dino/dino"
if [[ ${PV} == "9999" ]]; then
@@ -68,28 +70,12 @@ src_configure() {
"-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
"-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
"-DVALA_EXECUTABLE=${VALAC}"
+ "-DBUILD_TESTS=$(usex test)"
)
- if has test ${FEATURES}; then
- mycmakeargs+=("-DBUILD_TESTS=yes")
- fi
-
cmake_src_configure
}
src_test() {
"${BUILD_DIR}"/xmpp-vala-test || die
}
-
-update_caches() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postinst() {
- update_caches
-}
-
-pkg_postrm() {
- update_caches
-}