summaryrefslogtreecommitdiff
path: root/media-video/noad/files/patches-0.7.x
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/noad/files/patches-0.7.x')
-rw-r--r--media-video/noad/files/patches-0.7.x/noad-0.7.3-ffmpeg_detection.diff13
-rw-r--r--media-video/noad/files/patches-0.7.x/noad-0.7.3-hangcheck.diff21
-rw-r--r--media-video/noad/files/patches-0.7.x/noad-0.7.3_gcc-4.7.diff17
-rw-r--r--media-video/noad/files/patches-0.7.x/noad-0.7.3_missing_include.diff14
4 files changed, 0 insertions, 65 deletions
diff --git a/media-video/noad/files/patches-0.7.x/noad-0.7.3-ffmpeg_detection.diff b/media-video/noad/files/patches-0.7.x/noad-0.7.3-ffmpeg_detection.diff
deleted file mode 100644
index e757aeb884b0..000000000000
--- a/media-video/noad/files/patches-0.7.x/noad-0.7.3-ffmpeg_detection.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: noad-0.7.3/configure.ac
-===================================================================
---- noad-0.7.3.orig/configure.ac
-+++ noad-0.7.3/configure.ac
-@@ -158,7 +158,7 @@ dnl check that libavcodec is usable
- dnl ---------------------------------------------------------------------------
- if test "$withffmpeg" == "1"; then
- AC_SUBST(LIBAVCODEC,"-lavcodec")
-- AC_CHECK_LIB([avcodec],[avcodec_init],[AC_SUBST(HAVE_LIBAVCODEC,1) AC_SUBST(LIBS,"$LIBS $LIBAVCODEC ") ])
-+ AC_CHECK_LIB([avcodec],[avcodec_register_all],[AC_SUBST(HAVE_LIBAVCODEC,1) AC_SUBST(LIBS,"$LIBS $LIBAVCODEC ") ])
- fi
-
-
diff --git a/media-video/noad/files/patches-0.7.x/noad-0.7.3-hangcheck.diff b/media-video/noad/files/patches-0.7.x/noad-0.7.3-hangcheck.diff
deleted file mode 100644
index 37788a197fd7..000000000000
--- a/media-video/noad/files/patches-0.7.x/noad-0.7.3-hangcheck.diff
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ru noad-0.6.0-orig/main.cpp noad-0.6.0/main.cpp
---- noad-0.6.0-orig/main.cpp 2007-05-12 17:28:01.000000000 +0200
-+++ noad-0.6.0/main.cpp 2007-05-12 18:20:30.000000000 +0200
-@@ -566,10 +566,17 @@
- signal(SIGABRT, signal_handler);
- signal(SIGSEGV, signal_handler);
- signal(SIGUSR1, signal_handler);
-+ signal(SIGALRM, signal_handler);
-
- // do cleanup at exit...
- atexit(cleanUp);
-
-+
-+ if (!bOnline) {
-+ // now start alarm timer to kill hanging noad (hardcoded 30min timeout)
-+ alarm(30*60);
-+ }
-+
- // now do the work..,
- doNoad(bBefore, recDir);
-
diff --git a/media-video/noad/files/patches-0.7.x/noad-0.7.3_gcc-4.7.diff b/media-video/noad/files/patches-0.7.x/noad-0.7.3_gcc-4.7.diff
deleted file mode 100644
index ca37f8e22a87..000000000000
--- a/media-video/noad/files/patches-0.7.x/noad-0.7.3_gcc-4.7.diff
+++ /dev/null
@@ -1,17 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=423623
-compilefix gcc-4.7.x
-
-signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.org> (2012/06/27)
-
-diff -Naur noad-0.7.3.orig/vdr_cl.h noad-0.7.3/vdr_cl.h
---- noad-0.7.3.orig/vdr_cl.h 2012-06-27 20:27:57.000000000 +0200
-+++ noad-0.7.3/vdr_cl.h 2012-06-27 20:30:56.000000000 +0200
-@@ -287,7 +287,7 @@
- {
- T *l = new T;
- if (l->Parse(s))
-- Add(l);
-+ this->Add(l);
- else
- {
- esyslog("ERROR: error in %s, line %d", fileName, line);
diff --git a/media-video/noad/files/patches-0.7.x/noad-0.7.3_missing_include.diff b/media-video/noad/files/patches-0.7.x/noad-0.7.3_missing_include.diff
deleted file mode 100644
index c3c335c2663b..000000000000
--- a/media-video/noad/files/patches-0.7.x/noad-0.7.3_missing_include.diff
+++ /dev/null
@@ -1,14 +0,0 @@
-Add missing includes for ressource limits.
-
-Signed-off-by: Markus Rathgeb <maggu2810@gmail.com>
-
---- main.cpp
-+++ main.cpp
-@@ -22,6 +22,7 @@
-
- #include <stdlib.h>
- #include <time.h>
-+#include <sys/resource.h>
- #include <sys/wait.h>
- #include <signal.h>
- #include <execinfo.h>