summaryrefslogtreecommitdiff
path: root/media-video/noad/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/noad/files')
-rw-r--r--media-video/noad/files/patches-0.7.x/noad-0.7.3-ffmpeg_detection.diff13
-rw-r--r--media-video/noad/files/patches-0.7.x/noad-0.7.3-hangcheck.diff21
-rw-r--r--media-video/noad/files/patches-0.7.x/noad-0.7.3_gcc-4.7.diff17
-rw-r--r--media-video/noad/files/patches-0.7.x/noad-0.7.3_missing_include.diff14
-rw-r--r--media-video/noad/files/patches-0.8.x/noad-0.8.6-ffmpeg25.patch16
-rw-r--r--media-video/noad/files/patches-0.8.x/noad-0.8.6-libav9.diff106
6 files changed, 0 insertions, 187 deletions
diff --git a/media-video/noad/files/patches-0.7.x/noad-0.7.3-ffmpeg_detection.diff b/media-video/noad/files/patches-0.7.x/noad-0.7.3-ffmpeg_detection.diff
deleted file mode 100644
index e757aeb884b0..000000000000
--- a/media-video/noad/files/patches-0.7.x/noad-0.7.3-ffmpeg_detection.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: noad-0.7.3/configure.ac
-===================================================================
---- noad-0.7.3.orig/configure.ac
-+++ noad-0.7.3/configure.ac
-@@ -158,7 +158,7 @@ dnl check that libavcodec is usable
- dnl ---------------------------------------------------------------------------
- if test "$withffmpeg" == "1"; then
- AC_SUBST(LIBAVCODEC,"-lavcodec")
-- AC_CHECK_LIB([avcodec],[avcodec_init],[AC_SUBST(HAVE_LIBAVCODEC,1) AC_SUBST(LIBS,"$LIBS $LIBAVCODEC ") ])
-+ AC_CHECK_LIB([avcodec],[avcodec_register_all],[AC_SUBST(HAVE_LIBAVCODEC,1) AC_SUBST(LIBS,"$LIBS $LIBAVCODEC ") ])
- fi
-
-
diff --git a/media-video/noad/files/patches-0.7.x/noad-0.7.3-hangcheck.diff b/media-video/noad/files/patches-0.7.x/noad-0.7.3-hangcheck.diff
deleted file mode 100644
index 37788a197fd7..000000000000
--- a/media-video/noad/files/patches-0.7.x/noad-0.7.3-hangcheck.diff
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ru noad-0.6.0-orig/main.cpp noad-0.6.0/main.cpp
---- noad-0.6.0-orig/main.cpp 2007-05-12 17:28:01.000000000 +0200
-+++ noad-0.6.0/main.cpp 2007-05-12 18:20:30.000000000 +0200
-@@ -566,10 +566,17 @@
- signal(SIGABRT, signal_handler);
- signal(SIGSEGV, signal_handler);
- signal(SIGUSR1, signal_handler);
-+ signal(SIGALRM, signal_handler);
-
- // do cleanup at exit...
- atexit(cleanUp);
-
-+
-+ if (!bOnline) {
-+ // now start alarm timer to kill hanging noad (hardcoded 30min timeout)
-+ alarm(30*60);
-+ }
-+
- // now do the work..,
- doNoad(bBefore, recDir);
-
diff --git a/media-video/noad/files/patches-0.7.x/noad-0.7.3_gcc-4.7.diff b/media-video/noad/files/patches-0.7.x/noad-0.7.3_gcc-4.7.diff
deleted file mode 100644
index ca37f8e22a87..000000000000
--- a/media-video/noad/files/patches-0.7.x/noad-0.7.3_gcc-4.7.diff
+++ /dev/null
@@ -1,17 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=423623
-compilefix gcc-4.7.x
-
-signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.org> (2012/06/27)
-
-diff -Naur noad-0.7.3.orig/vdr_cl.h noad-0.7.3/vdr_cl.h
---- noad-0.7.3.orig/vdr_cl.h 2012-06-27 20:27:57.000000000 +0200
-+++ noad-0.7.3/vdr_cl.h 2012-06-27 20:30:56.000000000 +0200
-@@ -287,7 +287,7 @@
- {
- T *l = new T;
- if (l->Parse(s))
-- Add(l);
-+ this->Add(l);
- else
- {
- esyslog("ERROR: error in %s, line %d", fileName, line);
diff --git a/media-video/noad/files/patches-0.7.x/noad-0.7.3_missing_include.diff b/media-video/noad/files/patches-0.7.x/noad-0.7.3_missing_include.diff
deleted file mode 100644
index c3c335c2663b..000000000000
--- a/media-video/noad/files/patches-0.7.x/noad-0.7.3_missing_include.diff
+++ /dev/null
@@ -1,14 +0,0 @@
-Add missing includes for ressource limits.
-
-Signed-off-by: Markus Rathgeb <maggu2810@gmail.com>
-
---- main.cpp
-+++ main.cpp
-@@ -22,6 +22,7 @@
-
- #include <stdlib.h>
- #include <time.h>
-+#include <sys/resource.h>
- #include <sys/wait.h>
- #include <signal.h>
- #include <execinfo.h>
diff --git a/media-video/noad/files/patches-0.8.x/noad-0.8.6-ffmpeg25.patch b/media-video/noad/files/patches-0.8.x/noad-0.8.6-ffmpeg25.patch
deleted file mode 100644
index 455252a74c8a..000000000000
--- a/media-video/noad/files/patches-0.8.x/noad-0.8.6-ffmpeg25.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: noad-0.8.6/ffmpeg_decoder.cpp
-===================================================================
---- noad-0.8.6.orig/ffmpeg_decoder.cpp
-+++ noad-0.8.6/ffmpeg_decoder.cpp
-@@ -253,7 +253,11 @@ int FFMPegDecoder::decoder_exit()
- // close the file
- if( pFormatCtx )
- {
-+#if LIBAVFORMAT_VERSION_MAJOR < 54
- av_close_input_file(pFormatCtx);
-+#else
-+ avformat_close_input(&pFormatCtx);
-+#endif
- pFormatCtx = NULL;
- }
- // Close the codec
diff --git a/media-video/noad/files/patches-0.8.x/noad-0.8.6-libav9.diff b/media-video/noad/files/patches-0.8.x/noad-0.8.6-libav9.diff
deleted file mode 100644
index a9b6c89d9f8c..000000000000
--- a/media-video/noad/files/patches-0.8.x/noad-0.8.6-libav9.diff
+++ /dev/null
@@ -1,106 +0,0 @@
-compile fix noad-0.8.6
-testet with libav-9 ffmpeg-2.2.9
-Signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.o> (22 Oct 2014)
-diff -Naur noad-0.8.6.orig/audiotools.cpp noad-0.8.6/audiotools.cpp
---- noad-0.8.6.orig/audiotools.cpp 2014-10-22 14:26:57.809249955 +0200
-+++ noad-0.8.6/audiotools.cpp 2014-10-22 14:28:06.830249955 +0200
-@@ -50,9 +50,9 @@
- uint8_t *outbuf=NULL;
- AVCodec *codec=NULL;
- AVCodecContext *codecContext= NULL;
--#if LIBAVCODEC_VERSION_MAJOR > 54
-+//#if LIBAVCODEC_VERSION_MAJOR > 54
- AVDictionary *avDictionary = NULL; // "create" an empty dictionary
--#endif
-+//#endif
- int64_t basepts=0;
- int64_t audiobasepts=0;
- //int64_t audiopts=0;
-@@ -108,13 +108,13 @@
- codecContext = avcodec_alloc_context3(codec);
- #endif
-
--#if LIBAVCODEC_VERSION_MAJOR > 54
-+//#if LIBAVCODEC_VERSION_MAJOR > 54
- /* open it */
- if (avcodec_open2(codecContext, codec, &avDictionary) < 0)
--#else
-+//#else
- /* open it */
-- if (avcodec_open(codecContext, codec) < 0)
--#endif
-+// if (avcodec_open(codecContext, codec) < 0)
-+//#endif
- {
- fprintf(stderr, "could not open codec\n");
- }
-@@ -129,9 +129,9 @@
- {
- free(outbuf);
- avcodec_close(codecContext);
--#if LIBAVCODEC_VERSION_MAJOR > 54
-+//#if LIBAVCODEC_VERSION_MAJOR > 54
- av_dict_free(&avDictionary);
--#endif
-+//#endif
- av_free(codecContext);
- av_codec_initialised = false;
- }
-diff -Naur noad-0.8.6.orig/ffmpeg_decoder.cpp noad-0.8.6/ffmpeg_decoder.cpp
---- noad-0.8.6.orig/ffmpeg_decoder.cpp 2014-10-22 14:26:57.808249955 +0200
-+++ noad-0.8.6/ffmpeg_decoder.cpp 2014-10-22 14:38:26.366249955 +0200
-@@ -184,7 +184,7 @@
-
- // Retrieve stream information
- resetDecoder();
-- int openCode2 = av_find_stream_info(pFormatCtx);
-+ int openCode2 = avformat_find_stream_info(pFormatCtx, NULL);
- if(openCode2<0)
- return -1; // Couldn't find stream information
-
-@@ -222,13 +222,13 @@
- if(pCodec->capabilities & CODEC_CAP_TRUNCATED)
- pCodecCtx->flags|=CODEC_FLAG_TRUNCATED;
-
--#if LIBAVCODEC_VERSION_MAJOR > 54
-+//#if LIBAVCODEC_VERSION_MAJOR > 54
- // Open codec
- if(avcodec_open2(pCodecCtx, pCodec,&avDictionary) < 0)
--#else
-+//#else
- // Open codec
-- if(avcodec_open(pCodecCtx, pCodec)<0)
--#endif
-+// if(avcodec_open(pCodecCtx, pCodec)<0)
-+//#endif
- return -1; // Could not open codec
-
-
-@@ -270,10 +270,10 @@
- pIOContext = NULL;
- }
- #endif
--#if LIBAVCODEC_VERSION_MAJOR > 54
-+//#if LIBAVCODEC_VERSION_MAJOR > 54
- av_dict_free(&avDictionary);
- avDictionary = NULL;
--#endif
-+//#endif
- return 0;
- }
-
-diff -Naur noad-0.8.6.orig/ffmpeg_decoder.h noad-0.8.6/ffmpeg_decoder.h
---- noad-0.8.6.orig/ffmpeg_decoder.h 2014-10-22 14:26:57.807249955 +0200
-+++ noad-0.8.6/ffmpeg_decoder.h 2014-10-22 14:36:27.213249955 +0200
-@@ -22,9 +22,9 @@
- int i, videoStream;
- AVCodecContext *pCodecCtx;
- AVCodec *pCodec;
--#if LIBAVCODEC_VERSION_MAJOR > 54
-+//#if LIBAVCODEC_VERSION_MAJOR > 54
- AVDictionary *avDictionary;
--#endif
-+//#endif
- AVFrame *pFrame;
-
- public: