summaryrefslogtreecommitdiff
path: root/gui-apps/wcm
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wcm')
-rw-r--r--gui-apps/wcm/Manifest4
-rw-r--r--gui-apps/wcm/metadata.xml17
-rw-r--r--gui-apps/wcm/wcm-0.4.0.ebuild46
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild46
4 files changed, 113 insertions, 0 deletions
diff --git a/gui-apps/wcm/Manifest b/gui-apps/wcm/Manifest
new file mode 100644
index 000000000000..9697512b3c35
--- /dev/null
+++ b/gui-apps/wcm/Manifest
@@ -0,0 +1,4 @@
+DIST wcm-0.4.0.tar.gz 263841 BLAKE2B 28cdf87c479cc7a4a5a40f17a1ec26688bae6a0cd5699b51ad7db2adca89946d7687ae345a7a82d71464df413c956aceeb3db8195c5b40da5f32043821883c49 SHA512 4136ceba90c054165b4b0e7a79d78af827d8b8ddb8b54820bda0c17bbaa28eb74981ce94d8c386b91257ca023a34f76f121a003229365afe72d65323f0a1d2cd
+EBUILD wcm-0.4.0.ebuild 809 BLAKE2B 5d1839a58cd7e5656cc55a4e7bd5aaedfe9a1280bf9ef33aa3fb61db21becb399c82ff5a8a9de12fc5864f48dd15dbabd31a6546c0f7d1782cd58e44758f0586 SHA512 da66001149e2d726fd1a348e505cdad3776ea737f9de355b83ceb64dc4cb190c43055f2ed3263efa84a59882c343949abd8bc4e932b26aba801a0098996bfd50
+EBUILD wcm-9999.ebuild 809 BLAKE2B 5d1839a58cd7e5656cc55a4e7bd5aaedfe9a1280bf9ef33aa3fb61db21becb399c82ff5a8a9de12fc5864f48dd15dbabd31a6546c0f7d1782cd58e44758f0586 SHA512 da66001149e2d726fd1a348e505cdad3776ea737f9de355b83ceb64dc4cb190c43055f2ed3263efa84a59882c343949abd8bc4e932b26aba801a0098996bfd50
+MISC metadata.xml 581 BLAKE2B 4c7238f4d651f521902f319da41b18b58d40a2db7e9c22f4084939fa0e70d534a7f112985de5f092c7f233f7891b50d17155b22781b32491f40c8d10f92c07a6 SHA512 a0b43b1632468feb2dd7b52fb34ce7f7c0bb8b0d8bf1952fc4e95017b0f7c8139451c78264966edab146cc3b8c255bc6724f4f7bb80479d5f119e6bbbda4fe2d
diff --git a/gui-apps/wcm/metadata.xml b/gui-apps/wcm/metadata.xml
new file mode 100644
index 000000000000..692d4fe3fd2e
--- /dev/null
+++ b/gui-apps/wcm/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ GUI front end to the wayfire config manager.
+ Allows to reload changes on the fly without
+ needing to restart wayfire.
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-apps/wcm/wcm-0.4.0.ebuild b/gui-apps/wcm/wcm-0.4.0.ebuild
new file mode 100644
index 000000000000..8178a3b0d885
--- /dev/null
+++ b/gui-apps/wcm/wcm-0.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ ~gui-wm/wayfire-${PV}[debug=]
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile() {
+ local emesonargs=""
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
new file mode 100644
index 000000000000..8178a3b0d885
--- /dev/null
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ ~gui-wm/wayfire-${PV}[debug=]
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile() {
+ local emesonargs=""
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}