summaryrefslogtreecommitdiff
path: root/gui-apps
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/Manifest.gzbin1881 -> 2375 bytes
-rw-r--r--gui-apps/kanshi/Manifest4
-rw-r--r--gui-apps/kanshi/kanshi-1.1.0.ebuild43
-rw-r--r--gui-apps/kanshi/kanshi-9999.ebuild43
-rw-r--r--gui-apps/kanshi/metadata.xml22
-rw-r--r--gui-apps/wcm/Manifest4
-rw-r--r--gui-apps/wcm/metadata.xml17
-rw-r--r--gui-apps/wcm/wcm-0.4.0.ebuild46
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild46
-rw-r--r--gui-apps/wf-shell/Manifest4
-rw-r--r--gui-apps/wf-shell/metadata.xml18
-rw-r--r--gui-apps/wf-shell/wf-shell-0.4.0.ebuild49
-rw-r--r--gui-apps/wf-shell/wf-shell-9999.ebuild49
13 files changed, 345 insertions, 0 deletions
diff --git a/gui-apps/Manifest.gz b/gui-apps/Manifest.gz
index 7b71e0d942c6..fb413cd74b53 100644
--- a/gui-apps/Manifest.gz
+++ b/gui-apps/Manifest.gz
Binary files differ
diff --git a/gui-apps/kanshi/Manifest b/gui-apps/kanshi/Manifest
new file mode 100644
index 000000000000..aae09a6baf9f
--- /dev/null
+++ b/gui-apps/kanshi/Manifest
@@ -0,0 +1,4 @@
+DIST kanshi-1.1.0.tar.gz 15884 BLAKE2B 1085e9d8f3ff53f78cb248941269713fd7ea38c60ad0e9816acb902f171b6f945af521a3835fc9db479620e6031483f6dbab5cfc507872dcabdfbcf9d6711269 SHA512 6582bae7b73ad13cad83e4d537c7c870699a72bf6993becaafa47a3dd70439a3c626ffff4874c8f737b32b62ad7512772c2c3bf54ac2cb74879213bd40b8d7a1
+EBUILD kanshi-1.1.0.ebuild 817 BLAKE2B 1a51aef77f13910c4d083209df702f02a2f51c488f1e91dd15745116ada7e0c63cf6cc7b02d554577e73938950bc9177906b649c04151f40d3ac969ea1b09c85 SHA512 8090432f3ad0e3291b8d2615b620e9d7e838b25b8bacadc05c3171d29f1435e0b61f737af5640853cf5987c1d2a7d61ab7af659a9459385e472a5a787d257014
+EBUILD kanshi-9999.ebuild 817 BLAKE2B 1a51aef77f13910c4d083209df702f02a2f51c488f1e91dd15745116ada7e0c63cf6cc7b02d554577e73938950bc9177906b649c04151f40d3ac969ea1b09c85 SHA512 8090432f3ad0e3291b8d2615b620e9d7e838b25b8bacadc05c3171d29f1435e0b61f737af5640853cf5987c1d2a7d61ab7af659a9459385e472a5a787d257014
+MISC metadata.xml 704 BLAKE2B ba26243d3417e1c46f674a0eeff81560833c9ce78f8a3c4d48e8b98f759a6080c40083a045bb03feae74c19b8ec8f2f0ff584e2c51e0b437f6f3d068b8a70843 SHA512 85145bd2e7f8d83c7d7dd77c0d8f4e396e1b987bcb176153527f62f8bfd96b98536a3627d01ecd52401dc26734bc5125913139f5defac7421b59fe30fd90a97a
diff --git a/gui-apps/kanshi/kanshi-1.1.0.ebuild b/gui-apps/kanshi/kanshi-1.1.0.ebuild
new file mode 100644
index 000000000000..221a5f5f59ed
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://github.com/emersion/kanshi"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/kanshi"
+else
+ SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+RDEPEND="
+ dev-libs/wayland
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/kanshi/kanshi-9999.ebuild b/gui-apps/kanshi/kanshi-9999.ebuild
new file mode 100644
index 000000000000..221a5f5f59ed
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://github.com/emersion/kanshi"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/kanshi"
+else
+ SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+RDEPEND="
+ dev-libs/wayland
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/kanshi/metadata.xml b/gui-apps/kanshi/metadata.xml
new file mode 100644
index 000000000000..170a33a029b3
--- /dev/null
+++ b/gui-apps/kanshi/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ <description>Proxy-maintainer, assign bugs</description>
+ </maintainer>
+ <longdescription>
+ kanshi allows you to define output profiles that are
+ automatically enabled and disabled on hotplug.
+ For instance, this can be used to turn a laptop's
+ internal screen off when docked.
+ </longdescription>
+ <use>
+ <flag name="man">build and install man pages</flag>
+ </use>
+</pkgmetadata>
diff --git a/gui-apps/wcm/Manifest b/gui-apps/wcm/Manifest
new file mode 100644
index 000000000000..9697512b3c35
--- /dev/null
+++ b/gui-apps/wcm/Manifest
@@ -0,0 +1,4 @@
+DIST wcm-0.4.0.tar.gz 263841 BLAKE2B 28cdf87c479cc7a4a5a40f17a1ec26688bae6a0cd5699b51ad7db2adca89946d7687ae345a7a82d71464df413c956aceeb3db8195c5b40da5f32043821883c49 SHA512 4136ceba90c054165b4b0e7a79d78af827d8b8ddb8b54820bda0c17bbaa28eb74981ce94d8c386b91257ca023a34f76f121a003229365afe72d65323f0a1d2cd
+EBUILD wcm-0.4.0.ebuild 809 BLAKE2B 5d1839a58cd7e5656cc55a4e7bd5aaedfe9a1280bf9ef33aa3fb61db21becb399c82ff5a8a9de12fc5864f48dd15dbabd31a6546c0f7d1782cd58e44758f0586 SHA512 da66001149e2d726fd1a348e505cdad3776ea737f9de355b83ceb64dc4cb190c43055f2ed3263efa84a59882c343949abd8bc4e932b26aba801a0098996bfd50
+EBUILD wcm-9999.ebuild 809 BLAKE2B 5d1839a58cd7e5656cc55a4e7bd5aaedfe9a1280bf9ef33aa3fb61db21becb399c82ff5a8a9de12fc5864f48dd15dbabd31a6546c0f7d1782cd58e44758f0586 SHA512 da66001149e2d726fd1a348e505cdad3776ea737f9de355b83ceb64dc4cb190c43055f2ed3263efa84a59882c343949abd8bc4e932b26aba801a0098996bfd50
+MISC metadata.xml 581 BLAKE2B 4c7238f4d651f521902f319da41b18b58d40a2db7e9c22f4084939fa0e70d534a7f112985de5f092c7f233f7891b50d17155b22781b32491f40c8d10f92c07a6 SHA512 a0b43b1632468feb2dd7b52fb34ce7f7c0bb8b0d8bf1952fc4e95017b0f7c8139451c78264966edab146cc3b8c255bc6724f4f7bb80479d5f119e6bbbda4fe2d
diff --git a/gui-apps/wcm/metadata.xml b/gui-apps/wcm/metadata.xml
new file mode 100644
index 000000000000..692d4fe3fd2e
--- /dev/null
+++ b/gui-apps/wcm/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ GUI front end to the wayfire config manager.
+ Allows to reload changes on the fly without
+ needing to restart wayfire.
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-apps/wcm/wcm-0.4.0.ebuild b/gui-apps/wcm/wcm-0.4.0.ebuild
new file mode 100644
index 000000000000..8178a3b0d885
--- /dev/null
+++ b/gui-apps/wcm/wcm-0.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ ~gui-wm/wayfire-${PV}[debug=]
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile() {
+ local emesonargs=""
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
new file mode 100644
index 000000000000..8178a3b0d885
--- /dev/null
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ ~gui-wm/wayfire-${PV}[debug=]
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile() {
+ local emesonargs=""
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}
diff --git a/gui-apps/wf-shell/Manifest b/gui-apps/wf-shell/Manifest
new file mode 100644
index 000000000000..0b2d0c30b8f5
--- /dev/null
+++ b/gui-apps/wf-shell/Manifest
@@ -0,0 +1,4 @@
+DIST wf-shell-0.4.0.tar.xz 8996656 BLAKE2B 609668bcf00fcc7a0b8142d84a7101f07578c2d6a88616da286a615076372e5a356387cf5e3fdee9b4aba6f027d8d081a5cce32f7f00682a756d4ee9bc46916d SHA512 1b293ce3fc2b12acbadb75e0de28217ed24f733e26d7ad12ada9a5f0673df911e75eea5af6841c466f031151f881a8e36dda229ea4dc2f91825e2e6df42d4903
+EBUILD wf-shell-0.4.0.ebuild 939 BLAKE2B 929f80d9d5fa3aa90e5a4e2d2f9f4b3aeea17fd741c209ab56d0c338d722bcadd2ce576bfa58da9ece29055decb064a826d874e7d888f6a2ecd28c48f03fd56d SHA512 17c67b6f3386a5a02619c42007822eba9833681a6be347c7204bad5038cd27b540416fdd7ab8ca322898c929214986ca127df4e56db159f69779dd125307ade5
+EBUILD wf-shell-9999.ebuild 939 BLAKE2B 929f80d9d5fa3aa90e5a4e2d2f9f4b3aeea17fd741c209ab56d0c338d722bcadd2ce576bfa58da9ece29055decb064a826d874e7d888f6a2ecd28c48f03fd56d SHA512 17c67b6f3386a5a02619c42007822eba9833681a6be347c7204bad5038cd27b540416fdd7ab8ca322898c929214986ca127df4e56db159f69779dd125307ade5
+MISC metadata.xml 653 BLAKE2B 537544446f8e320beafd02fe766de2c3ff66225aba3f69b852484f5251c3c1caeb68cd50d29e036ec96167b336bc9599319fcf324e7f9ecfaa9ddeee4bb52c67 SHA512 a8d332a80f7355424abd6f5b588c8cc9ef0f84bacea3c29b50bb56735d5c1b1753bc94c72737918152bdc6241ce90e8105f4da4bea5cc9a7f94c658d833a08cc
diff --git a/gui-apps/wf-shell/metadata.xml b/gui-apps/wf-shell/metadata.xml
new file mode 100644
index 000000000000..1f968932aa5f
--- /dev/null
+++ b/gui-apps/wf-shell/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Basic desktop environment for use with wayfire
+ which showcases all its plugins and desktop
+ effects. Integrates with other wayland
+ applications to provide a full desktop environment
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-apps/wf-shell/wf-shell-0.4.0.ebuild b/gui-apps/wf-shell/wf-shell-0.4.0.ebuild
new file mode 100644
index 000000000000..9167682d0b61
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+pulseaudio debug"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0=[wayland]
+ dev-libs/gobject-introspection
+ ~gui-wm/wayfire-${PV}
+ >=gui-libs/gtk-layer-shell-0.1
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ )
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}
diff --git a/gui-apps/wf-shell/wf-shell-9999.ebuild b/gui-apps/wf-shell/wf-shell-9999.ebuild
new file mode 100644
index 000000000000..9167682d0b61
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+pulseaudio debug"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0=[wayland]
+ dev-libs/gobject-introspection
+ ~gui-wm/wayfire-${PV}
+ >=gui-libs/gtk-layer-shell-0.1
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ )
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}