summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7912 -> 7908 bytes
-rw-r--r--games-util/linux-wbfs-manager/Manifest3
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild43
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild51
-rw-r--r--games-util/xboxdrv/Manifest5
-rw-r--r--games-util/xboxdrv/files/xboxdrv-0.8.8-Update-SConstruct-to-python3.patch79
-rw-r--r--games-util/xboxdrv/files/xboxdrv-0.8.8-Updating-python-code-to-python3.patch238
-rw-r--r--games-util/xboxdrv/files/xboxdrv-0.8.8-some-boost-fix.patch12
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.8_p20190118-r1.ebuild76
9 files changed, 423 insertions, 84 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index da21f5ec4a01..bdd4c202e308 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/linux-wbfs-manager/Manifest b/games-util/linux-wbfs-manager/Manifest
index 814f8627fb46..35745b3767b4 100644
--- a/games-util/linux-wbfs-manager/Manifest
+++ b/games-util/linux-wbfs-manager/Manifest
@@ -1,4 +1,3 @@
DIST linux-wbfs-manager-0.1.12.tar.gz 34251 BLAKE2B 57a3e5c405318ab128455455e6e45fb58b397c6b3135d97b54642569b26fd9f388d65250723818795fc310704afb59db7a682dbcaaea9c26e113bf0a28998e5d SHA512 58ac4d110e27123d04261d618df8734a0471bcad63171025aa4766a73bcc4a9240fceec59b1ba91fff71230e98f57b5fdd12390d380dc0c41d08740b7076bf6f
-EBUILD linux-wbfs-manager-0.1.12.ebuild 885 BLAKE2B c532d4dab9a898b3201b232e8db19e388bfa2674a224325332bfbc21e50bef187dc11b5ef8aec8ffcebe388211dcd8c38a6f178f6ef9183cb2edbfacb9d773ce SHA512 6b89eaf4fa7d97b52368ca0f5fd6cef7c925137f1262b3bd20060487fac4715db85efaf3e327c41a444e2e1907bfb5fc242c1f88333de421f8f2333ee13adce2
-EBUILD linux-wbfs-manager-9999.ebuild 885 BLAKE2B c532d4dab9a898b3201b232e8db19e388bfa2674a224325332bfbc21e50bef187dc11b5ef8aec8ffcebe388211dcd8c38a6f178f6ef9183cb2edbfacb9d773ce SHA512 6b89eaf4fa7d97b52368ca0f5fd6cef7c925137f1262b3bd20060487fac4715db85efaf3e327c41a444e2e1907bfb5fc242c1f88333de421f8f2333ee13adce2
+EBUILD linux-wbfs-manager-0.1.12.ebuild 704 BLAKE2B cecc2a1fa975aab6b1d1bc52583d3bde944fdbce47e6485c0980947c6fcd4cbec2d8178c48a4bae215093060904a1e361367b483eb11a27f342b230ada6c12be SHA512 e14351d2197187057456cd8290e503adedcaf7f91395df5d59a9b063abee6d2ae7b6eaa2d4b3c1bedeed640e061837a9fc1618ae261e41def9dc429f07a3de05
MISC metadata.xml 341 BLAKE2B 6dfa68b48d7d834af0a719e930d49fca895d7f929780e087882b9e5889ab492f02ad3f3ebaa990e4c995b80ef43e714fce299ff16181426138dcbe5fe1a6c211 SHA512 46913ec989d81928c2faf97ef1a4e57e19f412189b9acf6de875fea5a9615e808dde58ad29df401fa8d125dd1be232f76800dd2497c60a160db752a13f2ff8cd
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
index c94ba9084a1f..aba85f691454 100644
--- a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
@@ -1,45 +1,24 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit toolchain-funcs
-
-if [[ "${PV}" == "9999" ]]; then
- ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
- inherit subversion
- SRC_URI=""
-else
- SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi;
+inherit desktop toolchain-funcs
DESCRIPTION="WBFS manager for Linux using GTK+"
HOMEPAGE="https://code.google.com/p/linux-wbfs-manager/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/linux-wbfs-manager/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
+KEYWORDS="~amd64 ~x86"
-RDEPEND="dev-libs/glib:2
+RDEPEND="
+ dev-libs/glib:2
gnome-base/libglade:2.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-if [[ ${PV} == "9999" ]] ; then
- S=${WORKDIR}/${ECVS_MODULE}
-else
- S=${WORKDIR}/${PN}
-fi
-
-src_unpack() {
- if [[ ${PV} == "9999" ]]; then
- subversion_src_unpack
- else
- default
- fi
-}
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_compile() {
emake CC="$(tc-getCC)"
@@ -47,5 +26,7 @@ src_compile() {
src_install() {
dobin wbfs_gtk
- dodoc README
+ einstalldocs
+
+ make_desktop_entry wbfs_gtk "WBFS manager" applications-utilities
}
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
deleted file mode 100644
index c94ba9084a1f..000000000000
--- a/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit toolchain-funcs
-
-if [[ "${PV}" == "9999" ]]; then
- ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
- inherit subversion
- SRC_URI=""
-else
- SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi;
-
-DESCRIPTION="WBFS manager for Linux using GTK+"
-HOMEPAGE="https://code.google.com/p/linux-wbfs-manager/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND="dev-libs/glib:2
- gnome-base/libglade:2.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-if [[ ${PV} == "9999" ]] ; then
- S=${WORKDIR}/${ECVS_MODULE}
-else
- S=${WORKDIR}/${PN}
-fi
-
-src_unpack() {
- if [[ ${PV} == "9999" ]]; then
- subversion_src_unpack
- else
- default
- fi
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- dobin wbfs_gtk
- dodoc README
-}
diff --git a/games-util/xboxdrv/Manifest b/games-util/xboxdrv/Manifest
index a2236d7a99ff..920d2aaf60b4 100644
--- a/games-util/xboxdrv/Manifest
+++ b/games-util/xboxdrv/Manifest
@@ -1,8 +1,13 @@
AUX org.seul.Xboxdrv.conf 247 BLAKE2B 0829d1e65203f56efc0442c798070cf8c9f6b53792b5eb4fd8cc0671068d5d66d281b2c53c5cdb06474b635c2c9c5076d3a64364afdffc87a0c1bf052015f9ff SHA512 1416e80d326481e224ce3381a8feeacf304107f945d787183c74118aae955e191cc89269e8de44d6ce4efc2502def6957b690e9bad70072fcf0bbd47c8ab12cc
+AUX xboxdrv-0.8.8-Update-SConstruct-to-python3.patch 3026 BLAKE2B 344ccb6c567b2ec775bc0cee5562595343ba8baf636a83a7aa841a18c3ec87330832b22661d8d6f100cf20666bc41de9b3fe5823589120e8c27b4742a6407c01 SHA512 91fee5305e55e6158b9ab2198376d84bdff30b3114f4e7c0185d67cf1c6e127d7101bebf80a39adb8d855fdcc25cf08ba9d7a061d25ce7aa6c8a3f3abe686d22
+AUX xboxdrv-0.8.8-Updating-python-code-to-python3.patch 8610 BLAKE2B a92e10e0695c3d271fe40a82f24630c6e09cfce77a3c7064915779f73ceff2dfa3454c7f39d3255f8c9d3436e8657db2f55b1051ab17b58636969f438cf43a80 SHA512 50ef61511e2fd4496015ba8058845bb0e011380445d64ffa5f05988e6a049445b9ddae6e5c60cdd13b8257480a68d2ad5757efceeb40b444aa5b17ce09082a50
+AUX xboxdrv-0.8.8-some-boost-fix.patch 322 BLAKE2B 18a26c6ae89b62cbd261da2f9baa79972587e082beac67854f37d903f29af65cbe39cf24bd81451eeff276453cd04efa5cf8f49f4c18d2cc244e10cf92d12591 SHA512 f698b86ace7558a4a8646826ede09c5a2fc931cd6745741f2abeaa59488b5e3666cc5d839819eade4c350f7a354421e46a06d8cb83041a0ef575b1674a6842b7
AUX xboxdrv.confd 211 BLAKE2B 7a79059b29edbfbde33fe3daf9c89346246ac4323d7053ea4b26b6dd1fff07d731f8f7faa6a79f152f76eb1722606655f1d8d1026a3a83b0520e1909915039db SHA512 4c8a784a18979746a45653244e451fe1ba9e7cbb14301cc18f58e474e51f7569177364c5a96cbe0275db2b359424febd27c040ede5820148aadb80e90ebf8178
AUX xboxdrv.initd 446 BLAKE2B f78cf4af5cca703efc0a480c2ba34b0189d2b86a64aa89533e59a4d325ca03592bc911a9c85ff1fe5801ef2ade537dcfcc7266052a77f64ff05dad5f43630167 SHA512 e87d4b4b4313cb4ae983aef4ab7fa799f6b466e0f504eb15905b82f5b8bca2f0ff6f3d9a7d9963c048b6189e2a4c4b862a3f39d4201c2f5f02234362ad7b3af1
AUX xboxdrv.service 371 BLAKE2B afd5f5397f4ae15af69d8e12865201fe159691ba2a36c00fe207304afe5126814fafd0394e7618e9f4d27611bd2c0dd7371717c7a07a57d27c3a4ab8e6e40140 SHA512 80e7657edae9c771740628ef5f9752b79d50288ead33afe97e71ffc6e7d7c24343eeb213668cdc823b28742976e2e56f4defdcd823716897f3262be1fc7832e9
AUX xboxdrv.udev-rules 251 BLAKE2B 5a3af6d378b2d6ad5bb2da0dfa356c6939a274b194f075281bbfc3dcaee1c5b9fc63740bbfec2ecd0c8245065262a0449c47fad6c522e4773ef2e193018dc95f SHA512 131c90bee6ac4da5e3d51c7212abb362a540092db97af56332cdfe14e836c84c97727823462ea378da6e5544fda2fb4d36fbe00b6210e5663316f914eaa3f4ad
DIST xboxdrv-0.8.8_p20190118.tar.gz 322541 BLAKE2B ffa1021f974414ab9efebccf89e8be9137647ba7e1adf3bc9dad3b17b362b340f087fdac42c9b91a29a4cfe13295df6d3861fe953d9f96e80df08d4a6b1ce754 SHA512 ede650090c67642dc4729acc37630ae807f354d76f9bf31e23357668b6ae2b8d0261d2cf6e33090ab2120083b0664332dab22f1ed682bcdcbf1cac88b97e67af
+DIST xboxdrv-v0.8.8.tar.bz2 268046 BLAKE2B 3092a0e1e1cf1ee351879e791212445c567772f4115eb09eeb0c28bc1692b1951837ae7f6488091eb57d06cd38edae4e964502524606370f1ccd8fc39b307db8 SHA512 9b90f866ab322aaf3223215c78120a7aeacb56970fedf2e603f14704bd517b8316a3e28edb6a75e1a47729e9ced4cde5cac3a2f7a95d8514b83219b8821eb9db
+EBUILD xboxdrv-0.8.8_p20190118-r1.ebuild 1604 BLAKE2B 49b8bc3711a61018dbf581837b0a6753920f330d798289c8e8fda8863506b4d4fc90046b44d5e564a5ea00f7b55647140fb6c42396ed3b02b974554594aa8737 SHA512 6e77f68b5c0e969632981272cefc7768d61b2624d5c4604c16e4536c30a31bace8a58957d329f65ff4dfccfbcf55375acbbec3cf474cddc95613c45890797dcf
EBUILD xboxdrv-0.8.8_p20190118.ebuild 1590 BLAKE2B 49311695c45790b0eea211b88441f94dfc6b5782f6eb864ae5596db92cf79db9701f6333ffe162d10b7b9a8b8642ddee432bcc7fba30df40973a0610728469c9 SHA512 ce9195afe11dab928897142f14a534b0e625ef7342e1e8e2ea4259fcc6105431ac1a771e138eb1d83160ee2fd90c7e4e9bb781724e59b7d846d5f13549bd6cd2
MISC metadata.xml 393 BLAKE2B d8177cd12ab0e79dc748743bcaad99dd9bb77542703bbac6040af639e191f2fca4356d0edef80b7d21c7b8c27c269b3e1fe04f03ea8d725ab86920c08394f310 SHA512 e8913486c54693f734d541a4f1f72bc1b29adc9e4de3b8b9c16d657082643f256d87d6888ef7e6dd63f540106f96a9a0fe90aef8334629b73ef75b607709c33d
diff --git a/games-util/xboxdrv/files/xboxdrv-0.8.8-Update-SConstruct-to-python3.patch b/games-util/xboxdrv/files/xboxdrv-0.8.8-Update-SConstruct-to-python3.patch
new file mode 100644
index 000000000000..accb4317fad4
--- /dev/null
+++ b/games-util/xboxdrv/files/xboxdrv-0.8.8-Update-SConstruct-to-python3.patch
@@ -0,0 +1,79 @@
+From 39a334fbc0482626455f417e97308e52aa8746a7 Mon Sep 17 00:00:00 2001
+From: Ingo Ruhnke <grumbel@gmail.com>
+Date: Sun, 24 Nov 2019 18:16:16 +0100
+Subject: [PATCH 1/3] Update SConstruct to python3
+
+---
+ SConstruct | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+diff --git SConstruct SConstruct
+index 4cd7970..54fa11f 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -15,7 +15,7 @@ def build_dbus_glue(target, source, env):
+ "--mode=glib-server",
+ "--prefix=" + env['DBUS_PREFIX'], source[0].get_path()],
+ stdout=subprocess.PIPE).communicate()[0]
+-
++ xml = xml.decode()
+ xml = re.sub(r"callback = \(([A-Za-z_]+)\) \(marshal_data \? marshal_data : cc->callback\);",
+ r"union { \1 fn; void* obj; } conv;\n "
+ "conv.obj = (marshal_data ? marshal_data : cc->callback);\n "
+@@ -29,14 +29,14 @@ def build_bin2h(target, source, env):
+ Takes a list of files and converts them into a C source that can be included
+ """
+ def c_escape(str):
+- return str.translate(string.maketrans("/.-", "___"))
++ return str.translate(str.maketrans("/.-", "___"))
+
+- print target
+- print source
++ print(target)
++ print(source)
+ with open(target[0].get_path(), "w") as fout:
+ fout.write("// autogenerated by scons Bin2H builder, do not edit by hand!\n\n")
+
+- if env.has_key("BIN2H_NAMESPACE"):
++ if "BIN2H_NAMESPACE" in env:
+ fout.write("namespace %s {\n\n" % env["BIN2H_NAMESPACE"])
+
+ # write down data
+@@ -45,8 +45,8 @@ def build_bin2h(target, source, env):
+ data = fin.read()
+ fout.write("// \"%s\"\n" % src.get_path())
+ fout.write("const char %s[] = {" % c_escape(src.get_path()))
+- bytes_arr = ["0x%02x" % ord(c) for c in data]
+- for i in xrange(len(bytes_arr)):
++ bytes_arr = ["0x%02x" % c for c in data]
++ for i in range(len(bytes_arr)):
+ if i % 13 == 0:
+ fout.write("\n ")
+ fout.write(bytes_arr[i])
+@@ -62,7 +62,7 @@ def build_bin2h(target, source, env):
+ for src in source], ",\n"))
+ fout.write("\n}\n\n")
+
+- if env.has_key("BIN2H_NAMESPACE"):
++ if "BIN2H_NAMESPACE" in env:
+ fout.write("} // namespace %s\n\n" % env["BIN2H_NAMESPACE"])
+
+ fout.write("/* EOF */\n")
+@@ -131,12 +131,12 @@ env.Append(CPPDEFINES = { 'PACKAGE_VERSION': "'\"%s\"'" % package_version })
+ conf = Configure(env)
+
+ if not conf.env['CXX']:
+- print "g++ must be installed!"
++ print("g++ must be installed!")
+ Exit(1)
+
+ # X11 checks
+ if not conf.CheckLibWithHeader('X11', 'X11/Xlib.h', 'C++'):
+- print 'libx11-dev must be installed!'
++ print('libx11-dev must be installed!')
+ Exit(1)
+
+ env = conf.Finish()
+--
+2.29.0.rc1
+
diff --git a/games-util/xboxdrv/files/xboxdrv-0.8.8-Updating-python-code-to-python3.patch b/games-util/xboxdrv/files/xboxdrv-0.8.8-Updating-python-code-to-python3.patch
new file mode 100644
index 000000000000..139336affd90
--- /dev/null
+++ b/games-util/xboxdrv/files/xboxdrv-0.8.8-Updating-python-code-to-python3.patch
@@ -0,0 +1,238 @@
+From e37d3558a1a8a36fbc5d693c53893127a288fd02 Mon Sep 17 00:00:00 2001
+From: Ingo Ruhnke <grumbel@gmail.com>
+Date: Sun, 24 Nov 2019 18:36:25 +0100
+Subject: [PATCH 3/3] Updating python code to python3
+
+---
+ examples/responsecurve-generator.py | 14 ++++-----
+ runxboxdrv/runxboxdrv | 46 ++++++++++++++---------------
+ xboxdrvctl | 8 ++---
+ 3 files changed, 34 insertions(+), 34 deletions(-)
+
+diff --git examples/responsecurve-generator.py examples/responsecurve-generator.py
+index c74e34d..942463b 100755
+--- a/examples/responsecurve-generator.py
++++ b/examples/responsecurve-generator.py
+@@ -1,14 +1,14 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ import sys
+ import string
+
+ if len(sys.argv) != 3:
+- print "Usage:", sys.argv[0], "STEPS", "EQUATION"
+- print "Simple generator for generating responsecurve data from equations."
+- print ""
+- print "Example:"
+- print " ", sys.argv[0], "6 i**2"
++ print("Usage:", sys.argv[0], "STEPS", "EQUATION")
++ print("Simple generator for generating responsecurve data from equations.")
++ print("")
++ print("Example:")
++ print(" ", sys.argv[0], "6 i**2")
+ else:
+ steps = int(sys.argv[1])
+ equation = sys.argv[2]
+@@ -19,6 +19,6 @@ else:
+ left.reverse()
+ left = left[0:-1]
+
+- print string.join([str(x) for x in (left + right)], ":")
++ print(string.join([str(x) for x in (left + right)], ":"))
+
+ # EOF #
+diff --git runxboxdrv/runxboxdrv runxboxdrv/runxboxdrv
+index 360c836..6983496 100755
+--- a/runxboxdrv/runxboxdrv
++++ b/runxboxdrv/runxboxdrv
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # This program is free software: you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+ # the Free Software Foundation, either version 3 of the License, or
+@@ -409,7 +409,7 @@ class ProcessManager(object):
+ """
+ # Since reap() modifies __procs, we have to iterate over a copy
+ # of the keys in it. Thus, do not remove the .keys() call.
+- for procid in self.__procs.keys():
++ for procid in list(self.__procs.keys()):
+ self.reap(procid)
+
+
+@@ -445,7 +445,7 @@ import os, sys
+ import os.path
+ import fcntl
+ import time
+-import ConfigParser
++import configparser
+ from subprocess import check_call, Popen, PIPE
+ from signal import SIGINT, SIGKILL
+ from optparse import OptionParser
+@@ -482,7 +482,7 @@ class RunXBoxDrv(object):
+
+ @staticmethod
+ def runCommandAndGetOutput(command):
+- print command
++ print(command)
+ callcommand = Popen(command, shell=True, stdout=PIPE)
+ outputcommand = callcommand.communicate()
+ return outputcommand[0].split("\n")
+@@ -517,7 +517,7 @@ class RunXBoxDrv(object):
+ if RunXBoxDrv.which(RunXBoxDrv.sudo_command) is None:
+ raise Exception("Cannot find %s!" % RunXBoxDrv.sudo_command)
+ commandline = "%s %s" % (RunXBoxDrv.sudo_command, command)
+- print commandline
++ print(commandline)
+ callcommand = Popen(commandline, shell=True, stdout=PIPE)
+ outputcommand = callcommand.communicate()
+ return outputcommand[0]
+@@ -525,14 +525,14 @@ class RunXBoxDrv(object):
+ @staticmethod
+ def killExistingXBoxDrv(sig, signame):
+ for line in RunXBoxDrv.runCommandAndGetOutput("ps"):
+- print line
++ print(line)
+ fields = line.split()
+ if len(fields) < 4:
+ continue
+ pid = fields[0]
+ process = fields[3]
+ if process.find(XBOXDRVNAME) != -1:
+- print "Using %s on existing %s" % (signame, XBOXDRVNAME)
++ print("Using %s on existing %s" % (signame, XBOXDRVNAME))
+ os.kill(int(pid), sig)
+ return True
+ return False
+@@ -542,7 +542,7 @@ class RunXBoxDrv(object):
+ loadedmodules = []
+ unloadedmodules = []
+ for line in RunXBoxDrv.runCommandAndGetOutput("lsmod"):
+- print line
++ print(line)
+ fields = line.split()
+ if len(fields) < 3:
+ continue
+@@ -555,17 +555,17 @@ class RunXBoxDrv(object):
+ unloadedmodules.append(modulename)
+ for modulename in MODULELOAD:
+ if modulename in loadedmodules:
+- print "%s already loaded!" % modulename
++ print("%s already loaded!" % modulename)
+ else:
+- print "Loading %s!" % modulename
+- print RunXBoxDrv.runCommandAsRoot("modprobe %s" % modulename)
++ print("Loading %s!" % modulename)
++ print(RunXBoxDrv.runCommandAsRoot("modprobe %s" % modulename))
+
+ for modulename in MODULEUNLOAD:
+ if modulename in unloadedmodules:
+- print "Unloading %s!" % modulename
+- print RunXBoxDrv.runCommandAsRoot("rmmod %s" % modulename)
++ print("Unloading %s!" % modulename)
++ print(RunXBoxDrv.runCommandAsRoot("rmmod %s" % modulename))
+ else:
+- print "%s already unloaded!" % modulename
++ print("%s already unloaded!" % modulename)
+
+
+ @staticmethod
+@@ -579,11 +579,11 @@ class RunXBoxDrv(object):
+ raise Exception("Cannot find one of: %s!" % str(UINPUT_LOCATIONS))
+
+ if not os.access(location, os.W_OK):
+- print "Trying to change permissions of: %s" % location
+- print RunXBoxDrv.runCommandAsRoot("chmod 0660 %s" % location)
++ print("Trying to change permissions of: %s" % location)
++ print(RunXBoxDrv.runCommandAsRoot("chmod 0660 %s" % location))
+
+ if os.access(location, os.W_OK):
+- print "%s is writable!" % location
++ print("%s is writable!" % location)
+ else:
+ raise Exception("Could not set write permissions on %s" % location)
+
+@@ -614,36 +614,36 @@ class RunXBoxDrv(object):
+ out = ""
+ while out.lower().find(LOADEDTEXT) == -1:
+ out = RunXBoxDrv.getNext(myProc)
+- print out
++ print(out)
+
+ def process(self):
+ commandlist = [self.xboxdrvpath]
+
+ if self.configfile:
+ commandlist = commandlist + ["--config=%s" % self.configfile]
+- print commandlist
++ print(commandlist)
+ myProc = Process(commandlist)
+ with_timeout(1, self.checkLoaded, myProc)
+ if len(self.appandparams) == 0:
+ print("WARNING: No path to application specified!")
+ else:
+- print(self.appandparams)
++ print((self.appandparams))
+ check_call(self.appandparams)
+- print "Sending SIGINT"
++ print("Sending SIGINT")
+ myProc.kill(SIGINT)
+ try:
+ with_timeout(1, myProc.wait)
+ sys.exit(0)
+ except Timeout:
+ pass
+- print "Sending SIGINT again"
++ print("Sending SIGINT again")
+ myProc.kill(SIGINT)
+ try:
+ with_timeout(1, myProc.wait)
+ sys.exit(0)
+ except Timeout:
+ pass
+- print "Killing"
++ print("Killing")
+ myProc.terminate()
+
+ def main():
+diff --git xboxdrvctl xboxdrvctl
+index 4807a11..57177dc 100755
+--- a/xboxdrvctl
++++ b/xboxdrvctl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2
++#!/usr/bin/env python3
+
+ ## Xbox360 USB Gamepad Userspace Driver
+ ## Copyright (C) 2011 Ingo Ruhnke <grumbel@gmail.com>
+@@ -71,7 +71,7 @@ elif options.bus == "auto":
+ except dbus.exceptions.DBusException:
+ bus = dbus.SystemBus()
+ else:
+- print "Error: invalid argument to --bus. Must be 'auto', 'session, or 'system'"
++ print("Error: invalid argument to --bus. Must be 'auto', 'session, or 'system'")
+ exit()
+
+ if options.status:
+@@ -82,7 +82,7 @@ elif options.shutdown:
+ daemon.Shutdown()
+ else:
+ if (options.led or options.rumble or options.config) and options.slot == None:
+- print "Error: --slot argument required"
++ print("Error: --slot argument required")
+ exit()
+ else:
+ if options.slot != None:
+@@ -94,7 +94,7 @@ else:
+ if options.rumble:
+ m = re.match('^(\d+):(\d+)$', options.rumble)
+ if not m:
+- print "Error: invalid argument to --rumble"
++ print("Error: invalid argument to --rumble")
+ exit()
+ else:
+ left = int(m.group(1))
+--
+2.29.0.rc1
+
diff --git a/games-util/xboxdrv/files/xboxdrv-0.8.8-some-boost-fix.patch b/games-util/xboxdrv/files/xboxdrv-0.8.8-some-boost-fix.patch
new file mode 100644
index 000000000000..2063979fee4f
--- /dev/null
+++ b/games-util/xboxdrv/files/xboxdrv-0.8.8-some-boost-fix.patch
@@ -0,0 +1,12 @@
+diff -Naur a/src/controller_slot.cpp b/src/controller_slot.cpp
+--- a/src/controller_slot.cpp 2015-11-09 10:19:35.000000000 -0000
++++ b/src/controller_slot.cpp 2021-08-02 13:05:48.647684177 -0000
+@@ -69,7 +69,7 @@
+ bool
+ ControllerSlot::is_connected() const
+ {
+- return m_thread;
++ return m_thread.get();
+ }
+
+ /* EOF */
diff --git a/games-util/xboxdrv/xboxdrv-0.8.8_p20190118-r1.ebuild b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118-r1.ebuild
new file mode 100644
index 000000000000..c2ce54f034b1
--- /dev/null
+++ b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit linux-info python-any-r1 scons-utils toolchain-funcs systemd udev
+
+DESCRIPTION="Userspace Xbox 360 Controller driver"
+HOMEPAGE="https://xboxdrv.gitlab.io"
+SRC_URI="https://gitlab.com/xboxdrv/xboxdrv/-/archive/v0.8.8/xboxdrv-v0.8.8.tar.bz2"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ sys-apps/dbus
+ virtual/libudev:=
+ virtual/libusb:1
+ x11-libs/libX11
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/xboxdrv-v0.8.8"
+
+PATCHES=( "${FILESDIR}/"xboxdrv-0.8.8-some-boost-fix.patch
+ "${FILESDIR}/"xboxdrv-0.8.8-Update-SConstruct-to-python3.patch
+ "${FILESDIR}/"xboxdrv-0.8.8-Updating-python-code-to-python3.patch )
+
+CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python_setup
+}
+
+src_compile() {
+ escons \
+ BUILD=custom \
+ CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ CXXFLAGS="-Wall ${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xboxdrv
+ doman doc/xboxdrv.1
+ dodoc AUTHORS NEWS PROTOCOL README.md TODO
+
+ newinitd "${FILESDIR}"/xboxdrv.initd xboxdrv
+ newconfd "${FILESDIR}"/xboxdrv.confd xboxdrv
+
+ insinto /etc/dbus-1/system.d
+ doins "${FILESDIR}"/org.seul.Xboxdrv.conf
+
+ udev_newrules "${FILESDIR}"/xboxdrv.udev-rules 99-xbox-controller.rules
+ systemd_dounit "${FILESDIR}"/xboxdrv.service
+}
+
+pkg_postinst() {
+ udev_reload
+}