summaryrefslogtreecommitdiff
path: root/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild')
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild43
1 files changed, 12 insertions, 31 deletions
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
index c94ba9084a1f..aba85f691454 100644
--- a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
@@ -1,45 +1,24 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit toolchain-funcs
-
-if [[ "${PV}" == "9999" ]]; then
- ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
- inherit subversion
- SRC_URI=""
-else
- SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi;
+inherit desktop toolchain-funcs
DESCRIPTION="WBFS manager for Linux using GTK+"
HOMEPAGE="https://code.google.com/p/linux-wbfs-manager/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/linux-wbfs-manager/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
+KEYWORDS="~amd64 ~x86"
-RDEPEND="dev-libs/glib:2
+RDEPEND="
+ dev-libs/glib:2
gnome-base/libglade:2.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-if [[ ${PV} == "9999" ]] ; then
- S=${WORKDIR}/${ECVS_MODULE}
-else
- S=${WORKDIR}/${PN}
-fi
-
-src_unpack() {
- if [[ ${PV} == "9999" ]]; then
- subversion_src_unpack
- else
- default
- fi
-}
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_compile() {
emake CC="$(tc-getCC)"
@@ -47,5 +26,7 @@ src_compile() {
src_install() {
dobin wbfs_gtk
- dodoc README
+ einstalldocs
+
+ make_desktop_entry wbfs_gtk "WBFS manager" applications-utilities
}