summaryrefslogtreecommitdiff
path: root/dev-util/pahole
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pahole')
-rw-r--r--dev-util/pahole/Manifest2
-rw-r--r--dev-util/pahole/pahole-9999.ebuild28
2 files changed, 11 insertions, 19 deletions
diff --git a/dev-util/pahole/Manifest b/dev-util/pahole/Manifest
index b020843a2446..2ac66bf0c826 100644
--- a/dev-util/pahole/Manifest
+++ b/dev-util/pahole/Manifest
@@ -6,5 +6,5 @@ DIST pahole-1.24_p20221024-patches.tar.xz 22088 BLAKE2B b39458400411dd7da0f56825
EBUILD pahole-1.24_p20221024.ebuild 1693 BLAKE2B 3bafb0ab2e9278c0ff0f1af9f571311983d6545eae411b271e5bde9d5416d4f2c4dd5b671b291fccd0b03f6fbe5c99c92d620b6b91c1ae6edfb6f0b05e3f7b0e SHA512 0f9de7b39b1747e780322cf56e8a646e9980ee2dfcc4eecd2ea1d37dca369dae05c643a7be39898f0ef0264dd5a98890a600b282a7e1d759d0fc7c72fd8c4870
EBUILD pahole-1.25.ebuild 1700 BLAKE2B 12734f1ae26bed113c61cb05386a0c9e57b3fae8aeeb9c54b117ca8f15456a529e1d2cd5656000662917c4c07e46e32da0f8332c1577ff0c5ebf6bcc98c19b83 SHA512 1c3fc2ef434ee988ad79fca27163fc3fd645faabe45d2229e6bee4d23c38f0ec59ad4255b4604db1b321b871fef83573d70e889af859e58422fd8be8bfe8411c
EBUILD pahole-1.26.ebuild 1699 BLAKE2B bb9e555b23f0e59ba92d581234db077c8322d683c508363c1d85b485d0579bdf24818ce6d5fc180eb188c79df2acb3cc2dc56398a9d645585384395c8252c66f SHA512 4d0676ddd17feb8b744450b4258a8b39ec0f5d92252e6574cf4afce94b9f6bfd7ff9a7d86509e4cd9579240c4d4c317c686bfb4b2ea312921ede27ea52ce7859
-EBUILD pahole-9999.ebuild 1698 BLAKE2B 3f7a4d42fc08dd230544f946296cceded7e30ceb82bc2829b9bde7a24f87719812510c1d9d9292a03980442feb423c222ad3fa2c3f6713f146d1c9f466562701 SHA512 98e1827d57611960bf6d1e888d69c6f786c1d5280aa4fc683d6cf850f1a7c56254ace4de0118f73ef80f2caadbecf3f36392de91f4b92acdc318fef21af051ab
+EBUILD pahole-9999.ebuild 1519 BLAKE2B eafa78fe33f44043e333f2b554b0c0929c0548195de0f85e4073daeb703aacedd1d03c858fc7f85d870720d0c1d62e1a11fdcd89d98653b6900560a385511b5b SHA512 b0029fb308ba153bae71b96c31605e6ee2e92a49e9f27a6542a9b8ba540b2e79c99675df8703d8a1e1a002e4905eb176f575c0876a853aa7fad51d7a84505a6a
MISC metadata.xml 672 BLAKE2B 2178381434a5293df5a6a07a8c84c20a4f98d011c90ed2db911085639689224509445e16197ff88e0ab6fb7e6357bc96291feff21a44f350f51b1031e1882477 SHA512 2cd1f865e42bd845bb3831a1f6c8060e469e0afb3acbaaec2989018481a6f93e0fdae9afb74413c00db6967069cc6d0447548c3b4c238a70db07ee8786fe1e99
diff --git a/dev-util/pahole/pahole-9999.ebuild b/dev-util/pahole/pahole-9999.ebuild
index 62a62ec1aa61..aaef5d2f6e6c 100644
--- a/dev-util/pahole/pahole-9999.ebuild
+++ b/dev-util/pahole/pahole-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{9..12} )
inherit cmake python-single-r1
MY_PN=dwarves
-MY_P=${MY_PN}-${PV}
+MY_P=${MY_PN}-${PV%%_p*}
DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
@@ -15,30 +15,22 @@ HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/pahole/pahole.git"
inherit git-r3
-elif [[ ${PV} == *_p* ]] ; then
- # Snapshots
- #SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
-
- # Patch rollups from git format-patch. Sometimes there are important
- # fixes in git which haven't been released (and no release in sight).
- # Patch rollups are a bit better for understanding where changes have
- # come from for users.
- SRC_URI="
- http://fedorapeople.org/~acme/${MY_PN}/${MY_P%%_p*}.tar.xz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-patches.tar.xz
- "
- S="${WORKDIR}"/${MY_P%%_p*}
else
SRC_URI="http://fedorapeople.org/~acme/${MY_PN}/${MY_P}.tar.xz"
+ if [[ ${PV} == *_p* ]] ; then
+ # Patch rollups from git format-patch. Sometimes there are important
+ # fixes in git which haven't been released (and no release in sight).
+ # Patch rollups are a bit better for understanding where changes have
+ # come from for users.
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-patches.tar.xz"
+ fi
S="${WORKDIR}"/${MY_P}
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
fi
LICENSE="GPL-2" # only
SLOT="0"
IUSE="debug"
-if [[ ${PV} != 9999 ]] ; then
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-fi
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}