summaryrefslogtreecommitdiff
path: root/dev-util/pahole/pahole-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pahole/pahole-9999.ebuild')
-rw-r--r--dev-util/pahole/pahole-9999.ebuild28
1 files changed, 10 insertions, 18 deletions
diff --git a/dev-util/pahole/pahole-9999.ebuild b/dev-util/pahole/pahole-9999.ebuild
index 62a62ec1aa61..aaef5d2f6e6c 100644
--- a/dev-util/pahole/pahole-9999.ebuild
+++ b/dev-util/pahole/pahole-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{9..12} )
inherit cmake python-single-r1
MY_PN=dwarves
-MY_P=${MY_PN}-${PV}
+MY_P=${MY_PN}-${PV%%_p*}
DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
@@ -15,30 +15,22 @@ HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/pahole/pahole.git"
inherit git-r3
-elif [[ ${PV} == *_p* ]] ; then
- # Snapshots
- #SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
-
- # Patch rollups from git format-patch. Sometimes there are important
- # fixes in git which haven't been released (and no release in sight).
- # Patch rollups are a bit better for understanding where changes have
- # come from for users.
- SRC_URI="
- http://fedorapeople.org/~acme/${MY_PN}/${MY_P%%_p*}.tar.xz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-patches.tar.xz
- "
- S="${WORKDIR}"/${MY_P%%_p*}
else
SRC_URI="http://fedorapeople.org/~acme/${MY_PN}/${MY_P}.tar.xz"
+ if [[ ${PV} == *_p* ]] ; then
+ # Patch rollups from git format-patch. Sometimes there are important
+ # fixes in git which haven't been released (and no release in sight).
+ # Patch rollups are a bit better for understanding where changes have
+ # come from for users.
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-patches.tar.xz"
+ fi
S="${WORKDIR}"/${MY_P}
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
fi
LICENSE="GPL-2" # only
SLOT="0"
IUSE="debug"
-if [[ ${PV} != 9999 ]] ; then
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-fi
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}