summaryrefslogtreecommitdiff
path: root/dev-ruby/bindex/bindex-0.8.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bindex/bindex-0.8.1-r1.ebuild')
-rw-r--r--dev-ruby/bindex/bindex-0.8.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/bindex/bindex-0.8.1-r1.ebuild b/dev-ruby/bindex/bindex-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..7cd3b64f3f28
--- /dev/null
+++ b/dev-ruby/bindex/bindex-0.8.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/skiptrace/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/skiptrace/internal"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Bindings for your Ruby exceptions"
+HOMEPAGE="https://github.com/gsamokovarov/bindex"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' \
+ -e '/when/ s/ruby/rubyx/' \
+ -i Rakefile || die
+}