summaryrefslogtreecommitdiff
path: root/dev-ruby/bindex/bindex-0.8.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-ruby/bindex/bindex-0.8.1-r1.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-ruby/bindex/bindex-0.8.1-r1.ebuild')
-rw-r--r--dev-ruby/bindex/bindex-0.8.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/bindex/bindex-0.8.1-r1.ebuild b/dev-ruby/bindex/bindex-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..7cd3b64f3f28
--- /dev/null
+++ b/dev-ruby/bindex/bindex-0.8.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/skiptrace/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/skiptrace/internal"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Bindings for your Ruby exceptions"
+HOMEPAGE="https://github.com/gsamokovarov/bindex"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' \
+ -e '/when/ s/ruby/rubyx/' \
+ -i Rakefile || die
+}