summaryrefslogtreecommitdiff
path: root/dev-ros/visp_tracker/visp_tracker-0.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/visp_tracker/visp_tracker-0.12.1.ebuild')
-rw-r--r--dev-ros/visp_tracker/visp_tracker-0.12.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/visp_tracker/visp_tracker-0.12.1.ebuild b/dev-ros/visp_tracker/visp_tracker-0.12.1.ebuild
new file mode 100644
index 000000000000..81537d67935a
--- /dev/null
+++ b/dev-ros/visp_tracker/visp_tracker-0.12.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="noetic-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Wraps the ViSP moving edge tracker provided by the ViSP library"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads(+)]
+ dev-ros/dynamic_reconfigure
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/image_proc
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/resource_retriever
+ dev-ros/roscpp
+ dev-ros/sensor_msgs
+ dev-ros/tf[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
+ sci-libs/ViSP:=[opencv,X]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-noetic-${PV}/${ROS_SUBDIR}"
+fi
+PATCHES=( "${FILESDIR}/gcc6.patch" )