summaryrefslogtreecommitdiff
path: root/dev-ros/rosmaster/rosmaster-1.15.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosmaster/rosmaster-1.15.11.ebuild')
-rw-r--r--dev-ros/rosmaster/rosmaster-1.15.11.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosmaster/rosmaster-1.15.11.ebuild b/dev-ros/rosmaster/rosmaster-1.15.11.ebuild
new file mode 100644
index 000000000000..44c1207c39a0
--- /dev/null
+++ b/dev-ros/rosmaster/rosmaster-1.15.11.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Master implementation"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/defusedxml[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? ( $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]") )"