summaryrefslogtreecommitdiff
path: root/dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild')
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild
new file mode 100644
index 000000000000..a5642194ace7
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/PyQt5[gui,widgets,printsupport,\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}"