summaryrefslogtreecommitdiff
path: root/dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild')
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild
new file mode 100644
index 000000000000..a5642194ace7
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.4.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/PyQt5[gui,widgets,printsupport,\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}"