summaryrefslogtreecommitdiff
path: root/dev-ros/openni2_launch/openni2_launch-1.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/openni2_launch/openni2_launch-1.5.1.ebuild')
-rw-r--r--dev-ros/openni2_launch/openni2_launch-1.5.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/openni2_launch/openni2_launch-1.5.1.ebuild b/dev-ros/openni2_launch/openni2_launch-1.5.1.ebuild
new file mode 100644
index 000000000000..230a0150b089
--- /dev/null
+++ b/dev-ros/openni2_launch/openni2_launch-1.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-drivers/openni2_camera"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Launch files to start the openni2_camera drivers using rgbd_launch"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rgbd_launch
+ dev-ros/depth_image_proc
+ dev-ros/image_proc
+ dev-ros/nodelet
+ dev-ros/openni2_camera
+ dev-ros/tf
+ dev-ros/roslaunch
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ sys-apps/usbutils"