summaryrefslogtreecommitdiff
path: root/dev-ros/libmavconn/libmavconn-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/libmavconn/libmavconn-1.8.0.ebuild')
-rw-r--r--dev-ros/libmavconn/libmavconn-1.8.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/libmavconn/libmavconn-1.8.0.ebuild b/dev-ros/libmavconn/libmavconn-1.8.0.ebuild
new file mode 100644
index 000000000000..8f7b83354449
--- /dev/null
+++ b/dev-ros/libmavconn/libmavconn-1.8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink communication library"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/mavlink-gbp-release-2016.7.7
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"