summaryrefslogtreecommitdiff
path: root/dev-ros/genpy/genpy-0.6.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/genpy/genpy-0.6.16.ebuild')
-rw-r--r--dev-ros/genpy/genpy-0.6.16.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/genpy/genpy-0.6.16.ebuild b/dev-ros/genpy/genpy-0.6.16.ebuild
new file mode 100644
index 000000000000..e8cda9d3e500
--- /dev/null
+++ b/dev-ros/genpy/genpy-0.6.16.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/genpy"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Python ROS message and service generators"
+HOMEPAGE="https://wiki.ros.org/genpy"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyyaml[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )
+"
+PATCHES=( "${FILESDIR}/yaml.patch" )